El Foro

Getting Fallout 3 to work under Steam via POL

System: Ubuntu Trusty Thar 64-bit

Autor Respuestas
Jump to the page: 1 - 2
booman Wednesday 8 October 2014 at 1:48
booman

No problem.  If we can figure out what is wrong, maybe the devs will update the script so no one else has this problem


† Booman †
Mint 19.3 64-bit | Nvidia 440 | GeForce GTX 1060
Linux for Beginners | List of Linux Games | My Games
PlayOnLinux Guides | PlayOnLinux Explained
Ronin DUSETTE Thursday 9 October 2014 at 0:18
Ronin DUSETTE
Admin

We can't update the script until we isolate the problem. 

Are you sure that you have the 32 bit libraries for your system's graphics driver? Make sure. Also, you will want to install "multiarch-support", not "ia32-libs", as that one is not used anymore.

The intel graphics drivers are available directly from your distro. No need to use the Intel installer. Just make sure that you install the 32-bit libs for mesa and the intel drivers, and it should work. That is what it looks like to me, anyway. 

As for the script, I cannot personally test it, but I doubt that it is a script issue, considering we have not been getting reports of it not working, nor posts. It is most likely a missing lib on your system (and really, sometimes, the Intel stuff just does not play nice with certain games. You can try to upgrade your kernel for a higher-level of Intel supprt, but that is out of scope here.)

 

Delete the virtual drive, re-run the script, and when it crashes, post the debug log here. I am curious to see what the log looks like on a fresh, unadulterated install. 


Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
FMy1 Friday 12 June 2015 at 13:51
FMy1

I have a similar problem, a similar error :

Unhandled exception: page fault on read access to 0x00000000 in 32-bit code (0x00ad8cdb).

Except that I am not using the Steam installer, I installed fallout3 from the DVD. So this page fault is not a steam problem, I think.

Here is my entire log : http://sprunge.us/ZTbE

I am using gentoo x64, with USE=abi_x86_32 enabled (so I have all 32bit libraries installed).

My graphic card :

ego@trenzalore ~ $ lspci |grep VGA
00:02.0 VGA compatible controller: Intel Corporation 4th Gen Core Processor Integrated Graphics Controller (rev 06)

 

booman Friday 12 June 2015 at 18:19
booman

Did you use the "wineless" version of Wine?  Fallout 3 requires Games For Windows Live if you patch it.  Try playing first without the patch and see if it will launch.


† Booman †
Mint 19.3 64-bit | Nvidia 440 | GeForce GTX 1060
Linux for Beginners | List of Linux Games | My Games
PlayOnLinux Guides | PlayOnLinux Explained
Ronin DUSETTE Friday 12 June 2015 at 19:10
Ronin DUSETTE
Admin

I see a gang of sound-related errors in the debug logs. Stuff related to libmpg123, ALSA, libasound, and others. I would first make sure that all of your sound libs are installed correctly and that the 32-bit libs for those are installed. I would start with that. The Intel drivers are open source and already included with your system, but you would want to double-check for the 32-bit MesaGL libs, too. At least that is what I am thinking to check so far. It is something to start with. :)


Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
Ronin DUSETTE Friday 12 June 2015 at 19:14
Ronin DUSETTE
Admin

New version of Wine just came out. Has a fix for some stuff specifically for this game. Might be worth a shot:

https://www.winehq.org//announce/1.7.45

You should be able to get it from Tools -> Manage Wine Versions as soon as our WineBuilds system compiles and packages it (really, it should be any time now). I would switch the Wine version on that virtual drive to that version and see if that helps (there is a change that the GFWL patch may need to be built against this version, but I am not sure). 


Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
booman Friday 12 June 2015 at 19:50
booman

Ooh, good to know.... I haven't tested Fallout 3 in a long time


† Booman †
Mint 19.3 64-bit | Nvidia 440 | GeForce GTX 1060
Linux for Beginners | List of Linux Games | My Games
PlayOnLinux Guides | PlayOnLinux Explained
FMy1 Saturday 13 June 2015 at 9:18
FMy1

Hum…

The version of wine I used in my first post was the one embedded in PoL (1.3.26-xliveless2). The sound was fine in the menu, and the game crashed when loading a new game.

Now when I try to use the system's wine (wine-1.7.44), I get more audio errors in the log, the sound is actually wrong in the menu, and the game is crashing in the same moment (loading the first game).

New log : http://sprunge.us/WFeE

Edit :

I just tested with 1.7.45 from the PoL manager. The sound is still uggly (a litle less though), and same crash.

New log : http://sprunge.us/PONC

Edit 2 :

The mesa package is installed in both 32bit and 64bits versions :

[I] media-libs/mesa
     Available versions:  [M]7.10.3 10.2.8^d 10.3.7-r1^d (~)10.3.7-r2^d (~)10.4.6^d (~)10.5.4^d (~)10.5.5^d (~)10.5.6^d {bindist +classic d3d9 debug +dri3 +egl +gallium +gbm gles gles1 gles2 hardened (+)llvm motif +nptl opencl openmax openvg osmesa pax_kernel pic selinux +udev vaapi vdpau wayland xa xvmc ABI_MIPS="n32 n64 o32" ABI_PPC="32 64" ABI_S390="32 64" ABI_X86="32 64 x32" KERNEL="FreeBSD linux" VIDEO_CARDS="freedreno i915 i965 ilo intel mach64 mga nouveau r100 r128 r200 r300 r600 radeon radeonsi savage sis tdfx via vmware"}
     Installed versions:  10.5.6^d(09:43:58 PM 05/29/2015)(classic dri3 egl gallium gbm llvm nptl udev -bindist -d3d9 -debug -gles1 -gles2 -opencl -openmax -osmesa -pax_kernel -pic -selinux -vaapi -vdpau -wayland -xa -xvmc ABI_MIPS="-n32 -n64 -o32" ABI_PPC="-32 -64" ABI_S390="-32 -64" ABI_X86="32 64 -x32" KERNEL="-FreeBSD" VIDEO_CARDS="intel -freedreno -i915 -i965 -ilo -nouveau -r100 -r200 -r300 -r600 -radeon -radeonsi -vmware")
     Homepage:            http://mesa3d.sourceforge.net/
     Description:         OpenGL-like graphic library for Linux

(If you are not gentooist, ABI_X86="32 64 -x32" means that. The flags begining with minus are not enabled, and the ones without minus are enabled.).

Editado por: FMy1

Ronin DUSETTE Wednesday 17 June 2015 at 17:20
Ronin DUSETTE
Admin

It sounds like you need to mess with the buffer settings in Pulseaudio (as that is what it looks like you are using). I woulld stry this. 

https://wiki.archlinux.org/index.php/PulseAudio/Troubleshooting#Audio_quality

You will also need the 32-bit versions of libasound, alsa, libmpg123, and any other graphcis lib that Wine might want (here is a list: http://wiki.winehq.org/Recommended_Packages) and your graphics drivers (it looks like a lot of that stuff is missing from the bug report, but it can be hard to tell.). I would try the above fix to see if trying to optimize the Pulseaudio or ALSA buffer fixes the sound (for most people, it does). 


Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
booman Wednesday 17 June 2015 at 18:02
booman

I'm dealing with those stinking buffer issues in Wine right now.  Its so bad that Neverwinter crashes.
You can also edit:

/etc/pulse/daemon.conf

Add "5" to this line:

default-fragment-size-msec = 5

Save daemon.conf and restart Pulseaudio:

pulseaudio -k && pulseaudio --start


Also try installing pavucontrol and then running it in the terminal. You can configure the default audio output if you have multiple outputs

Editado por: booman


† Booman †
Mint 19.3 64-bit | Nvidia 440 | GeForce GTX 1060
Linux for Beginners | List of Linux Games | My Games
PlayOnLinux Guides | PlayOnLinux Explained