El Foro

POL Won't Run, Ubuntu 10.04

Autor Respuestas
animeforlaifu Sunday 30 August 2015 at 22:18
animeforlaifuAnonymous

Hi,

I downloaded POL 4.2.8 fine, it appeared to install fine, but when I click on the icon it doesn't open, and when I try to open it in the Terminal I get this:

sudo playonlinux
Looking for python... 2.6.5 - wxversion(s): 2.8-gtk2-unicode
Traceback (most recent call last):
  File "/usr/share/playonlinux/python/check_python.py", line 7, in <module>
    import wx
  File "/usr/lib/python2.6/dist-packages/wx-2.8-gtk2-unicode/wx/__init__.py", line 45, in <module>
    from wx._core import *
  File "/usr/lib/python2.6/dist-packages/wx-2.8-gtk2-unicode/wx/_core.py", line 4, in <module>
    import _core_
ImportError: /usr/lib/python2.6/dist-packages/wx-2.8-gtk2-unicode/wx/_core_.so: symbol _ZNK12wxWindowBase18WindowToClientSizeERK6wxSize, version WXU_2.8 not defined in file libwx_gtk2u_core-2.8.so.0 with link time reference
failed tests
Looking for python2.7...
Looking for python2.6... 2.6.5 - wxversion(s): 2.8-gtk2-unicode
Traceback (most recent call last):
  File "/usr/share/playonlinux/python/check_python.py", line 7, in <module>
    import wx
  File "/usr/lib/python2.6/dist-packages/wx-2.8-gtk2-unicode/wx/__init__.py", line 45, in <module>
    from wx._core import *
  File "/usr/lib/python2.6/dist-packages/wx-2.8-gtk2-unicode/wx/_core.py", line 4, in <module>
    import _core_
ImportError: /usr/lib/python2.6/dist-packages/wx-2.8-gtk2-unicode/wx/_core_.so: symbol _ZNK12wxWindowBase18WindowToClientSizeERK6wxSize, version WXU_2.8 not defined in file libwx_gtk2u_core-2.8.so.0 with link time reference
failed tests
Looking for python2... 2.6.5 - wxversion(s): 2.8-gtk2-unicode
Traceback (most recent call last):
  File "/usr/share/playonlinux/python/check_python.py", line 7, in <module>
    import wx
  File "/usr/lib/python2.6/dist-packages/wx-2.8-gtk2-unicode/wx/__init__.py", line 45, in <module>
    from wx._core import *
  File "/usr/lib/python2.6/dist-packages/wx-2.8-gtk2-unicode/wx/_core.py", line 4, in <module>
    import _core_
ImportError: /usr/lib/python2.6/dist-packages/wx-2.8-gtk2-unicode/wx/_core_.so: symbol _ZNK12wxWindowBase18WindowToClientSizeERK6wxSize, version WXU_2.8 not defined in file libwx_gtk2u_core-2.8.so.0 with link time reference
failed tests
Please install python before trying to run this program

But when I run the command "sudo apt-get install python-wxgtk2.8" I get the following:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
python-wxgtk2.8 is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

I typed in the command to see the Python version, and it said "Python 2.6.5".

I also went to /usr/local/bin, but I found nothing there. Regardless, I went to /usr/bin and copied "python" and "python2.6" (there was no "python 2.6-config" like it said on other websites) to /usr/local/bin, tried to run POL again, but still the same error. I really don't know what to do. Is it because Ubuntu 10.04 is incompatible? Any help appreciated. Thanks.

petch Monday 31 August 2015 at 1:07
petch
Developer

Hi,

Personally I try to test PlayOnLinux installation on the Ubuntu releases currently supported by Canonical: Precise, Trusty, Vivid.

I tried installing Lucid Lynx 10.04.4 in a VM, ran the upgrades, installed the PlayOnLinux version that comes with it (for me that was the occasion to try PlayOnLinux 3.7.3!).

Then I followed the instructions to install PlayOnLinux 4.2.8 on Ubuntu Precise, and PlayOnLinux still works. I didn't need to modify anything.

 

petch Monday 31 August 2015 at 1:09
petch
Developer

sudo playonlinux

By the way PlayOnLinux should never be run as root

animeforlaifu Monday 31 August 2015 at 10:29
animeforlaifuAnonymous

So should I try installing a previous version and then update it?
petch Monday 31 August 2015 at 12:58
petch
Developer

Either that, or you broke something in your installation