El Foro

Font Problems in RollerCoaster Tycoon 3

Autor Respuestas
MTres19 Monday 23 November 2015 at 3:33

I've been having some trouble with my RollerCoaster Tycoon 3 script. I've been planning to clean it up a lot (native d3dx9 doesn't even seem to be necessary) but there's a problem that remains: fonts. I originally got RCT3 working on Debian 7 "Wheezy." I was using the Catalyst driver for the (old) Radeon HD 3200. However, with an update to Debian 8 "Jessie," I could no longer use Catalyst since it only supported Linux 3.2 and some versions older than that. While RCT3 still runs, ever since I was forced to get rid of Catalyst, the fonts are usually completely mangled, like this (I am now on Kubuntu 15.10):

If I'm lucky, and maybe after a simulated windows reboot or so, I'll get partially-correct fonts, like this:

Sometimes, everything will be completely perfect, but most of the time it's not. I've tried using Wine 1.7.48-WGL-ShareList, based on the WineHQ bug report here, but it seems to have no effect whatsoever.

Is this a familiar problem? Does anyone know of a solution?



MTres19 Wednesday 25 November 2015 at 3:22

It occured to me that perhaps I could try using the LLVMpipe renderer temporarily to see if this is a driver issue. However, even after much Googling, I couldn't find anything recent about how to switch to LLVMpipe. I'm on Kubuntu 15.10 on a computer with an AMD Phenom X4 9750 CPU (which supports SSE2) and integrated Radeon HD Graphics 3200. (RS780 line, I think)

Does anyone know how to temporarily enable LLVMpipe? I've tried "Failsafe" from the login screen, but I just get kicked right back to the login after a second or so.


MTres19 Wednesday 25 November 2015 at 21:08

In the meantime, my sister let me install RCT3 on her computer, which has Intel HD Graphics instead of AMD. The fonts are perfect. Evidently it is a problem with the Mesa driver for my GPU. I suppose I'll have to report a bug...