El Foro

[Script Series] Adobe CC 2014 (32-bit)

Autor Respuestas
Andy4 Saturday 21 May 2016 at 4:11
Andy4Anonymous

Helo everyone,

I would like to share scripts for installing applications from Adobe CC 2014 series:

  • Photoshop 15
  • Illustrator 18
  • Bridge 6
  • Lightroom 5.5

I managed to make everything install on one WINE prefix and the apps can communicate with each other, use less disc space (full prefix uses 5.0GB) and less memory while run together. That's why there are 5 separate scripts, starting with "pre-requisites" one, that's required to be installed first. As for apps, you can choose which ones you want.

It's fully based on "Photoshop CS6" script provided by RoninDusette (+ "Lightroom 5" one). I mostly split it into parts, did a little re-formatting, removed messages to speed-up the whole process (needed to attempt installations multiple times to get everything to work, so every click/second mattered - will probably restore them in final version) and changed WINE version to 1.9.9 - that's the only one, on which everything actually workes for me (didn't tried that latest 1.9.10 though and there are lots of problems with stagings).

I did and tested everything on Ubuntu 16.04 64-bit and Radeon HD card.

Yes, there were issues with installations (Adobe apps likes to fail during installation in 2 or 3 ways) and even some after... but once I finally managed to install and configure everything (by either trying again, restoring backup - which I was making after every step - or even starting from zero), it works very nicely and does not break itself. You just cannot change any important settings (like WINE version) after installation, because everything will completely stop working and even will kindly tell you "Please re-install". Didn't find rescue after that.

Sometimes apps does not want to start and are just using lots of CPU... In such cases debug outputs: err:shell:HCR_GetFolderAttributes should be called for simple PIDL's only!. I need to press "Stop" in POL's GUI (or do "Close all PlayOnLinux software") and try again (and it helps). Seen same issue on CS6... I also needed to disable all hardware rendering options and it renders and refreshes normally now. Plus there are also few small "obstructions" while using apps, but you can learn to get around 'em. Illustrator in comparison to CS6, renders better and does not have weird glitches.

However... the only update for those apps, that I was able to install, was latest "Camera RAW". No other update wants to install (using setup files downloaded from adobe.com) and tells that it's not meant for version of software I have (I'm pretty sure that I got proper updates) and that you need to use that "Adobe Update Manager" app.... I'm not gonna test that myself.

OK... enough talk, here are the scripts:

  1. Pre-requisites
  2. Photoshop 15
  3. Illustrator 18
  4. Bridge 6
  5. Lightroom 5.5

Please test 'em, point your fixes/improvements and if we establish something, help me properly share them with rest of the POL community.

Best Regards!

PS. Icons in 256x256 extracted by POL itself: http://imgur.com/a/WoBsz

PS2. Those scripts also works with CC 2015 versions and Photoshop even seems to be doing nicely (altough haven't tested that much yet), however Illustrator is one big glitch, probably because of that new hardware interface. I managed to go through that glitch and disable all h/w accelerations in settings, but it's not helping. Well, maybe with some newer version on WINE or maybe it needs some additional libs...

Editado por: Andy4

Quentin PÂRIS Monday 23 May 2016 at 21:14
Quentin PÂRIS
Admin

Cool!

I think you can safely post them, the pre-requiste could be a POL Function you call with POL_Call command