El Foro

Strange bug with amd64 and old x86 Wine versions

Autor Respuestas
Striker Wednesday 9 August 2017 at 0:57

Hello there. I've been trying to make PlayOnLinux work on Arch for the last few weeks and I'm having only problems.

What I did: I installed both Wine and POL through Arch's official repositories, then proceeded to install some Wine versions (both x86 and amd64) through POL. Everything went fine. After that, I tried creating a virtual drive with a x86 recent version (2.12-staging). It worked perfectly  I also tried out creating a drive with my Wine's system version (2.12 staging, 64-bit), and it also worked perfectly.

Then I tried creating two new drives. One was a amd64 one with 2.12-staging. The other one was an old version of x86 Wine (2.0). Both of them give me the same bug: once the driver is created and POL tries to run winecfg automatically, and after that, if I try running it through POL's menu, or running any problem with a GUI or which are graphical in any way, instead of rendering proper windows and dialogs, one or more objects like this appear in the screen. They seem to, in fact, be the upper right border of a window, which isn't being rendered properly. In my task bar, Wine instances appear and if I minimize them through Right Click -> Minimize, those objects are minimized. If I close them, they disappear from the screen. This seems to happen with every Wine x86 version older than 2.8 and with every single amd64 version. Strangely enough, my system's Wine is also 64bit and doesn't have any of these problems.

I'm afraid that if this problem isn't solved, I might not be able to play any games or use applications that require 64-bit Windows and don't work in most recent versions for whatever reasons without having to install multiple Wine versions manually. Therefore, if anyone can give me any kind of help with this problem, I would be immensely grateful. If you need any specs, my CPU is a AMD FX-6300 and my GPU is a Radeon R9 270. The POL and Wine packages I installed are the one's in Arch's default repositories. I'm also using the open-source drivers for AMD GPUs which are listed here. Thanks in advance.

Editado por: Striker