El Foro

Manually create 64bit prefix

Autor Respuestas
thom_PoL Friday 11 August 2017 at 10:25


I'm trying to install a non-listed game into a 64bit prefix, and can't work it out. So, here's what I'm doing, maybe someone can tell me what I'm doing wrong.

I click on

"+ Install" button
"Install a non-listed program" at the very bottom
"Install a program in a new virtual drive"
Name the drive
Tick all three boxes ("Use another version of wine", "Configure Wine", "Install some libraries), cause, I need all three
Then I get to select a wine version, and that's already off, cause I only get to pick a 32bit version. But heck, I pick 2.13-staging, and go on.
THEN I get to chose 64bit windows installation (a bit late, is it?), which I do.
The drive gets created.
I change the wine settings, pick dx11 to install and then the program's install file, which runs through fine.

After all that, when I check, and the prefix is 32bit (no "Programs (x86)", no "windows/syswow64"; icon in PoL/Configure correctly shows as 32).


So, what am I missing here? The order in which I get to pick wine-version and 32/64bits seems turned around, doesn't it?

This is on Ubuntu 16.04 with PoL 4.2.11 installed

De1m0s Sunday 20 August 2017 at 11:28

Don't know if that is important, but i don't use the option with the 3 checkboxes.

So, choose 64bit installation, install your program. If installation has finished, go to "options", install latest 64-bit wine-version, choose that version from the drop-down-field, and install all required things like DX11.

Never checked, if there´s a folder "windows/syswow64" , but that always worked right.