El Foro

Cant Configure Games

PoL 4.2.12

Autor Respuestas
kimm Monday 30 October 2017 at 19:14
kimmAnonymous

Hi,

Trying to modify oine of my games and for some reason the "configure" option no longer works, if I run PoL from a cmd line I get the following errors, I tried updating to the latest version, 4.2.12, but thats made no differemce.

I'm trying to change the wine version that the game uses as Ive started getting lots of screen flickering issues and this was one of the suggested actions.

Running Linux Mint Xenial 4.4.0-97-generic

$ playonlinux
Looking for python... 2.7.12 - wxversion(s): 3.0-gtk2
selected
[main] Message: PlayOnLinux (4.2.12) is starting
[clean_tmp] Message: PlayOnLinux seems to be already running. Don't cleaning tmp
[Check_OpenGL] Message: 32bits direct rendering is enabled
[Check_OpenGL] Message: 64bits direct rendering is enabled
[POL_System_CheckFS] Message: Checking filesystem for /home/kevin/.PlayOnLinux/
[main] Message: Filesystem is compatible
Bad cookie!
[install_plugins] Message: Checking plug-in: Capture...
[install_plugins] Message: Checking plug-in: ScreenCap...
[install_plugins] Message: Checking plug-in: PlayOnLinux Vault...
[update_check] Message: List is up to date
Traceback (most recent call last):
  File "mainwindow.py", line 977, in Configure
    self.configureFrame = configure.MainWindow(self, -1, _("{0} configuration").format(os.environ["APPLICATION_TITLE"]),game_exec.decode("utf-8","replace"),False)
  File "/usr/share/playonlinux/python/configure.py", line 733, in __init__
    self.list_software()
  File "/usr/share/playonlinux/python/configure.py", line 920, in list_software
    self.list_game.SetItemBold(self.prefixes_item[prefix], True)
  File "/usr/lib/python2.7/dist-packages/wx-3.0-gtk2/wx/_controls.py", line 5309, in SetItemBold
    return _controls_.TreeCtrl_SetItemBold(*args, **kwargs)
wx._core.PyAssertionError: C++ assertion "node" failed at ../src/generic/imaglist.cpp(247) in GetSize(): wrong index in image list

 

 

Cheers

Kevin

Editado por: kimm

jontis Monday 13 November 2017 at 12:42
jontisAnonymous

SImilar problem:

Linux mint:

$ playonlinux
Looking for python... 3.6.3 :: Anaconda custom (64-bit) - skipped
Looking for python2.7... 2.7.12 - wxversion(s): 3.0-gtk2
selected
[main] Message: PlayOnLinux (4.2.10) is starting
[clean_tmp] Message: Cleaning temp directory
[Check_OpenGL] Warning: check_dd_x86 missing, test skipped
[Check_OpenGL] Warning: check_dd_amd64 missing, test skipped
[POL_System_CheckFS] Message: Checking filesystem for /home/jonathan/.PlayOnLinux/
[main] Message: Filesystem is compatible
[install_plugins] Message: Checking plugin: ScreenCap...
[install_plugins] Message: Checking plugin: PlayOnLinux Vault...
Traceback (most recent call last):
  File "mainwindow.py", line 973, in Configure
    self.configureFrame = configure.MainWindow(self, -1, _("{0} configuration").format(os.environ["APPLICATION_TITLE"]),"default",True)
  File "/usr/share/playonlinux/python/configure.py", line 714, in __init__
    self.onglets.Packages(_("Install components"))
  File "/usr/share/playonlinux/python/configure.py", line 322, in Packages
    for app in self.packageList.getParsedList():
  File "/usr/share/playonlinux/python/configure.py", line 53, in getParsedList
    clist = self.getCutList();
  File "/usr/share/playonlinux/python/configure.py", line 45, in getCutList
    clist = self.available_packages.split("\n")
AttributeError: 'list' object has no attribute 'split'
Registered PID: 28527 (Present)

$ uname -r
4.11.0-14-generic

 

Also, the list of programs to install seems to try to load a list but never shows anything.

 

jontis Monday 13 November 2017 at 12:44
jontisAnonymous

Not sure if this is related but I've gone away from standard language settings to en-GB to get metric units.