El Foro

Install of Crossword Compiler hangs

Autor Respuestas
dch888 Monday 14 January 2019 at 22:59


I've tried leaving the install of Crossword Compiler running for a few hours but the result is the same - it just hangs at the step of setting up the virtual drive, says ("Please wait while the virtual drive is being created...").  I'm running:

Hardware:  MacBook Pro (15-inch, 2016),  2.7 GHz Intel Core i7,  16 GB 2133 MHz LPDDR3, R adeon Pro 455 2048 MB,  Intel HD Graphics 530 1536 MB

Software: macOS Mojave (10.14.2) [latest], PlayOnMac 4.3.4.

I've managed to install Steam and through that a Sherlock Holmes game (although that was hanging when launching, I found a fix for that on youtube - namely to delete the install script in the vcredist folder).  Crossword Compiler doesn't even install though, but I wonder if the hang is similar.  The debug log follows.  I'm pretty new to PlayOnMac, so not sure where to go from here yet.  Any pointers would be appreciated.

I think I tried another game World of Tanks and also Spider Solitaire and that did the same thing.



PlayOnLinux debugging tool (v4.3.4)


Debugging: Crossword Compiler


Warning: This is a PlayOnLinux script logfile. It does not contain everything that happened in your program\'s virtual drive (wineprefix)

Please do not use this logfile on winehq forum, this logfile is not interesting for wine debugging.


Date: 01/13/19 11:29:54


> uname -a

  Darwin davids-MBP 18.2.0 Darwin Kernel Version 18.2.0: Mon Nov 12 20:24:46 PST 2018; root:xnu-4903.231.4~2/RELEASE_X86_64 x86_64

> lsb_release -a


> wine --version (Be careful; this version might not be the version used

in the script. Read the content of this file for more information)

  wine-4.0-rc4 (Staging)

> glxinfo \| grep rendering


> glxinfo \| grep renderer


> OpenGL libs



> export

  declare -x AMD64_COMPATIBLE="True"

declare -x APPLICATION_TITLE="PlayOnMac"

declare -x ARGVZERO="./playonmac.real"

declare -x Apple_PubSub_Socket_Render="/private/tmp/com.apple.launchd.7k5Y4f1dvM/Render"


declare -x DESKTOP="/Users/davidcarter/Desktop"

declare -x DONT_MONITOR="1"

declare -x DYLDPATH_ORIGIN="/Applications/PlayOnMac.app/Contents/MacOS"

declare -x DYLD_LIBRARY_PATH="/Applications/PlayOnMac.app/Contents/Resources/playonlinux/../unix/tools/lib/dyld:/Applications/PlayOnMac.app/Contents/Resources/playonlinux/../unix/image_magick/lib:/Appdeclare -x EXECUTABLEPATH="/Applications/PlayOnMac.app/Contents/MacOS/./playonmac.real"

declare -x FREETYPE_PROPERTIES="truetype:interpreter-version=35"

declare -x GECKO_SITE="http://wine.playonlinux.com/gecko"

declare -x GNUPGHOME="/Users/davidcarter/Library/PlayOnMac//gpg"

declare -x HOME="/Users/davidcarter"

declare -x IGNORE_ICON_DIR="false"

declare -x LANG="en_GB"

declare -x LC_ALL="en_GB.UTF-8"

declare -x LD_32_PATH_ORIGIN=""

declare -x LD_LIBRARY_PATH="/Applications/PlayOnMac.app/Contents/Resources/playonlinux/../unix/image_magick/lib:/Applications/PlayOnMac.app/Contents/Resources/playonlinux/../unix/tools/lib/ld:/opt/X11declare -x LD_PATH_ORIGIN=""

declare -x LOGNAME="davidcarter"

declare -x MACHTYPE="x86_64-apple-darwin18"

declare -x MAGICK_HOME="/Applications/PlayOnMac.app/Contents/Resources/playonlinux/../unix/image_magick/"

declare -x MD5_COMMAND="md5"

declare -x MONO_SITE="http://wine.playonlinux.com/mono"

declare -x OLDPWD="/Users/davidcarter/Library/PlayOnMac/plugins"

declare -x OSX_SUB_VERSION="2"

declare -x OSX_VERSION="18"

declare -x OS_NAME="darwin"

declare -x OpenGL32="1"

declare -x OpenGL64="1"

declare -x PATH="/Applications/PlayOnMac.app/Contents/Resources/playonlinux/../unix/wine/bin:/Applications/PlayOnMac.app/Contents/Resources/playonlinux/../unix/image_magick/bin:/Applications/PlayOnMacdeclare -x PATH_ORIGIN="/Applications/PlayOnMac.app/Contents/Resources/playonlinux/../unix/wine/bin:/Applications/PlayOnMac.app/Contents/Resources/playonlinux/../unix/image_magick/bin:/Applications/Pldeclare -x PLAYONLINUX="/Applications/PlayOnMac.app/Contents/Resources/playonlinux"

declare -x PLAYONMAC="/Applications/PlayOnMac.app/Contents/Resources/playonlinux"

declare -x POL_ARCH="x86"

declare -x POL_COOKIE="gTMLUmy27uuujHDVVb9x"

declare -x POL_CURL="curl"

declare -x POL_DNS="playonmac.com"

declare -x POL_HOST=""

declare -x POL_ID="30935047"

declare -x POL_LANG="en"

declare -x POL_OS="Mac"

declare -x POL_PORT="30000"

declare -x POL_SetupWindow_ID="1199"

declare -x POL_TERM="xterm"

declare -x POL_UPTODATE="TRUE"

declare -x POL_USER_ARCH="x86"

declare -x POL_USER_ROOT="/Users/davidcarter/Library/PlayOnMac/"

declare -x POL_WGET="wget --prefer-family=IPv4 -q --no-check-certificate"

declare -x PWD="/Applications/PlayOnMac.app/Contents/Resources/playonlinux/python"

declare -x PYTHONHOME="/Applications/PlayOnMac.app/Contents/Resources"

declare -x PYTHONPATH="/Applications/PlayOnMac.app/Contents/Resources"

declare -x REPERTOIRE="/Users/davidcarter/Library/PlayOnMac/"

declare -x RESOURCEPATH="/Applications/PlayOnMac.app/Contents/Resources"

declare -x RLANG="en_GB"

declare -x SCRIPTID="Crossword Compiler"

declare -x SED="sed"

declare -x SETUPWINDOW_INIT="true"

declare -x SHELL="/bin/bash"

declare -x SHLVL="3"

declare -x SITE="http://repository.playonlinux.com"

declare -x SSH_AUTH_SOCK="/private/tmp/com.apple.launchd.E8q7OATShQ/Listeners"

declare -x TEXTDOMAIN="pol"

declare -x TEXTDOMAINDIR="/Applications/PlayOnMac.app/Contents/Resources/playonlinux/lang/locale/"

declare -x TITLE="Crossword Compiler"

declare -x TITRE="PlayOnMac"

declare -x TMPDIR="/var/folders/5d/p7m8764d15g1f7yg3xtp77_c0000gn/T/"

declare -x USER="davidcarter"

declare -x VERSION="4.3.4"

declare -x WGETRC="/Users/davidcarter/Library/PlayOnMac//configurations/wgetrc"

declare -x WINEDLLOVERRIDES="winemenubuilder.exe=d"

declare -x WINEPREFIX="/Users/davidcarter/Library/PlayOnMac//wineprefix/default"

declare -x WINE_SITE="https://phoenicis.playonlinux.com/index.php/wine?os=darwin"

declare -x WRITE_DYLD="/Applications/PlayOnMac.app/Contents/Resources/playonlinux/../unix/tools/lib/dyld:/Applications/PlayOnMac.app/Contents/Resources/playonlinux/../unix/image_magick/lib:/Applicatiodeclare -x WRITE_LD="/Applications/PlayOnMac.app/Contents/Resources/playonlinux/../unix/image_magick/lib:/Applications/PlayOnMac.app/Contents/Resources/playonlinux/../unix/tools/lib/ld:/opt/X11/lib/:"declare -x XPC_FLAGS="0x0"

declare -x XPC_SERVICE_NAME="0"

declare -x __CF_USER_TEXT_ENCODING="0x1F5:0x0:0x2"



01/13/19 11:31:14 - [POL_Wine_SelectPrefix] Message: Selecting prefix: CrosswordCompiler

01/13/19 11:31:14 - [POL_System_SetArch] Message: POL_ARCH set to x86

01/13/19 11:31:14 - [POL_Wine_PrefixCreate] Message: Setting POL_WINEVERSION to 1.8

01/13/19 11:31:14 - [POL_Wine_PrefixCreate] Message: Creating prefix (1.8)...

01/13/19 11:31:14 - [POL_Wine_PrefixCreate] Message: Using wine 1.8

01/13/19 11:31:14 - [POL_Wine_InstallVersion] Message: Installing wine version path: 1.8, x86

01/13/19 11:31:14 - [POL_Config_PrefixWrite] Message: Prefix config write: ARCH x86

01/13/19 11:31:14 - [POL_Config_PrefixWrite] Message: Prefix config write: VERSION 1.8

01/13/19 11:31:14 - [POL_Wine] Message: Running wine-1.8 --version (Working directory : /Applications/PlayOnMac.app/Contents/Resources/playonlinux/python)

01/13/19 11:31:14 - [POL_Wine] Message: Notice: PlayOnLinux deliberately disables winemenubuilder. See http://www.playonlinux.com/fr/page-26-Winemenubuilder.html


01/13/19 11:31:15 - [POL_Wine] Message: Wine return: 0



Editado por: dch888

Quentin PÂRIS Monday 14 January 2019 at 23:40
Quentin PÂRISAnonymous

Try with a more recent version of wine

dch888 Tuesday 15 January 2019 at 8:20


Try with a more recent version of wine


Thanks,, that got things a little further. I tried the following.  Clicked on Configure, Right click on Crossword Compiler and changed the wine version from 1.8 to  3.17.  Then clicked on install agiain, got past the virtual drive part, then was presented with Overwrite, Erase or Abort chose Overwrite, install got as far as 'Please wait while Crossword Compiler installs..." which I left overnight but it was stuck there.  Here is the log:

01/15/19 07:13:53 - [POL_Wine] Message: Running wine-1.8 ccdemo.exe (Working directory : /Users/davidcarter/Library/PlayOnMac/tmp/CrosswordCompiler)

Wine cannot find the FreeType font library.  To enable Wine to

use TrueType fonts please install a version of FreeType greater than

or equal to 2.0.5.


Wine cannot find the FreeType font library.  To enable Wine to

use TrueType fonts please install a version of FreeType greater than

or equal to 2.0.5.


Wine cannot find the FreeType font library.  To enable Wine to

use TrueType fonts please install a version of FreeType greater than

or equal to 2.0.5.


err:display:macdrv_ChangeDisplaySettingsEx No matching mode found 1680x1050x32 @60!

fixme:wincodecs:CreateComponentInfo {6fddc324-4e03-4bfe-b185-3d77768dc90e} is not supported

wine: Unhandled page fault on read access to 0x0000005c at address 0x4828bf8c (thread 0009), starting debugger...

Wine cannot find the FreeType font library.  To enable Wine to

use TrueType fonts please install a version of FreeType greater than

or equal to 2.0.5.


err:syslink:SYSLINK_SetFont Failed to create link font!



Notice that it has reverted itself to version 1.8 again.

Quentin PÂRIS Wednesday 16 January 2019 at 9:34
Quentin PÂRISAnonymous

01/15/19 07:13:53 - [POL_Wine] Message: Running wine-1.8 ccdemo.exe (Working directory : /Users/davidcarter/Library/PlayOnMac/tmp/CrosswordCompiler)

You are still using wine 1.8

dch888 Friday 18 January 2019 at 21:34


01/15/19 07:13:53 - [POL_Wine] Message: Running wine-1.8 ccdemo.exe (Working directory : /Users/davidcarter/Library/PlayOnMac/tmp/CrosswordCompiler)

You are still using wine 1.8