El Foro

Not using correct wine executable

Autor Respuestas
bpl07 Wednesday 9 July 2008 at 22:02
bpl07Anonymous

When PlayOnLinux installs a program that uses a version of wine different than the one installed on the system, it correctly creates a wineprefix and uses it in the shortcuts it creates. However, it does not use the different wine binaries when running the program.

For example, I used PlayOnLinux to install Steam. Although a new wine binary is created at ~/.PlayOnLinux/Wineversions/0.9.58/usr/bin/wine, this binary is not used by the shortcuts. I get very different results when using this binary vs. the default 1.1.0 wine binary, i.e. my game runs with the 0.9.58 binary but not the 1.1.0 binary.

When making shortcuts, PlayOnLinux should use the custom wine binaries for the specific program, not the default system ones.
Quentin PÂRIS Friday 11 July 2008 at 12:39
Quentin PÂRIS
Admin

PlayOnLinux uses the custom version ...
bpl07 Friday 11 July 2008 at 18:26
bpl07Anonymous

Well then the launchers are not being created correctly.

env WINEPREFIX="/home/brad/.PlayOnLinux/wineprefix/Steam" wine "C:\Program Files\Steam\Steam.exe" will use the default wine binary installed on my system (1.1.0), not the one used during the installation, which is located at /home/brad/.PlayOnLinux/WineVersions/0.9.58/usr/bin/wine

Like I said, using the system wine binary and not the one located in the WineVersions bin folder causes errors on my system.
Quentin PÂRIS Sunday 20 July 2008 at 22:52
Quentin PÂRIS
Admin

Use POL shortcut instead of wine's