El Foro

DirectX cannot install Steam

Steam cannot install DirectX due to missing program

Autor Respuestas
steam-user Wednesday 3 August 2022 at 16:46

I'm trying to open a game on Steam (installed via PlayonMac), but whenever it does first time setup Steam gets stuck on installing DirectX and then Wine returns the message: "There is no Windows program configured to open this file". 

Steam Window for open Star Wars Jedi: Fallen Order: "Performing first time setup... Intalling: Microsoft DirectX (step 2 of 2)". Wine Error Window: "There is no Windows program configured to open this type of file."

I have also tried to install DIrectX directly via PlayonMac from here: https://www.microsoft.com/en-us/download/details.aspx?id=35 , but this also results in an error (I cannot find the log mentioned):

An internal system error occurred. Please refer to DXError.log and DirectX.log in your Windows folder to determine problem.

I have also tried installing the d3dx10, d3dx11, and d3dx9 components, but installing any compoent I can find related to DirectX always results in the same failure to download:

PlayOnMac Wizard: An error happened during download. Do you want to retry?


It should be noted that if I go onto configure wine for Steam, the components seem to be built-in? :

Existing overrides: *d3dx10_33 (native, builtin), *d3dx10_34 (native, builtin), *d3dx10_35 (native, builtin), *d3dx10_36 (native, builtin), *d3dx10_37 (native, builtin), *d3dx10_38 (native, builtin), *d3dx10_39 (native, builtin), *d3dx10_40 (native, builtin), *d3dx10_41 (native, builtin), *d3dx10_42 (native, builtin), *d3dx10_43 (native, builtin)

(Continuing from previous image) Existing overrides: *dwrite (disabled), *gameoverlayrenderer (disabled)


Does anyone have any advice?


ATTSSystem Saturday 20 August 2022 at 21:03

Approximately same problem here. The only difference is in Steam, it shows the DirectX installation process then just stops and quits the game whereas Steam stays opened. Moreover DirectX is not present in Wine configuration in my case. I'm running it on a MBA M1. Does someone found a solution ?

This site allows content generated by members, and we promptly remove any content that infringes copyright according to our Terms of Service. To report copyright infringement, please send a notice to dmca-notice@playonlinux.com