El Foro

Counter-Strike Source Crashes

Steam Related Problem

Autor Respuestas
alien260 Friday 8 August 2008 at 0:27


I'm very new to playonlinux but as a first thing WELL DONE to everyone that helped the development of this. Amazing tool.

I have managed to install everything without a problem, steam loads fine everything connects and i start playing but after a couple of min usually around 3 min the whole thing freezes sits there for about 10 seconds and then the window closes and im back to the steam menu.

Has anyone had this problem of know how to fix this?

Many thanks in advance.

OS: Ubuntu 8.04

alien260 Friday 8 August 2008 at 9:59

Just wanted to give a quick update, Im not sure if this is a steam problem or a CS problem. i dont have any other games to test steam on.

Let me know please

Thank you again
Ante Sunday 10 August 2008 at 20:57

I am on Ubuntu 8.04 (Hardy) and uses wine version 0.9.58 with a Geforce 6800GT and it works good!
I use this launch options for Counter-Strike Source in steam "-fullscreen -w 640 -h 480 -dxlevel 80" and it works great. I hope this helps you or try to find some clues here wine's homepage.

Know this, my friend - the evil that you move against is the dark lord of terror. -Deckard Cain
alien260 Sunday 10 August 2008 at 21:53

Hi Ante,

Its become even worse now... i when i try an press the settings button the whole of the window crashes. i really dont understand why my version is having such a problem. apart from res.. im running the same as u, i have a Geforce 6800 SLI ... ?!?!?

i dont understand why its giving me such a problem?

Ante Sunday 10 August 2008 at 23:13

What wine version u use?
When I uses the newest version of wine it is laggy that's why I use a older version who works good with CS Source.
Forgot to tell u that I use 32-bits Hardy Heron not 64-bits even if I got a AMD X2 5200+ CPU and 4GB in DDR2. I use 32-bits because it is less buggy and more stable for my system.

Known issue:
Counter Strike crashes as soon as it starts or you join a game.
You most likely have other program(s) using sound. Run winecfg and select only ALSA sound driver. OSS is not the best choice anymore.

For Ubuntu 8.04 - kill/disable pulseaudio. It is not compatible with Wine.

Another possible reason - you have "Steam Community In-Game" enabled. It does not work properly on Wine and causes all games to crash. Please disable it in settings -> In-game tab.

Editado por: Ante

Know this, my friend - the evil that you move against is the dark lord of terror. -Deckard Cain