El Foro

Pb installation Wine

Autor Respuestas
PaniPwoBlem Tuesday 16 September 2008 at 9:28
PaniPwoBlemAnonymous

Bonjour à tous.

Alors j'ai fait la manip suivante pour avoir wine sur mon EEEpc sous Xandros:

wget -q http://wine.budgetdedicated.com/apt/387EE263.gpg -O- | sudo apt-key add -
sudo wget http://wine.budgetdedicated.com/apt/sou ... /etch.list -O /etc/apt/sources.list.d/winehq.list
sudo apt-get update
sudo apt-get install wine


Mais quand mon EEE arrive à la dernière ligne (sudo apt-get install wine) j'ai ce message:

asus:/home/user> apt-get install wine
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances... Fait
Vous pouvez lancer « apt-get -f install » pour corriger ces problèmes :
Les paquets suivants contiennent des dépendances non satisfaites :
libperl5.8: Dépend: perl-base (= 5.8.8-7etch3) mais 5.8.8-7 devra être installé
perl: Dépend: perl-base (= 5.8.8-7etch3) mais 5.8.8-7 devra être installé
wine: Dépend: winbind mais ne sera pas installé
E: Dépendances non satisfaites. Essayez « apt-get -f install » sans paquet
(ou indiquez une solution).


Je lance donc apt-get -f install et ça me donne:

asus:/home/user> apt-get -f install
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances... Fait
Correction des dépendances... Fait
Les paquets supplémentaires suivants seront installés :
perl-base
Les paquets suivants seront mis à jour :
perl-base
1 mis à jour, 0 nouvellement installés, 0 à enlever et 245 non mis à jour.
3 partiellement installés ou enlevés.
Il est nécessaire de prendre 0o/760ko dans les archives.
Après dépaquetage, 164ko d'espace disque seront libérés.
Souhaitez-vous continuer [O/n] ? o
(Lecture de la base de données... 66951 fichiers et répertoires déjà installés.)
Préparation du remplacement de perl-base 5.8.8-7 (en utilisant .../perl-base_5.8.8-7etch3_i386.deb) ...
Dépaquetage de la mise à jour de perl-base ...
dpkg : erreur de traitement de /var/cache/apt/archives/perl-base_5.8.8-7etch3_i386.deb (--unpack) :
tentative de remplacement de « /usr/lib/perl/5.8 », qui appartient aussi au paquet voice-command
Des erreurs ont été rencontrées pendant l'exécution :
/var/cache/apt/archives/perl-base_5.8.8-7etch3_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)



Alors je ne sais plus quoi faire à partir de là et j'aurais besoin de votre aide,merci beaucoup d'avance.

Editado por: PaniPwoBlem

Quentin PÂRIS Tuesday 16 September 2008 at 12:10
Quentin PÂRIS
Admin

Il semble qu'il y ai un conflit avec le paquet voice-command
PaniPwoBlem Tuesday 16 September 2008 at 13:35
PaniPwoBlemAnonymous

Comment remédier à ce conflit s'il vous plait?
lateo Friday 19 September 2008 at 14:05
lateo

manifestement tu as déjà perl 5.8.8-7 sur ta xandros, le repository etch propose exactement la meme version, mais personnalisée pour etch ("5.8.8-7etch3"). bref je ne suis pas persuadé que tu sois obligé de remplacer ça.

il n'y a pas énormément de dépendances pour PoL, et amha tu devrais procéder à l'installation manuelle du paquet deb et régler les quelques pb de dépendance que tu risque de rencontrer au fil de l'eau.
au niveau pb de dépendances, de mémoire, tu devrais déjà commencer par installer LZMA "sudo apt-get install lzma".
après tu essaies d'installer le deb à la main, genre :
$ cd /home/panipwoblem/chemin/vers/le/fichier/deb/préalablement/téléchargé/
$ dpkg -i pol3.1.deb

Editado por: lateo