El Foro

Half.Life 2 problems.

Autor Respuestas
Mear Tuesday 25 November 2008 at 19:28

Nice and easy program.

My specs are,
Ubuntu 8.10-x86 (gnome)
Newest version of Playonlinux (with both wine 1.9 and 0.9.58)
nvidia 8800gts (Yes newest drivers)
AMD Athlon 62 Dual Core 5600+
3Gb of RAM

Well, to my problem then.

Steam installed just fine, no problems there. And I installed hl2 through steam (is that ok?).
After that i try to start hl2, the first video has less bits then the original nintendo and is kind of pink in some places. Figured already there that something is wrong.

And it just crashes after the loading screen with the blurry City 17 in the background.
I've tried with both wine versions in playonlinux. And googled my ass off.
I've also tried with vanilla wine and it's the same thing there. The old half-life works fine though.

Parameters tried: -novid -dxlevel (70,80,81,90) -width -height

Am I missing something? Like dlls or do I have to install directx9 or something.

And oh, is the no 3d acceleration thing something to worry about?

Well thanks for me.

Ran glxinfo | grep rendering in terminal and it returned "no" so that means that 3d acceleration ins't turned on. Time to figure out how to turn that on, care to help me on that one?

It was the 3d acceleration thing that messed it up.
Here's what I did.
sudo apt-get install nvidia-glx

There was 4 diffrent, took 177 since that's my driver version, so in terminal:
sudo apt-get install nvidia-glx-177
sudo nvidia-glx-config enable (think it was like that, but it dind't work .....)
So I restarted my computer and boom, there was 3d acceleration.. and hl2 worked like a charm.

I also tried to run glxinfo | grep again after the reboot, but it didn't work. And steam also complain that my drivers is outdated.

Editado por: Mear