El Foro

World Of Warcraft Cd Rom

Autor Respuestas
MinceMeat Saturday 7 February 2009 at 0:22

HI all,

Today I installed playonlinux, and it worked after a bit of stuffing around.
So then I installed some games, and they worked fine. Then I tried to install WoW, I put in a blank DVD, I told the machine to install it on a DVD, put in the location of the DVD, but then it said "unable to find the cd rom".

Any help would be greatly appreciated.
Ghostofkendo Saturday 7 February 2009 at 23:38

Hi MinceMeat,

I'm not sure to understand what you tried to do
You wanted to install WoW on a blank DVD ?
If that's right, I think you misunderstood the purpose of PlayOnLinux. In this case, the WoW installation script is intended to install WoW on your Linux system from the WoW DVD you bought in a shop.

BigPimpin Monday 9 February 2009 at 21:31

I might be able to expand on this, because I'm having a similar problem. Ubuntu 8.10 is the system I'm running.

I put in the WOW-Wrath of the Lich King DVD and start up PlayOnLinux. I click Install, the choose World of Warcraft, then Apply. I click Next, then choose Install with One DVD

I put the DVD in, point to where it's mounted, and Error - not a valid DVD comes up. I know my DVD player is working fine, because when I just put the WotLK DVD in, it mounts and I can read it. So I'm not sure why this wouldn't work for that, unless they're referring to the first WoW.
Ghostofkendo Wednesday 11 February 2009 at 21:57

Hello BigPimpin,

To my mind, the problem is that the WoW script has been written for the first WoW (and not the add-ons).
And the "not valid DVD" error you get isn't caused by a defective DVD or DVD player. You get this error because the script looks for the first WoW installer in the DVD and when it doesn't find the correct installer, it assumes it's the wrong DVD/mount point.

So, to manage to install WoW: Wraith of the Lich King, you can either install it manually (POL > Install > Install a .pol package or an unsupported application) or create a script for this add-on.

BigPimpin Thursday 12 February 2009 at 13:22

OK, cool.

Installing an unsupported app didn't work. I left it overnight on the "Please don't click next until the program is installed" screen and got nothing installed, so I'm going to start looking at scripting documentation. Thank you for the suggestions.
Ghostofkendo Thursday 12 February 2009 at 15:08

You're welcome BigPimpin.
If you need help or have questions about scripting, feel free to ask

I advise you to use the POL Script Creator plugin to write your script.
(Warning: the documentation isn't very up to date, it's still good to explain the principles of a POL script but the scripting language it describes is the v2. Today, we (and the POLSC plugin) use the version 3 of this language. It's a bit different but you can read some scripts that are already validated for a better understanding. The script for Age of Empires II is quite simple for example.)

Steel_Hammer Monday 23 February 2009 at 18:18


If I read your post correctly, I need to script myself the WotLK. There's an other way, to install this expansion, witch is free, and a little bit easier?