El Foro

Bugs POL v.3.3.1

Autor Respuestas
NSLW Sunday 1 March 2009 at 23:12
NSLW

Hello,
I'm using POL v.3.3.1 Generic on Fedora 10 i386. I've got "Default Wine Version to run wine programs with PlayOnLinux" set to System. I've got Wine 1.1.16 compiled from source package. Here is list of issues I would like to share with developers of POL.

1) ScriptCreator 0.4 installs but doesn't work.
Here is the output from terminal

$ sh playonlinux
PlayOnLinux v3.3.1

Checking python :                     [ Ok ]
Fatal Error: Mismatch between the program and library build versions detected.
The library used 2.8 (no debug,Unicode,compiler with C++ ABI 1002,wx containers,compatible with 2.4,compatible with 2.6),
and your program used 2.8 (no debug,Unicode,compiler with C++ ABI 1002,wx containers,compatible with 2.6).
/home/WINEUSER/.PlayOnLinux//plugins/Script Creator/scripts/menu: line 4: 19244 Aborted ./POLSC
Running options

2) after setting something e.g. UseGLSL to disabled through Advanced Wine Configuration I get "Python Error"

"Can't load image from file '/usr/share/playonlinux/themes/tango/ok.png': file does not exist."

3) Advanced Wine Configuration (v.3.5.1) doesn't set UseGLSL but only creates "String Value" in registry called "UseGLSL"

4)Issue with winecfg with steps to reproduce

1.Tools-> Manage wine Versions->My Applications
2.Choose one app and set it's version to e.g 1.1.16 and close this window
3.Configure this application->Forward->Configure wine->Forward->About

The problem is when in system you've got installed e.g Wine 1.1.15 the About tab in winecfg shows "Wine 1.1.15" instead of "Wine 1.1.16"

5) POL creates wrong scripts if app is installed on chosen partition (filesystem is ext3).
I tested it on GTA Vice City by "Install a .pol package or an unsupported application" (I know there is script for GTAVC). When "Choose the file to exec the game." appeared I gave "/media/Operacyjna/GTAVC/gta-vc.exe"

POL should create:

#!/bin/bash
export WINEPREFIX="/home/WINEUSER/.PlayOnLinux/wineprefix/ViceCity"
export WINEDEBUG="-all"
cd "/media/Operacyjna/GTAVC"
wine "gta-vc.exe" $@

instead of:

#!/bin/bash
export WINEPREFIX="/home/WINEUSER/.PlayOnLinux/wineprefix/ViceCity"
export WINEDEBUG="-all"
cd "/home/WINEUSER/.PlayOnLinux/wineprefix/ViceCity/drive_c//media/Operacyjna/GTAVC"
wine "/media/Operacyjna/GTAVC/gta-vc.exe" $@

6) POL links not correctly to "My Documents".
I installed GTA:VC as above started to play and then saved the game but then there was no sign of saved file and in load menu of GTA:VC there were nothing to load. The save file should be in my home folder as it is when I install GTA:VC not using POL.

7) There is typo error in POL
in "Settings->general->Environment" instead of "Defaut [...]" should be "Default [...]"
Quentin PÂRIS Thursday 5 March 2009 at 21:07
Quentin PÂRIS
Admin

Hello,
I'm using POL v.3.3.1 Generic on Fedora 10 i386. I've got "Default Wine Version to run wine programs with PlayOnLinux" set to System. I've got Wine 1.1.16 compiled from source package. Here is list of issues I would like to share with developers of POL.

1) ScriptCreator 0.4 installs but doesn't work.
Here is the output from terminal

$ sh playonlinux
PlayOnLinux v3.3.1

Checking python :                     [ Ok ]
Fatal Error: Mismatch between the program and library build versions detected.
The library used 2.8 (no debug,Unicode,compiler with C++ ABI 1002,wx containers,compatible with 2.4,compatible with 2.6),
and your program used 2.8 (no debug,Unicode,compiler with C++ ABI 1002,wx containers,compatible with 2.6).
/home/WINEUSER/.PlayOnLinux//plugins/Script Creator/scripts/menu: line 4: 19244 Aborted ./POLSC
Running options

Quote from NSLW

The problem came from the plugin


2) after setting something e.g. UseGLSL to disabled through Advanced Wine Configuration I get "Python Error"

"Can't load image from file '/usr/share/playonlinux/themes/tango/ok.png': file does not exist."

3) Advanced Wine Configuration (v.3.5.1) doesn't set UseGLSL but only creates "String Value" in registry called "UseGLSL"

Quote from NSLW

These problem also came from the plugin. Contact GNU_Raziel


4)Issue with winecfg with steps to reproduce

1.Tools-> Manage wine Versions->My Applications
2.Choose one app and set it's version to e.g 1.1.16 and close this window
3.Configure this application->Forward->Configure wine->Forward->About

The problem is when in system you've got installed e.g Wine 1.1.15 the About tab in winecfg shows "Wine 1.1.15" instead of "Wine 1.1.16"

Quote from NSLW

It does not change anything. winecfg run with all wine versions


5) POL creates wrong scripts if app is installed on chosen partition (filesystem is ext3).
I tested it on GTA Vice City by "Install a .pol package or an unsupported application" (I know there is script for GTAVC). When "Choose the file to exec the game." appeared I gave "/media/Operacyjna/GTAVC/gta-vc.exe"

POL should create:

#!/bin/bash
export WINEPREFIX="/home/WINEUSER/.PlayOnLinux/wineprefix/ViceCity"
export WINEDEBUG="-all"
cd "/media/Operacyjna/GTAVC"
wine "gta-vc.exe" $@

instead of:

#!/bin/bash
export WINEPREFIX="/home/WINEUSER/.PlayOnLinux/wineprefix/ViceCity"
export WINEDEBUG="-all"
cd "/home/WINEUSER/.PlayOnLinux/wineprefix/ViceCity/drive_c//media/Operacyjna/GTAVC"
wine "/media/Operacyjna/GTAVC/gta-vc.exe" $@

Quote from NSLW

When you install a program with POL, you should use the default directory. It's just impossible to detect where the program has been installed


6) POL links not correctly to "My Documents".
I installed GTA:VC as above started to play and then saved the game but then there was no sign of saved file and in load menu of GTA:VC there were nothing to load. The save file should be in my home folder as it is when I install GTA:VC not using POL.

7) There is typo error in POL
in "Settings->general->Environment" instead of "Defaut [...]" should be "Default [...]"

Quote from NSLW

Ok
NSLW Thursday 5 March 2009 at 22:29
NSLW

Citation de NSLW:


4)Issue with winecfg with steps to reproduce

1.Tools-> Manage wine Versions->My Applications
2.Choose one app and set it's version to e.g 1.1.16 and close this window
3.Configure this application->Forward->Configure wine->Forward->About

The problem is when in system you've got installed e.g Wine 1.1.15 the About tab in winecfg shows "Wine 1.1.15" instead of "Wine 1.1.16"


It does not change anything. winecfg run with all wine versions

Citar

Yes, but you cannot be absolutely sure that Wine doesn't update its winecfg in future releases and invoking it correctly now, may not cause problems in future.

Citation de NSLW:


5) POL creates wrong scripts if app is installed on chosen partition (filesystem is ext3).
I tested it on GTA Vice City by "Install a .pol package or an unsupported application" (I know there is script for GTAVC). When "Choose the file to exec the game." appeared I gave "/media/Operacyjna/GTAVC/gta-vc.exe"

POL should create:

#!/bin/bash
export WINEPREFIX="/home/WINEUSER/.PlayOnLinux/wineprefix/ViceCity"
export WINEDEBUG="-all"
cd "/media/Operacyjna/GTAVC"
wine "gta-vc.exe" $@

instead of:

#!/bin/bash
export WINEPREFIX="/home/WINEUSER/.PlayOnLinux/wineprefix/ViceCity"
export WINEDEBUG="-all"
cd "/home/WINEUSER/.PlayOnLinux/wineprefix/ViceCity/drive_c//media/Operacyjna/GTAVC"
wine "/media/Operacyjna/GTAVC/gta-vc.exe" $@


When you install a program with POL, you should use the default directory. It's just impossible to detect where the program has been installed

Citar

Yes, it is impossible to detect where the program has been installed but I gave the path for it "/media/Operacyjna/GTAVC/gta-vc.exe" so I think it should parse it in folowing manner:
go to dir "/media/Operacyjna/GTAVC/"
execute gta-vc.exe