El Foro

Version 3.7.2 does not accept multi-disc install

bash siezes the installation disc with a steel grip

Autor Respuestas
A Nonny Moose Monday 21 December 2009 at 21:37
A Nonny MooseAnonymous

I have tried to install a large game which requires the installation of two discs. When the time to switch discs arrived, the shell gripped the first disc like a closed clam, even though there was a dialog box to override this. The override fails and, therefore the installation fails.

One wonders if the product is worth using at all and whether it should even be offered by ubuntu as part of the current wine update.

More program testing is needed, mes chers amis. Try an install an SimCity 4 original version to reproduce the problem.

Bonne chance.
Reiger Tuesday 26 January 2010 at 17:33

This can be worked around via (commandline):

wine eject

However, AFAIK, it requires that the cdrom is mounted under (claimed by) Wine itself. So presumably this does not work if you had mounted the cdrom first using e.g. a file manager. eject -a before installation ought to work around _that_ too.