El Foro

Today's update caused shortcuts not to work

PlayOnLinux thinks it was not used before

Autor Respuestas
Jump to the page: 1 - 2
PaddyLandau Wednesday 17 August 2011 at 9:16
PaddyLandauAnonymous

Today's PlayOnLinux update to 4.0.1 has a serious problem. All shortcuts no longer work. Message:

/usr/share/playonlinux/playonlinux: line 45: ./playonlinux-bash: No such file or directory

Also, when I ran PlayOnLinux itself, it thought I had not run it ever before and created a new "virtual drive".

If I try to use the Detour plugin to restore the shortcut, it complains, "drive_c folder does not exist".

Please, how can I fix the shortcuts? I badly need access to my programs!

Thank you.
GNU_Raziel Wednesday 17 August 2011 at 10:11
GNU_Raziel


Hi,
First, detour plugin no longer work with PoLv4 and it's not needed anymore because you can regenerate shortcuts at any time.

Try to completely remove PoLv4 then reinstall it, your current installation has probably goe wrong and you miss some utils.

Regards,

GNU_Raziel
Quentin PÂRIS Wednesday 17 August 2011 at 11:04
Quentin PÂRIS
Admin

Today's PlayOnLinux update to 4.0.1 has a serious problem. All shortcuts no longer work. Message:

/usr/share/playonlinux/playonlinux: line 45: ./playonlinux-bash: No such file or directory

Also, when I ran PlayOnLinux itself, it thought I had not run it ever before and created a new "virtual drive".

Quote from PaddyLandau

This point is normal, POL 4 was run for the first time

Please, how can I fix the shortcuts? I badly need access to my programs!

Thank you.

Quote from PaddyLandau


You must run POL 4 and wait for few seconds. Then, try to run one of your program in PlayOnLinux's list.

If you can't see any program, go to configure window, and restore them with "Make a shortcut from this virtual drive"

If you can see your program, and if they work, you can use "Shortcut" button in the toolbar
Scyth Wednesday 17 August 2011 at 19:07
ScythAnonymous

Got a similar situation here:

- fresh wine installation 1.3
- fresh playonlinux installation 4.0.1
- fresh installation office 2007 in pol

Installation was successful. Unfotunately no shortcuts were created. Clicking Shortcut brings no solution to that problem (no window appears).
So I tried Configuration / focus on prefix Office 2007 / Make new shortcut from this firtual drive / searched for winword.exe and excel.exe, selected them and created shortcuts.
Now I have them in my shortcutlist in the main window. But as soon as I try to execute them I get an error message: Invalid error - received internal parameters (translated this error message into english... so... not sure if it is even near to the english message ;) )

Activated Debugging, posting logfiles now:

Word:

File :Word
Date : 08/17/11 18:46:52
PlayOnMac Version : 4.0.1
File content :
[code language%3Dplayonlinux]
#!/bin/bash
[ "$PLAYONLINUX" = "" ] && exit 0
source "$PLAYONLINUX/lib/sources"
export WINEPREFIX="/home/kathi/.PlayOnLinux//wineprefix/Office2007"
export WINEDEBUG=""
cd "/home/kathi/.PlayOnLinux//wineprefix/Office2007/drive_c/./Programme/Microsoft Office/Office12"
POL_Wine "WINWORD.EXE" $@[/code]
Output :

Citar


Excel:

File :excel
Date : 08/17/11 18:31:42
PlayOnMac Version : 4.0.1
File content :
[code language%3Dplayonlinux]
#!/bin/bash
[ "$PLAYONLINUX" = "" ] && exit 0
source "$PLAYONLINUX/lib/sources"
export WINEPREFIX="/home/kathi/.PlayOnLinux//wineprefix/Office2007"
export WINEDEBUG=""
cd "/home/kathi/.PlayOnLinux//wineprefix/Office2007/drive_c/./Programme/Microsoft Office/Office12"
POL_Wine "EXCEL.EXE" $@[/code]
Output :[/code]

Output :

Citar


Link for debugging-error files
http://dl.dropbox.com/u/38515169/errors_excel.log.e
http://dl.dropbox.com/u/38515169/errors_Word.log.e

Thx for your help!

Quentin PÂRIS Wednesday 17 August 2011 at 21:50
Quentin PÂRIS
Admin

Normally, it's fixed in git version for 4.0.2
Scyth Wednesday 17 August 2011 at 22:06
ScythAnonymous

Ah, great (and thx for your fast responses, btw... if there'd be some kind of internet wub you'd get one :P )
May I ask you what kind of error it is and when 4.0.2 will be released?
Thx!
Quentin PÂRIS Wednesday 17 August 2011 at 22:13
Quentin PÂRIS
Admin

It was a cd missing in bash file. Can you test it for me please ? I want to be sure that this bug is solved.

1 - Edit /usr/share/playonlinux/playonlinux

Just before the lines :

shift
NAME="$1"
shift
./playonlinux-bash ....,

add cd "$(dirname "$0")"

The file should be like this

#!/bin/bash

# Copyright (C) 2007-2010 PlayOnLinux Team
# Copyright (C) 2011 Pâris Quentin

# This program is free software; you can redistribute it and/or modify
# it under the terms of the GNU General Public License as published by
# the Free Software Foundation; either version 2 of the License, or
# (at your option) any later version.

# This program is distributed in the hope that it will be useful,
# but WITHOUT ANY WARRANTY; without even the implied warranty of
# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
# GNU General Public License for more details.

# You should have received a copy of the GNU General Public License along
# with this program; if not, write to the Free Software Foundation, Inc.,
# 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA. 

#Variables
die() ## PHP function copy
{
	echo "$@"
	exit
}
[ "$(uname -s)" = "Linux" ] || die "This script must be run on a linux system"

export PYTHON="python"
export POL_OS="Linux"
export UBUNTU_MENUPROXY=0 
export MACHTYPE

[ "$PLAYONLINUX" = "" ] || die "You are already in a PlayOnLinux environement" 

if [ ! "$(which $PYTHON)" ]then
	echo "Please install $PYTHON before trying to run PlayOnLinux"
fi

if [ "$1" == "--run" ]
then
	cd "$(dirname "$0")"
	shift
	NAME="$1"
	shift
	./playonlinux-bash "$HOME/.PlayOnLinux/shortcuts/$NAME" "$@"
else
	cd "$(dirname "$0")/python"
	"$PYTHON" mainwindow.py "$@"
	if [ ! "$?" = "0" ]
	then
		python2.6 mainwindow.py "$@" || python2.5 mainwindow.py "$@"
	fi
fi
exit $?
Quentin PÂRIS Wednesday 17 August 2011 at 22:15
Quentin PÂRIS
Admin

For office 2007 problem, set wine-1.2-rc1 wine version for Office virtual drive
PaddyLandau Wednesday 17 August 2011 at 22:17
PaddyLandauAnonymous

First, detour plugin no longer work with PoLv4 and it's not needed anymore because you can regenerate shortcuts at any time.

Quote from GNU_Raziel

Does that mean I should delete the detour plugin?

Try to completely remove PoLv4 then reinstall it, your current installation has probably goe wrong and you miss some utils.

Quote from GNU_Raziel

I have done that. Nothing changed.

You must run POL 4 and wait for few seconds. Then, try to run one of your program in PlayOnLinux's list.

Quote from Tinou

Still the same error.

If you can't see any program, go to configure window, and restore them with "Make a shortcut from this virtual drive"

Quote from Tinou

I have done that, and the new shortcut is identical to the old shortcut.

In the past, upgrading POL has always been flawless; the new POL just carried on from where the last one left off.

This time, the new POL thought it had not been run before (none of the other upgrades has done this).

But it gets weirder...

Publisher:
From the automatically-generated menu shortcut, it gives that error. However, from POL's screen, it runs.

Quicken:
From the automatically-generated menu shortcut, it gives that error. From POL's screen, nothing happens.

So, I'm getting inconsistent results as well as the error.
Quentin PÂRIS Wednesday 17 August 2011 at 22:21
Quentin PÂRIS
Admin

Yep, automatically-generated menu shortcut are broken ! The git version is fixed

Pol did'nt thought it had not been run before, if it was the case, it would have been reinstalled microsoft fonts. POL just need to run "first wizard" to make a wineprefix called "default", it's a new feature that's prevent POL to modify .wine folder if the WINEPREFIX is not specified. Don't worry, all is okay :)

You can read my latest post for the fix
PaddyLandau Wednesday 17 August 2011 at 22:21
PaddyLandauAnonymous

It was a cd missing in bash file...

Quote from Tinou

I've tried this. The error has changed:

[POL_Wine_AutoSetVersionEnv] Message: Reading version : usr
[POL_Wine_AutoSetVersionEnv] Message: wineprefix : /home/paddy/.PlayOnLinux//wineprefix/Quicken
[POL_Wine_SetVersionEnv] Message: Setting wine version path: usr, x86
[POL_Wine_SetVersionEnv] Message: Wine usr not installed
[POL_Wine_InstallVersion] Message: Installing wine version path: usr, x86
--2011-08-17 21:19:57-- http://www.playonlinux.com/wine/binaries//linux-x86.lst
Resolving www.playonlinux.com... 91.121.5.64
Connecting to www.playonlinux.com|91.121.5.64|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 3556 (3.5K) [text/plain]Saving to: `STDOUT'

100%[==========================>] 3,556 --.-K/s in 0.001s

2011-08-17 21:19:57 (5.70 MB/s) - written to stdout [3556/3556]

[POL_Wine_InstallVersion] Error: Unable to find version: usr
Traceback (most recent call last):
File "wrapper.py", line 73, in <module>
message = open(fichier_index,'r').read()
IOError: [Errno 2] No such file or directory: '/home/paddy/.PlayOnLinux//configurations/guis/index_29296122'


And then it hangs!

Editado por: Tinou

Quentin PÂRIS Wednesday 17 August 2011 at 22:22
Quentin PÂRIS
Admin

Click on configure button on quicken

Wineversion is set to "usr" isn't it ? Put another one ;)
PaddyLandau Wednesday 17 August 2011 at 22:29
PaddyLandauAnonymous

Click on configure button on quicken

Wineversion is set to "usr" isn't it ? Put another one ;)

Quote from Tinou

Yes, it is!

I have changed it to "System".

Now, I get a better result.

1. The following messages display:
[POL_Wine_AutoSetVersionEnv] Message: Reading version :
[POL_Wine_AutoSetVersionEnv] Message: wineprefix : /home/paddy/.PlayOnLinux/wineprefix/Quicken
[POL_Wine_AutoSetVersionEnv] Message: POL_WINEVERSION is not set
[POL_Wine] Message: Running wine- QW.EXE
Traceback (most recent call last):
File "wrapper.py", line 73, in <module>
message = open(fichier_index,'r').read()
IOError: [Errno 2] No such file or directory: '/home/paddy/.PlayOnLinux//configurations/guis/index_50661669'

2. It runs! :D

3. When I close the program, in the terminal it still hangs. Even Ctrl-C does not stop the session. The processes playonlinux and playonlinux-bas are still sitting in the background.

So, it is much better -- thank you! But the process doesn't die; something is still wrong.

(By the way, the "Preview" button under this post doesn't work, so I cannot preview to check that I have put the codes correctly.)
PaddyLandau Wednesday 17 August 2011 at 22:30
PaddyLandauAnonymous

Oh... the processes have died now. It seems they just take a long time.

It works.

Thank you!

EDIT: No, I was mistaken -- I was looking at the wrong screen. Sorry. They are still hanging.

Editado por: PaddyLandau

Quentin PÂRIS Wednesday 17 August 2011 at 22:34
Quentin PÂRIS
Admin

Ok, I know where does the problem come from !

4.0.2 is out in 5 minutes to correct all that mistake
Scyth Wednesday 17 August 2011 at 23:30
ScythAnonymous

Yay! Works here too with 4.02 after setting wine-version to System.
Awesome programm, awesome support, I rlly rlly rlly feel like to have to donate now ;)
Quentin PÂRIS Wednesday 17 August 2011 at 23:34
Quentin PÂRIS
Admin

It was a pleasure Scyth ;)

(In three week, I'll be unavailable for nine months again. And after that, I'll have plenty of time for POL, so if you have something to ask, don't hesitate)
PaddyLandau Thursday 18 August 2011 at 9:02
PaddyLandauAnonymous

I have just installed POL 4.0.2, and everything works again!

Thank you, Tinou.
Tommy_CZ Sunday 8 September 2013 at 10:05
Tommy_CZAnonymous

Playonlinux 4.2.1 - same problem,
tomas@tomas-Lenovo-IdeaPad-Y550P:~$ playonlinux
/usr/share/playonlinux/playonlinux: řádek 70: /home/tomas/bin/uname: binární soubor nelze spustit
This script must be run on a linux system
.... I used it without problems for few weeks. I will try to reinstall it and will refer.
Tommy_CZ Sunday 8 September 2013 at 10:06
Tommy_CZAnonymous

Oh sry I didn't realise, in my case the playonlinux now doesn't even run.