El Foro

Warcraft 3 resolution 1280x800 possible ?

Autor Respuestas
ptitpique Tuesday 11 December 2007 at 11:58
ptitpique

Bonjour,

Tout d'abord merci pour tout votre travaille

J'ai donc installer sans problème Warcraft 3 sur mon PC portable.
Mais j'aimerais bien avoir une résolution de 1280x800, mais je n'ai pas réussi.
J'ai pourtant essayer de modifier les registres mais cela ne change pas la résolution

Je suis sous :
-Kubuntu 7.10
-Wine 0.9.50
-bureau KDE

Merci d'avance pour votre aide
goku Tuesday 11 December 2007 at 12:18
goku

Bonjour ptitpique;
C'est bien avec la base de registre que tu peux mettre Warcraft III en 1280x800. Voici la démarche à suivre:
tu ouvres playonlinux, dans la liste de tes jeux, tu selectionnes warcraft III. Ensuite, tu vas dans l'onglet expert et tu cliques sur base de registre. Tu vas dans HKEY_CURRENT_USER --> Sofware --> Blizzard entertainment-->Warcraft III --> Video

Il ne reste plus qu'à modifier resheight et reswidth
resheight : 800
reswidth : 1280

Cette manipulation devrait marcher .

Editado por: goku


Windows de Microsoft.

Mac de Apple.

Linux du monde entier.
Quentin PÂRIS Tuesday 11 December 2007 at 15:14
Quentin PÂRIS
Admin

N'oublie pas de mettre ça en décimal

Editado por: goku

ptitpique Wednesday 12 December 2007 at 9:51
ptitpique

Bonjour,

Bon ben maintenant, j'ai un gros problème.

Le jeu ne marche plus et je n'ai plus les registres qui permettent de modifier la résolution.
J'ai essayé de réinstaller le jeu mais même chose
goku Wednesday 12 December 2007 at 11:57
goku

Alors, je vais te montrer ce que tu devrais avoir au bout du compte :
Normalement tu dois obteni quelque chose qui ressemble à ça.

Sinon, comme l'a souligné Tinou, fais attention à ne pas rentrer 1280 et 800 en hexadécimal. Car dans le jeu tu obtiendras du 4736x2048. Je ne pense pas que ton ecran ni ta carte graphique le supporte, ce qui expliquerait que le jeu plante

Windows de Microsoft.

Mac de Apple.

Linux du monde entier.
ptitpique Wednesday 12 December 2007 at 18:57
ptitpique

Oui mais voila ce que j'ai

Quentin PÂRIS Wednesday 12 December 2007 at 19:04
Quentin PÂRIS
Admin

Ta essayé de le désinstaller et de supprimer le préfixe ?
ptitpique Wednesday 12 December 2007 at 19:15
ptitpique

Je vais essayer tout de suite.

Edit : toujours la même chose

Editado por: ptitpique

goku Thursday 13 December 2007 at 11:47
goku

Je suis un peu perdu...
Tu peux faire une recherche de la clé resheight dans la base. Au moins on sera fixé si elle existe.

Sinon, étant donné que tu avais les bonnes clé à la première installation, c'est peut-etre un problème lors de l'installation.

Windows de Microsoft.

Mac de Apple.

Linux du monde entier.
ptitpique Thursday 13 December 2007 at 13:07
ptitpique

En fait, le problème était que j'ai utilisé wine 0.9.46 au lieu de 0.9.50.
Maintenant cela marche et j'ai la bonne résoltution
Mais la souris se déplace lentement
Peut être à cause de ma carte graphique : ATI mobility radeon X1400 avec les drivers 7.11 de ATI.
Sinon si vous avez moyen de m'aider pour optimiser le jeu avec cette carte je vous en seriez reconnaissant.

Editado por: ptitpique

Quentin PÂRIS Thursday 13 December 2007 at 16:06
Quentin PÂRIS
Admin

playonlinux --run "WarcraftIII" --opengl
ptitpique Thursday 13 December 2007 at 18:18
ptitpique

Merci pour tout