El Foro

Diablo 3 Blank Screen and Hang after hitting Play

Autor Respuestas
Jump to the page: 1 - 2
doff Sunday 20 May 2012 at 17:25
doffAnonymous

Debian Sid, 3.2.0-1-amd64
Diablo 3, 1.5.4
KDE Desktop
4.7.4
Nvidia TI 560 Driver: 295.49-1

Diablo 3 installs without a hitch, updates and finishes fine. When I hit play the screen either goes all gray and hangs then needs to be terminated, or just freezes the screen and nothing happens until I again terminate the program.

I ran with Debugging but did not see any errors that seemed to indicate a problem.

Let me know what other information I can provide.

Thanks,

Doff
Quentin PÂRIS Sunday 20 May 2012 at 17:56
Quentin PÂRIS
Admin

Please paste the debug log here
doff Sunday 20 May 2012 at 18:47
doffAnonymous

Not sure why but the Log doesent seem to show up in this topic when I reply and post it.

Thanks jockmock I should have thought of using pastebin as well, guess it just seemed odd that I couldnt paste a log here.

http://pastebin.com/PDNyEDra

Editado por: doff

doff Sunday 20 May 2012 at 18:57
doffAnonymous

Log file pasted.

Thanks,

Doff

Editado por: doff

jockmock Sunday 20 May 2012 at 20:29
jockmockAnonymous

I am having the exact same issue as Doff.

This is my debug log
http://pastebin.com/34NgWTvb

Please advice

Thanks in beforehand

Editado por: jockmock

petch Sunday 20 May 2012 at 21:50
petch
Developer


*** glibc detected *** C:/Program Files/Diablo III/Diablo III.exe: malloc(): memory corruption: 0xf505c340 ***


I have the same issue (glibc detecting all sorts of heap corruption) more and more often under Debian Sid when I use Wine, for different games; I don't know what they're currently breaking...

Often,

/usr/lib32/libXi.so.6(XIQueryDevice+0x1b3)

appears in my backtraces too.

I'm also using the nvidia proprietary driver, so it cannot be ruled out...

Editado por: petch

eigenroy Sunday 20 May 2012 at 23:08
eigenroyAnonymous

Ubuntu 12.04 - Installed fine. Initially got error 3007 so used the fix:

echo 0|sudo tee /proc/sys/kernel/yama/ptrace_scope

Now everything freezes upon hitting 'LOGIN' and requires a hard reboot.

Debug Log:
http://pastebin.com/abgPjUmK
Quentin PÂRIS Sunday 20 May 2012 at 23:17
Quentin PÂRIS
Admin

ALSA lib conf.c:3314:(snd_config_hooks_call) Cannot open shared library libasound_module_conf_pulse.so

Citar


Install 32bits alsa libs
petch Sunday 20 May 2012 at 23:28
petch
Developer


Feel free to create different threads for different issues.
eigenroy Sunday 20 May 2012 at 23:36
eigenroyAnonymous

ALSA lib conf.c:3314:(snd_config_hooks_call) Cannot open shared library libasound_module_conf_pulse.so

Citar


Install 32bits alsa libs

Quote from Tinou

Thanks, perhaps I should I look at my own logs closer.  The exact package needed was ia32-libs.

Sorry if I slightly derailed the thread.

EDIT:  I have appeared to have gotten lucky the first time.  The problem still persists.  Going to look closer before posting up an updated log.  

Editado por: eigenroy

petch Monday 21 May 2012 at 0:23
petch
Developer

Another one for completeness (sadly he received no answer yet):
http://lists.debian.org/debian-user/2012/05/msg01888.html

Editado por: petch

VulcanRidr Tuesday 22 May 2012 at 1:16
VulcanRidrAnonymous

Another one for completeness (sadly he received no answer yet):
http://lists.debian.org/debian-user/2012/05/msg01888.html

Quote from petch


Indeed. This was my post. I have been searching independently, trying small steps first. I found a post from Patrick Volkerding on http://www.linuxquestions.org/questions/slackware-14/dos-support-unavailable-855667/ dated 01-11-2011 where he suggested that vm.mmap_min_addr=0 might help.

It didn't. The Debian wiki stated that the default setting is 4096. Mine was set to 65536 (possibly because I have 8GB of RAM). I set it to 4096, but there was no change. Even setting it to 0 had no effect.

Next, I plan to try the non-free nvidia drivers in experimental. If those don't work, I will roll back to the previous version.

--vr
VulcanRidr Thursday 24 May 2012 at 0:24
VulcanRidrAnonymous

Another one for completeness (sadly he received no answer yet):
http://lists.debian.org/debian-user/2012/05/msg01888.html

Quote from VulcanRidr


Indeed. This was my post. I have been searching independently, trying small steps first. I found a post from Patrick Volkerding on http://www.linuxquestions.org/questions/slackware-14/dos-support-unavailable-855667/ dated 01-11-2011 where he suggested that vm.mmap_min_addr=0 might help.

It didn't. The Debian wiki stated that the default setting is 4096. Mine was set to 65536 (possibly because I have 8GB of RAM). I set it to 4096, but there was no change. Even setting it to 0 had no effect.

Next, I plan to try the non-free nvidia drivers in experimental. If those don't work, I will roll back to the previous version.

--vr

Quote from petch


New kernel and new version of the nvidia drivers in the sid repos today. Dist-upgraded, rebooted. Still the same indications:


[install_plugins] Message: Checking plugin: Offline PlayOnLinux...
/usr/share/playonlinux/lib/plugins.lib: line 85: let: 5 offlineplayonlinux: syntax error in expression (error token is "offlineplayonlinux")
/usr/share/playonlinux/lib/plugins.lib: line 90: [: too many arguments
[install_plugins] Message: Checking plugin: Capture...
[b]snip[/b]
[Check_OpenGL] Message: 32bits direct rendering is enabled
[POL_System_CheckFS] Message: Checking filesystem for StarCraft II.exe
[POL_Wine] Message: Running wine- StarCraft II.exe
[POL_Wine] Message: Notice: PlayOnLinux deliberately disables winemenubuilder. See http://www.playonlinux.com/fr/page-26-Winemenubuilder.html
[POL_Wine] Message: Wine return: 0
*** glibc detected *** C:\\Program Files\\StarCraft II\\Versions\\Base21029\\SC2.exe: malloc(): memory corruption: 0xf5662668 ***
======= Backtrace: =========
/lib32/libc.so.6(+0x6f121)[0xf74a7121]
/lib32/libc.so.6(+0x71f24)[0xf74a9f24]
/lib32/libc.so.6(__libc_malloc+0x5c)[0xf74abb2c]
/usr/lib32/libXi.so.6(XIQueryDevice+0x140)[0x7db378d0]
/usr/lib32/wine-unstable/winex11.drv.so(+0x38f75)[0x7ddf4f75]
[b]snip[/b]
7dc60000-7dc78000 r-xp 00000000 fe:05 792641 /usr/lib32/libxcb.so.1.1.0 7dc78000-7dc79000 rw-p 00017000 fe:05 792641 /usr/lib32/libxcb.so.1.1.0 7dc79000-7dd92000 r-xp 00000000 fe:05 792386 /usr/lib32/libX11.so.6.3.0 7dd92000-7dd96000 rw-p 00118000 fe:05 792386 /usr/lib32/libX11.so.6.3.0





Anyone else have any better luck or other suggestions? I have not gotten around to upgrading the drivers to the 302 series in unstable yet due to excessive demands on my time. Hopefully this weekend. I'm also concerned about the syntax errors in the script (/usr/share/playonlinux/lib/plugins.lib: line 85: let: 7 capture: syntax error in expression (error token is "capture")) --vr

Editado por: VulcanRidr

petch Thursday 24 May 2012 at 1:32
petch
Developer

"Offline playonlinux" extension does not work anymore with PlayOnLinux 4.x, you can disable it.
VulcanRidr Thursday 24 May 2012 at 2:07
VulcanRidrAnonymous

"Offline playonlinux" extension does not work anymore with PlayOnLinux 4.x, you can disable it.

Quote from petch


Okay, that's cool. What about the "let" not being recognized?
petch Thursday 24 May 2012 at 3:30
petch
Developer

http://forums.debian.net/viewtopic.php?f=6&t=79859
It seems ia32-libs is lagging behind the rest of the system, to the point some things started to break...
Workaround for the time being:
* Download libxi6 compiled for i386 architecture:
http://packages.debian.org/sid/i386/libxi6/download
* Take libXi.so.6 lib out of the package and overwrite ia32-libs one with it

$ dpkg -x libxi6_1.6.1-1_i386.deb /tmp/libxi6
$ cd /tmp/libxi6/usr/lib/i386-linux-gnu
$ sudo cp -av libXi.so.6* /usr/lib32/

Editado por: petch

doff Thursday 24 May 2012 at 5:42
doffAnonymous

Is the fix to the crashing supposed to be adding alsa32bit? I have the ia32-libs. I got confused when the post seemed to be derailed a bit.

Petch I have the ia32-libs, should I be trying your patch to fix this error

ALSA lib ../../src/conf.c:3314:(snd_config_hooks_call) Cannot open shared library libasound_module_conf_pulse.so
ALSA lib ../../../src/pcm/pcm.c:2217:(snd_pcm_open_noupdate) Unknown PCM default
ALSA lib ../../src/dlmisc.c:254:(snd1_dlobj_cache_get) Cannot open shared library /usr/lib32/alsa-lib/libasound_module_pcm_pulse.so

Thanks,

Doff
VulcanRidr Thursday 24 May 2012 at 15:24
VulcanRidrAnonymous

http://forums.debian.net/viewtopic.php?f=6&t=79859
It seems ia32-libs is lagging behind the rest of the system, to the point some things started to break...
Workaround for the time being:
* Download libxi6 compiled for i386 architecture:
http://packages.debian.org/sid/i386/libxi6/download
* Take libXi.so.6 lib out of the package and overwrite ia32-libs one with it

$ dpkg -x libxi6_1.6.1-1_i386.deb /tmp/libxi6
$ cd /tmp/libxi6/usr/lib/i386-linux-gnu
$ sudo cp -av libXi.so.6* /usr/lib32/

Quote from petch


Thanks petch! I'll give it a try when I get home tonight. Next up on my list is to remove pulseaudio once and for all.

--vr
kneissel Thursday 24 May 2012 at 22:12
kneisselAnonymous

Hello,
I just give a try and it works fine, thanks a lot petch.
petch Thursday 24 May 2012 at 22:47
petch
Developer

You're welcome!
I'm so glad it works on my box too :)