[SOLVED] League of Legends crash in Launcher (ALSA?)

When clicking the Play button in the Launcher, LoL crashes

Autor Odpowiedzi
yorrd Sunday 16 February 2014 at 12:31


I've been doing my research for the last 2 days now and I got nothing else to try. As said in the title, LoL crashes instantly when I press the play button in the patcher / launcher with this error message (see below for more information): 

Unhandled exception: page fault on read access to 0x00001ff0 in 32-bit code (0x00001ff0).
Register dump:
 CS:0023 SS:002b DS:002b ES:002b FS:0063 GS:006b
 EIP:00001ff0 ESP:0033e37c EBP:00000009 EFLAGS:00010246(  R- --  I  Z- -P- )
 EAX:ffaa2294 EBX:f773efbc ECX:00000004 EDX:7d0edee4
 ESI:00000000 EDI:7d0edcd4
Stack dump:
0x0033e37c:  f772d00e 00000009 ffaa2294 ffaa22bc
0x0033e38c:  00000001 f773f000 00000000 7dd62138
0x0033e39c:  f773efbc 0000000e 7de59130 00000034
0x0033e3ac:  f772d104 ffaa2294 ffaa22bc 00000000
0x0033e3bc:  f752a000 f752a420 00000009 ffaa2294
0x0033e3cc:  f73f8928 80000000 7d7f41c8 f772d08b
=>0 0x00001ff0 (0x00000009)
0x00001ff0: -- no code accessible --
Module Address Debug info Name (126 modules)
PE  400000-  416000 Deferred        lolclient
PE 10000000-114d1000 Deferred        adobe air
PE 70200000-70294000 Deferred        wininet
PE 702b0000-70328000 Deferred        urlmon
PE 70440000-704cf000 Deferred        mlang
PE 70bd0000-70c34000 Deferred        shlwapi
ELF 7b800000-7b916000 Deferred        kernel32<elf>
  \-PE 7b810000-7b916000 \               kernel32
ELF 7bc00000-7bcdf000 Deferred        ntdll<elf>
  \-PE 7bc10000-7bcdf000 \               ntdll
ELF 7bf00000-7bf03000 Deferred        <wine-loader>
ELF 7cf16000-7cf30000 Deferred
ELF 7cf30000-7cf38000 Deferred
ELF 7cf38000-7cf64000 Deferred
ELF 7cf64000-7cff0000 Deferred
ELF 7cff0000-7d025000 Deferred
ELF 7d025000-7d0c8000 Deferred
ELF 7d0c8000-7d0ef000 Deferred
ELF 7d0ef000-7d163000 Deferred
ELF 7d163000-7d183000 Deferred
ELF 7d183000-7d1cf000 Deferred
ELF 7d1cf000-7d248000 Deferred
ELF 7d248000-7d299000 Deferred
ELF 7d299000-7d392000 Deferred
ELF 7d3b0000-7d3df000 Deferred        winealsa<elf>
  \-PE 7d3c0000-7d3df000 \               winealsa
ELF 7d3df000-7d400000 Deferred        mmdevapi<elf>
  \-PE 7d3e0000-7d400000 \               mmdevapi
ELF 7d506000-7d51b000 Deferred        schannel<elf>
  \-PE 7d510000-7d51b000 \               schannel
ELF 7d51b000-7d53f000 Deferred        imm32<elf>
  \-PE 7d520000-7d53f000 \               imm32
ELF 7d599000-7d5a0000 Deferred
ELF 7d605000-7d618000 Deferred        psapi<elf>
  \-PE 7d610000-7d618000 \               psapi
ELF 7d618000-7d67f000 Deferred        dbghelp<elf>
  \-PE 7d620000-7d67f000 \               dbghelp
ELF 7d67f000-7d6f3000 Deferred
ELF 7d6f3000-7d78b000 Deferred
ELF 7d78b000-7d7aa000 Deferred        dnsapi<elf>
  \-PE 7d790000-7d7aa000 \               dnsapi
ELF 7d7aa000-7d7f3000 Deferred        dsound<elf>
  \-PE 7d7b0000-7d7f3000 \               dsound
ELF 7d7f3000-7d80b000 Deferred
ELF 7d80e000-7d819000 Deferred
ELF 7d819000-7d829000 Deferred
ELF 7d829000-7d84e000 Deferred        iphlpapi<elf>
  \-PE 7d830000-7d84e000 \               iphlpapi
ELF 7d84e000-7d87a000 Deferred        netapi32<elf>
  \-PE 7d850000-7d87a000 \               netapi32
ELF 7d87a000-7d8ac000 Deferred        secur32<elf>
  \-PE 7d880000-7d8ac000 \               secur32
ELF 7d8ac000-7d8f9000 Deferred
ELF 7d8f9000-7d919000 Deferred        mscms<elf>
  \-PE 7d900000-7d919000 \               mscms
ELF 7d919000-7d959000 Deferred        winspool<elf>
  \-PE 7d920000-7d959000 \               winspool
ELF 7d959000-7da44000 Deferred        comdlg32<elf>
  \-PE 7d960000-7da44000 \               comdlg32
ELF 7da44000-7da67000 Deferred        oleacc<elf>
  \-PE 7da50000-7da67000 \               oleacc
ELF 7da67000-7da91000 Deferred        msacm32<elf>
  \-PE 7da70000-7da91000 \               msacm32
ELF 7da91000-7db4b000 Deferred        winmm<elf>
  \-PE 7daa0000-7db4b000 \               winmm
ELF 7db4b000-7db80000 Deferred        ws2_32<elf>
  \-PE 7db50000-7db80000 \               ws2_32
ELF 7db80000-7dbb6000 Deferred        uxtheme<elf>
  \-PE 7db90000-7dbb6000 \               uxtheme
ELF 7dbb6000-7dbbc000 Deferred
ELF 7dbbc000-7dbc7000 Deferred
ELF 7dbc7000-7dbd8000 Deferred
ELF 7dbd8000-7dbe3000 Deferred
ELF 7dbe3000-7dbee000 Deferred
ELF 7dbee000-7dc13000 Deferred
ELF 7dc13000-7dd4a000 Deferred
ELF 7dd4a000-7dd5d000 Deferred
ELF 7dd61000-7dd68000 Deferred
ELF 7dd68000-7dd7b000 Deferred        msimg32<elf>
  \-PE 7dd70000-7dd7b000 \               msimg32
ELF 7dd7b000-7de0d000 Deferred        winex11<elf>
  \-PE 7dd90000-7de0d000 \               winex11
ELF 7df0d000-7df36000 Deferred
ELF 7df36000-7df71000 Deferred
ELF 7df71000-7dfaa000 Deferred
ELF 7dfaa000-7dfba000 Deferred
ELF 7dfba000-7e05b000 Deferred
ELF 7e079000-7e08d000 Deferred
ELF 7e08d000-7e0ad000 Deferred        cabinet<elf>
  \-PE 7e090000-7e0ad000 \               cabinet
ELF 7e0ad000-7e1e4000 Deferred        oleaut32<elf>
  \-PE 7e0c0000-7e1e4000 \               oleaut32
ELF 7e1e4000-7e2b3000 Deferred        crypt32<elf>
  \-PE 7e1f0000-7e2b3000 \               crypt32
ELF 7e2b3000-7e3f1000 Deferred        ole32<elf>
  \-PE 7e2d0000-7e3f1000 \               ole32
ELF 7e414000-7e498000 Deferred        rpcrt4<elf>
  \-PE 7e420000-7e498000 \               rpcrt4
ELF 7e498000-7e596000 Deferred        msi<elf>
  \-PE 7e4a0000-7e596000 \               msi
ELF 7e596000-7e69c000 Deferred        comctl32<elf>
  \-PE 7e5a0000-7e69c000 \               comctl32
ELF 7e69c000-7e7f7000 Deferred        user32<elf>
  \-PE 7e6b0000-7e7f7000 \               user32
ELF 7e7f7000-7e866000 Deferred        advapi32<elf>
  \-PE 7e800000-7e866000 \               advapi32
ELF 7e866000-7e97e000 Deferred        gdi32<elf>
  \-PE 7e870000-7e97e000 \               gdi32
ELF 7e97e000-7ea2a000 Deferred        msvcrt<elf>
  \-PE 7e990000-7ea2a000 \               msvcrt
ELF 7ea2a000-7ec5e000 Deferred        shell32<elf>
  \-PE 7ea40000-7ec5e000 \               shell32
ELF 7ec5e000-7ec6b000 Deferred
ELF 7ef9c000-7efe2000 Deferred
ELF 7efe3000-7efe7000 Deferred
ELF 7efe7000-7f000000 Deferred        version<elf>
  \-PE 7eff0000-7f000000 \               version
ELF f7371000-f737a000 Deferred
ELF f737b000-f7380000 Deferred
ELF f7381000-f752e000 Deferred
ELF f752e000-f754a000 Deferred
ELF f754a000-f7550000 Deferred
ELF f7564000-f7568000 Deferred
ELF f7568000-f771d000 Dwarf 
ELF f771e000-f7740000 Deferred
ELF f7740000-f7741000 Deferred        [vdso].so
process  tid      prio (all id:s are in hex)
0000000e services.exe
0000001d    0
0000001c    0
00000018    0
00000016    0
00000014    0
00000010    0
0000000f    0
00000012 winedevice.exe
00000019    0
00000017    0
00000013    0
0000001a plugplay.exe
0000001f    0
0000001e    0
0000001b    0
00000020 rads_user_kernel.exe
0000002d    0
0000002c    0
0000002b    0
0000002a    0
00000029    0
00000027    0
00000026    0
00000021    0
00000024 explorer.exe
0000002f    0
00000025    0
00000030 LoLLauncher.exe
0000003b    0
0000003a    0
00000039    0
00000033    0
00000032    0
00000031    0
0000003c (D) C:\Riot Games\League of Legends\RADS\projects\lol_air_client\releases\\deploy\LolClient.exe
00000045    0
00000044    0
00000043    0
00000042    0
00000041    0
00000040    0
0000003f    0
0000003e    0
0000003d    0 <==
System information:
    Wine build: wine-1.7.1-158-g88c2a18
    Platform: i386
    Host system: Linux
    Host version: 3.13.3-1-ARCH

The debugger gives me:

ALSA lib dlmisc.c:252:(snd1_dlobj_cache_get) Cannot open shared library /usr/lib32/alsa-lib/


wine: Unhandled page fault on read access to 0x00001ff0 at address 0x1ff0 (thread 003d), starting debugger...

is this an ALSA problem? I'm quite sure I installed all libraries, also the 32 bit ones. Moreover they should be included in the installer script anyways, I heard. 

I'm on 3.13 Arch Linux, Xmonad window manager. In my old Mint and Arch installations LoL worked flawlessly (neglecting the usual store and icon issues), I'm not sure what I'm doing wrong this time. I already tried reinstalling and the latest proprietary nVidia drivers are running.

Thanks in advance for your help!

Edytowane przez yorrd

bockscar Tuesday 18 February 2014 at 2:38

With the information provided, it's difficult (for me) to tell what could be going wrong here. "Unhandled exception: page fault on read access" is a pretty generic exception. I can say that the ASLA is not likely to be your problem. Worse case scenario, once you get into the game you may not have sound, but that's about it.
yorrd Tuesday 18 February 2014 at 23:28

Hey, first of all, thanks for your reply.

I do realize I can't give a whole lot of useful information here, anything specific I could get for you in order to improve my chances of someone being able to help? I just don't have any ideas what to give you guys anymore.

Well okay... that wouldn't be that big an issue. Any other idea what it could be about?

Thanks in advance,
yorrd Saturday 22 February 2014 at 18:50

Okay, I was able to fix this.

The problem was that my .wine prefix was a 64-bit installation. Yes, I did use the playonlinux script, but I'm on arch and the ARCHLINUX variable wasnt set to win32.

Check this out if you're on 64-bit arch:

I now used the manual installation script provided in the first comment of the appdb entry on which worked out fine after installing the multilib-devel packages from the arch repository.

Hope this helps some people,


This site allows content generated by members, and we promptly remove any content that infringes copyright according to our Terms of Service. To report copyright infringement, please send a notice to