Skyrim - ATI - Mint 16 Cinnamon

Autor Odpowiedzi
stimpe Monday 17 February 2014 at 23:59

Hello, I recently tried to install skyrim because I heard how easy playonlinux was to install emulated games, but im having trouble getting it to run, here's what I'm running and what ive tried so far

-Linux Mint 16 Cinnamon
-ATI Catalyst beta 14.1 with catalyst control center (problems started after updated from xorg-xserver-ati-video to beta 14.1, but xorg drivers gave black screen in game)
-Playonlinux installed ok, have tried Wine 1.7.12 and 1.7.8. have tried GLSL support enabled. have tried emulate desktop. windows version set to 7.

-Intel i7 930
-AMD Radeon HD 7870
-12 GB ram

here is a debug file of playonlinux - skyrim

In POL i am trying to run steam to download skyrim, it asks for login info, logs in and then crashes saying

Error in main
Steam (The Elder Scrolls V : Skyrim) crashed.
Click on debug link to get more details.

Im not a linux genius and nothing in the debug log is popping out at me. Any help is appreciated!

Edytowane przez stimpe

bockscar Tuesday 18 February 2014 at 2:36

I'm a little fuzzy on the part where you say "In POL i am trying to run steam to download skyrim, it asks for login info, logs in and then crashes..". Are you saying it crashes upon logging into Steam? Can you just log into Steam and navigate around?

In your debug I am seeing a number of things that are alarming (though no smoking guns):

err:setupapi:create_dest_file failed to create L"C:\\windows\\system32\\mscoree.dll" (error=80) - Sounds like a problem with your Wine installation

err:winediag:SECUR32_initNTLMSP ntlm_auth was not found or is outdated. Make sure that ntlm_auth >= 3.0.25 is in your path. - Make sure winbind is installed on your Linux distro

ALSA lib conf.c:3314:(snd_config_hooks_call) Cannot open shared library - I've seen this before. I've read that Wine doesn't like PulseAudio much but I haven't heard of Wine crashing because of it. Make sure you have that library installed on your Linux distro

From the looks of the debug log, it would seem that you tried to run/install Skyrim several times and failed each time. Here's what I would recommend:

1. Don't use the "Skyrim" prefix in POL. Install Steam using the POL prefix and then install Skyrim into that. This method isn't best practice but, I have had the most success doing it this way.
2. Use the most recent development version of Wine (1.7.12 right now I think).
3. Make sure you have all the dependancies and requirements installed before you dive in, especially winbind.
stimpe Tuesday 18 February 2014 at 2:50

Yes it crashes upon logging into steam - i am unable to open steam at all

going through your things you see wrong
-wine installation: through POL i removed all wine versions
-winbind: "samba nameservice integration server" ? not seeing why this is required but i will install it
-ALSA: how can i make sure that library is installed? what am i looking for exactly?

I will try installing steam in POL and then installing skyrim, will let you know what happens, thank you for the help!
stimpe Tuesday 18 February 2014 at 3:19

I removed the wine versions in POL. I then removed POL and wine in software manager. I installed winbind, and reinstalled POL. Installed Steam (preconfigured way) in POL, which in turn installed wine. Installed wine 1.7.12 and tried running Steam, didnt work, here is the newest log file.

oh and also in POL when I click configure wine I verified my audio was working through the test button

any more ideas?
bockscar Thursday 20 February 2014 at 5:36

Don't worry too much about removing Wine installations through POL, unless you are having disk space issues. I always just use the latest version of Wine with mine.

As far as winbind goes.. Sure? If the debug log is saying it is missing, just install it. That's how I do my debugging ;)

I wouldn't worry about ASLA until you know it's an issue. Having a problem with ASLA will not likely prevent Steam from launching.

That is so odd, I have no idea why it is crashing. I am using almost the exact same setup as you, only I am running Ubuntu instead of Mint.

This may not make a difference but, could you go to the directory where your debug file is and delete it, close POL down entirely, run debug again, and then post that? I want to see a totally clean debug log.