Ableton Live 9 - Failed to open WineASIO Driver

Targeted at DJYoshaBYD ;)

Autor Odpowiedzi
joe42 Saturday 22 February 2014 at 0:33

I'm on Arch Linux, i3 WM, no desktop environment.

I've got PlayOnLinux 4.2.2 with Wine 1.7.13, and Ableton Live 9 installed with the POL script (the script uses a 1.5.x Wine, but I've tried that and 1.7.13).

I did the "install component" for wineasio, it ran and gave no errors, but didn't say "success" or anything (not sure if it's supposed to).

I have jackd running (qjackctl says "running" and "rolling"--no idea what "rolling" is).

`regsvr32 wineasio.dll` worked successfully.

In Live's settings, I can select Driver Type = ASIO, and under Audio Device I can select WineASIO Driver, but it gives me an error: "Failed to open the audio device WineASIO Driver"

Live is the 32 bit version.

I don't understand the ASIO -> JACK part. There may be some configuration there that I haven't done?

Thanks very much.
Ronin DUSETTE Wednesday 26 February 2014 at 19:37

That is not how you do it.

You need to install WineASIO from WITHIN POL. If it installed with no errors, do NOT run regsvr32 wineasio.dll. That is for your system wine, not POL. POL is completely separate.

In order to run WineASIO, you need to understand how jack works. Jack server needs to be running, your audio device needs to be configured, plugged in, and powered on. If your system cannot recognize your low-latency device, then WineASIO will fail like it did.

You need to check your jack settings.

Again, if the install for WineASIO worked with no errors, it IS installed. Its a very simple "bridge", if you will, from Wine to Jack.

You also need realtime priority turned on, etc.. Pretty much, WineASIO is trivial to install, and you got no errors, so there is something wrong with your jack setup or your permissions to use RT priority, or maybe even something else. It is not dependent on any specific wine version, so that isnt an issue.

If you dont know what "rolling" means, in the context of Jack, then you need to read the tutorials on how to use it correctly. Dont worry about WineASIO yet. It certainly would have thrown an error if it failed to install. If it said nothing, its good, and your systems setup is incorrect somewhere.

You need:

-your user to be part of the "audio" group

-32 bit install of audio software (which you already did)

-real-time access via jack (read the manual for it)

-audio interface plugged in and powered on. Make sure it works WITHOUT jack/wineasio first. If your system doesnt see it, jack will not either.

-when starting jack, settings should show that it sees your interface (read the manual)

So, go back, check your jack and audio interface settings. I doubt there is an issue with wineasio, as it has very few requirements, and I have tested this like, MANY times (I just tested again on my laptop, fresh install of Arch, fresh ableton 9 install, fresh wineasio install, and it worked with no issues), so far, for me, it literally never fails, and if it does not work for whatever reason, it has been a jack problem, showing that the wineasio install is pretty much foolproof. The jack/system setup is where people get it mixed up.

Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
joe42 Wednesday 26 February 2014 at 21:24

Ok, I'll read more on Jack (I admittedly know nothing about it).

Borrowed a spare MacBook, so I took the easy way out for now, though :)

cenoura Tuesday 24 June 2014 at 0:47


I'm having the same problem. Running Arch Linux with Ableton 9 (32bit).

Jackd seems to be working ok: I can play music in clementine via Jack (choose "Audio Sink (jack)") and even in Ableton, if I choose "MME/DirectX" and play a sound I can see in qjackctl its created a connection named alsa-jack.jackP.xxxxx.x. But once I choose "ASIO/WineASIO Driver" e pops the "Failed to open the audio device WineASIO Driver".

Could you please specify which packages did you installed on Arch (like lib32-jack2, qjackctl, lib32-alsa-plugins, lib32-mpg123...)? Do I need wineasio from AUR? Any extra configuration in /etc/asound.conf?