Fora

Crackling sound in games

Crackle sound

Autor Odpowiedzi
zilent Monday 10 November 2014 at 17:01
zilentAnonymous

Whilst in a game on wine ill get the a problem with the sound. It goes crackly and has an impact on the games performance. I think it has something to do with pulseaudio becasue the cpu usage will go up for pulseaudio. The error in the debug is "ALSA lib pcm.c:7843:(snd_pcm_recover) underrun occurred" which will just keep repeating until it stops. Is there any way to stop this?

 

Ronin DUSETTE Monday 10 November 2014 at 17:30
Ronin DUSETTE
Admin

Thats so strange, because I use pulse all of the time and have never had this happen. I believe there are some 32 bit alsa packages that should be installed, as well as a pulse-alsa package or something to that extent that need to be installed as well. I even make music through wine and pulse, and it has just always worked. No extra packages needed, no configuration, either. I am running kubuntu 14.04 64 bit, if you were curious.


Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
zilent Monday 10 November 2014 at 18:15
zilentAnonymous

If it helps any way im on LMDE

Ronin DUSETTE Monday 10 November 2014 at 19:05
Ronin DUSETTE
Admin

First thing I would do is make sure that you have all of your 32-bit libraries installed for audio. Other than that, I don't know what would cause it. Can you post up your full computer specs along with graphics card infor a driver info (this should be in the first post anyway)?


Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
xpander Tuesday 11 November 2014 at 11:55
xpander

try and install pavucontrol and open it up before you go into game.. i have seen some integrated soundcards starting to work after that(it probably just gives some more priority to sound server, no idea)

 

if that doesnt help you can try install paprefs and go to simultaneous output tab and enable it

then go to your normal volume properties and output tab and select simultaneous output

 

third thing to try is to tweak your pulseaudio settings: 

https://wiki.archlinux.org/index.php/PulseAudio#Setting_the_default_fragment_number_and_buffer_size_in_PulseAudio

Ronin DUSETTE Wednesday 12 November 2014 at 6:07
Ronin DUSETTE
Admin

 

try and install pavucontrol and open it up before you go into game.. i have seen some integrated soundcards starting to work after that(it probably just gives some more priority to sound server, no idea)

 

if that doesnt help you can try install paprefs and go to simultaneous output tab and enable it

then go to your normal volume properties and output tab and select simultaneous output

 

third thing to try is to tweak your pulseaudio settings: 

https://wiki.archlinux.org/index.php/PulseAudio#Setting_the_default_fragment_number_and_buffer_size_in_PulseAudio

 

I actually always install pavucontrol, but never open it. Nevertheless, it is installed. I wonder if that or paprefs pulls in some needed dependencies? 


Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts