Fora

No sound on Traktor

Autor Odpowiedzi
Shaku Wednesday 21 January 2015 at 21:40
Shaku

Linux version: Ubuntu 14.04

Version de POL: 4.2.5

I'm new on linux, I want to know how to config. Traktor shows me only one audio card.

When I installed the software, I followed these steps:
1- install wine
2- install POL
3- search Traktor Pro 2 and complete the instalation with "Traktor 2 2.6.2 Setup PC.exe".


Please, help me frown  I dont find any tutorial.

 

Ronin DUSETTE Wednesday 21 January 2015 at 21:56
Ronin DUSETTE
Admin

Check your audio settings in Ubuntu. You will likely need to adjust it to output the sound. It has your soundcard detected, so it should work. What other options does it have listed in the Audio Device menu and in Built-In Soundcard? 

Oh, and in your picture, it says in that bright red bar to check your output routing in traktor. You did that, right? That would be the first thing you should check. If you need to know how to configure that in Traktor, you will need to refer to the user's manual, but it is pretty easy when you look at it. If your audio output routing is not set up, then audio will go nowhere. 

Edytowane przez RoninDusette


Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
Shaku Wednesday 21 January 2015 at 22:26
Shaku

Audio settings in Ubuntu works fine (i've check)
In Traktor > Audio Setup i have only 1 audio device to select (picture) Just as in Built-In Soundcard.

In Output Routing: mixing mode is Internal and i can't select anything in Left or Right outputs.

PD: when i first open Traktor works fine, but then no. I try reinstalling, but nothing change. The error persists

Ronin DUSETTE Wednesday 21 January 2015 at 22:27
Ronin DUSETTE
Admin

You mean that the sound works fine, THEN the sound stops? So, the sound plays, but only for a moment, and then it stops?


Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
Ronin DUSETTE Wednesday 21 January 2015 at 22:30
Ronin DUSETTE
Admin

OH. I see a problem that would cause that. At the top of the screen, there is a meter that says LOAD, and it is in the red, according to your picture. That would cause the audio engine to crash. You are going to need to run it through an audio interface through WineASIO/Jack. Your CPU is going through the roof because it cannot handle the sound processing, which is why you would want an audio interface. That is at least part of the problem for sure. 


Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
Shaku Thursday 22 January 2015 at 1:37
Shaku

I reinstalled all (Ubuntu, Wine, POL, Traktor) and at the first launch works fine, i been mixing and then close.

Then I install "libgstreamer-plugins-bad" and other libs for .m4a extensions.

Then I relaunch Traktor and back to same soundcard problem.

I know, I'm a newbie, but i can't understand why, I will find support from a friend who is a dj and linux user. Finally, try to configure WineASIO.

Thanks and sorry if my english is not so well.. =)

Ronin DUSETTE Thursday 22 January 2015 at 1:55
Ronin DUSETTE
Admin

It's not a problem. Like I said, I can see that your CPU is pegging out, which is causing the audio to die, so that would need to be addressed. Though, with WineASIO, Jack, and audio hardware capable of handling the audio engine, you should be able to get it working just fine.

Also, there are native Linux alternatives, one of my favourites is called Mixxx. It is free, powerful, has a GREAT set of features and hardware support, and runs on Linux just fine. Might be something to check out. I stopped using Traktor last year because Mixxx takes care of what I need.

http://www.mixxx.org/


Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts