Fora

I have problems with diablo 3 installing (battle.net black screen)

Autor Odpowiedzi
zaphiel Wednesday 20 January 2016 at 21:59
zaphielAnonymous

Hello!

First of all, i don't know how to search on this forum, so... if yet exist post with this problem, please, link me it.

I'm trying install battle.net with PlayOnLinux but i have a problem, when i put my credentials (user and password), appears screen battle.net, but is black, so i cant see interface program.

I have PlayOnLinux 4.2.0 version, and i have the librarys that i need (i think...), i have other game and it works correctly. I want install battle.net because i want play Diablo III with Debian.

I saw it that Diablo III needs wine needs wine 1.7.15 version... i have wine 1.6.2 on terminal, but playonlinux can use all versions, right? How can i update or install wine 1.7.15 manually? apt-get install wine1.7 get me error...

Someone can help me?

Thanks!.

petch Thursday 21 January 2016 at 2:01
petch
Developer

Hi,

First, there's no PlayOnLinux 4.2.0; And if you mean 4.2, you shouldn't be using that version. Not only this version is turning 3 years old, but this was a short lived version, replaced one week later by a version 4.2.1 that fixed a critical bug. For this reason it's not supported.

Now, use more Wine versions, it's a two steps process: first install more versions, then change the version used by the virtual drive(s) you want (each virtual drive can use a different version).

1. Tools > Manage Wine versions

2. Configure button > (select virtual drive) > General tab > Wine version

Note that for convenience, next to "Wine version" in the second step you have a "+" button that allows to open the Wine versions manager (the window that opens in the first step).

zaphiel Thursday 21 January 2016 at 11:12
zaphielAnonymous

I'm sorry, i write 4.2.0 but my version is 4.2.10...

I have installed more versions wine how you say me, and i have now 1.9.1-staging, 1.9.1, 1.9.0, and 1.7.15(32 bits versions) but battle.net black screen still appears. I need 64 bits versions too? I see on this link that Diablo III needs 1.7.15 wine version.

 

Edytowane przez zaphiel

petch Thursday 21 January 2016 at 17:28
petch
Developer

You cannot use 64bit Wine versions with virtual drives that have been created as 32bit and vice-versa, that's a Wine limitation. So to use 64bit versions you'd have to reinstall your game from scratch, if it can be made to work under 64bit Wine.

I don't know about Battle.NET specifically, maybe they broke Wine compatibility, maybe the problem is elsewhere (video drivers being next suspect).

Edytowane przez petch

zaphiel Thursday 21 January 2016 at 18:05
zaphielAnonymous

I can not find information on google (or looking bad) about compatibility issues with battle.net, only distortion problems. I have not installed nvidia drivers, I'm using xserver I think ... but another game (league of legends) does not give me problems. I tried to install nvidia drivers (gtx 850m in this case), but messed up something, and I had to return to xserver.

petch Thursday 21 January 2016 at 19:20
petch
Developer

I still highly recommend proprietary drivers for gaming

zaphiel Friday 22 January 2016 at 10:58
zaphielAnonymous

I dont know how to install propietary drivers on reliable way. Can you say me? yesterday i install it but crashed and i had to return xserver...

 

I see that i need to install Bumbleblee, but can you say me a reliable way to return xserver in case of something goes wrong?

 

Thanks

petch Friday 22 January 2016 at 11:51
petch
Developer

I use Debian (Sid) packages; I have no personal experience with hybrid graphic subsystem. I suspect most of your issues come from the latter, because otherwise the packages work quite well.

 

zaphiel Friday 22 January 2016 at 11:57
zaphielAnonymous

I dont know what is Sid packages...

I see that i can install propietary drivers with this guide but my graphic card is gtx 850M.

petch Friday 22 January 2016 at 15:37
petch
Developer

Debian Sid is the name of Debian unstable.

I use a method similar to what's described in https://wiki.debian.org/NvidiaGraphicsDrivers#Version_340.65

zaphiel Friday 22 January 2016 at 23:13
zaphielAnonymous

Well... i tried install nvidia drivers of this guide but broken, i had to return xorg... i wait someone with diablo 3 say me if he use nvidia/amd drivers or not, i have other game(LoL) and no problems...

I had version 340.65 and i had problems too... I dont know what can i do. I wanna play diablo :(