run a PlayonLinux prefix in terminal

Autor Odpowiedzi
zonzon510 Monday 1 October 2018 at 3:22


I am new to playonlinux and wine. I am running a game (Supreme commander) on steam. I'm able to run it successfully by using PlayonLinux with wine 3.15 to start Steam, from there i can run the game and it works. However, I am using a downloaded multiplayer client that is seperate from the original game on Steam. The client runs on linux without Steam, and it needs to launch the game directly, so I cannot use PlayOnLinux directly to launch it. I need to provide the wine prefix for the multiplayer client to run the game, and I am trying to use the same as PlayonLinux is using. In the settings of the game client I've provided the wine prefix which playonlinux says it uses on the GUI, "~/.PlayOnLinux/wineprefix/Steam". However when the multiplayer client tries to launch a game it immediately throws an error. By running  "WINEPREFIX=~/.PlayOnLinux/wineprefix/Steam wine Steam.exe -no-cef-sandbox" in terminal I can start steam and then when I start the game I get that same error I mentioned before. I think the problem will be solved if I can find out how to run a program as PlayOnLinux does on command line, but it seems to be adding some other settings other than the wine prefix. I've also used "winecfg" to verify that the settings are the same as listed on the PlayOnLinux GUI. Does someone know how to do this or what the problem is?



Dadu042 Sunday 24 March 2019 at 17:56