CLSID in debug

'File writer'

Autor Odpowiedzi
brcisna Saturday 6 April 2019 at 19:43

Hello, All,



Wine 1.8.7 (stock) on Debian Stretch 64-bit.

-i386 libraries installed.

CrazyTalk8 - to install.


Trying to see if I can get CrazyTalk8 to run on wine/PlayOnLinux. Have tried off and on for three days now,and most everything works except trying to import either music or voice files in .mp3 format (which is supported) and running in debug from POL console, when trying to import a MP3 file it shows the following

err:ole:CoGetClassObject no class object {8596e5f0-0da5-11d0-bd21-00a0c911ce86} could be created for context 0x1

This CLSID in windows registry,shows up as 'friendly name' ,file writer. Looking at wine registry compared to an actual Windows 10 machine(64-bit) machine the registry entries are totally different in regards to structured entries.


Importing .wav files works fine. Can also ONLY export the projects as MP3 format ,so the mov,avi,webm throws error exporting..(just the reverse of importing formats) 

Also adding ,before adding the K-Lite codecs package when trying to import an MP3 the program would crash,but after installing the K-Lite codecs package the program does not crash at all, but throws error, 'format not supported', just for completeness.


This is a 32-bit container and have tried many versions of wine through POL interface,ending in the same results. After looking at an actual Win10(64-bit) machine this CLSID appears to be a subset inprocess of ActiveMovie/devenum. Have installed the devenum and quartz .dll's in the library overrides.

Tried for much time to get this to install into a 64-bit container,but no luck there at all..

Am sure I dont have enough info here for anyone to decypher much,but at least a  starting point.




Dadu042 Sunday 7 April 2019 at 0:59

As I wrote in

I see that test reports on Wine about CrazyTalk are rare  :(   

I suggest to :


Because this app uses video codecs and webcam, I doubt it can work with Wine...


Edytowane przez Dadu042

brcisna Sunday 7 April 2019 at 1:11

OK, Thank You Dadu,


Yes, This is probably one of the worst case apps to try and make run under wine as could be,,any heavy multimedia stuff many times dont even work without hiccups,,even in real MS windows, 
I have never tried putting in the ffdshow through POL. I think Ive tried installing about every other combination.
It does actually work fine other than the restricted file formats to export and can be imported.
I was very suprised to see even rendering works corrcetly to be honest.

Am fairly certain i tried doing a 4.5 staging 32-bit wine install a couple times,,but ill try 4.0.

Thank You for tips."

brcisna Sunday 7 April 2019 at 3:41

Hi Dadu,

With Wine 4.0 it crashes on startup wit this error.

WARNING: Application calling GLX 1.3 function "glXCreatePixmap" when GLX 1.3 is not supported!  This is an application bug!


I know this app does look for minimum of OpenGL-1.3 on startup as I have lots of troubles trying to run this app in a  vm with no OpenGL-1.3 support on the graphics adapter. the program closes after no OpenGL-1.3 findings.


EDIT: The above message was due to the fact I was remoted into server via X2Go so no Opengl-1.3 support . Running from  console the program does open as expected. Still cant import .MP3 files.
Also I see when running in debuig mode many wine dbus errors that I never seen in the older version of wine and am guessing the new Wine versions just have more verbose logging? The dbus errors are probably what is causing the certain formats not to be recognized for some reason,but it is beyond me.

Thank You,


Edytowane przez brcisna

Dadu042 Sunday 7 April 2019 at 12:25

Am fairly certain i tried doing a 4.5 staging 32-bit wine install a couple times,,but ill try 4.0.

This is because I wanted you to test v4.0 (stable) before v4.5 (stable).


am guessing the new Wine versions just have more verbose logging?

I think the same thing.


If possible you can contribute to add  your test report to  :

Jesteś tutaj: Index > PlayOnLinux > CLSID in debug