Fora

Steam ne se lance pas après installation

Autor Odpowiedzi
SAMsan Tuesday 26 June 2007 at 9:27
SAMsanAnonymous

Bonjour à tous et merci de maintenir ce paquet qui tue.

Mon problème ressemble beaucoup à celui-là : http://playonlinux.ovh.org/forums/see_topic.php?topic=64

Je tourne sous Ubuntu Festy Fawn, POL 1.7 et wine 0.9.39 frais de ce matin.

Le problème :
Installation de steam, connexion à mon compte et DL ok.
Je quitte Steam OK
Je relance Steam -> rien qui se passe.
Dans la console ce message :
wine: could not load L"c:windowssystem32steam.exe": Module not found
Et celà malgré plusieurs réinstallation de POL/Steam et MAJ de Wine.

Donc à votre bon coeur messieurs dames...

Je repasserais ce soir quand je serais devant ma machine.

Merci d'avance.

Edytowane przez SAMsan

Quentin PÂRIS Tuesday 26 June 2007 at 9:59
Quentin PÂRIS
Admin

Bonjour,

1- Install PlayOnLinux 1.7.2
2- Tape ceci dans une console :
cat $HOME/.PlayOnLinux/configurations/installed/Steam

Et de la, j'aurais surement la solution

Edytowane przez goku

SAMsan Tuesday 26 June 2007 at 18:32
SAMsanAnonymous

Voilà le résultat (sous POL 1.7.2-2) :

export WINEPREFIX="/home/samuel/.PlayOnLinux/wineprefix/Steam"
export WINEDEBUG="-all"
cd "/home/samuel/.PlayOnLinux/wineprefix/Steam//drive_c/Program Files/Steam/"
wine steam.exe

Edytowane przez SAMsan

Christhaal Tuesday 26 June 2007 at 18:40
Christhaal

remplace plutot par

export WINEPREFIX="/home/samuel/.PlayOnLinux/wineprefix/Steam"
export WINEDEBUG="-all"
cd /home/samuel/.PlayOnLinux/wineprefix/Steam//drive_c/Program Files/Steam/
wine steam.exe

SAMsan Tuesday 26 June 2007 at 18:41
SAMsanAnonymous

C'est grave Docteur ?

OK je tente de suite
Domo.

Ah bah oué c nickel :|
merci bien messieurs !

Edytowane przez SAMsan

GNU_Raziel Tuesday 26 June 2007 at 18:45
GNU_Raziel

Non c'est pas grave, c'est un bug de POL, Tinou va corriger ça en un rien de temps ^^
Quentin PÂRIS Tuesday 26 June 2007 at 18:52
Quentin PÂRIS
Admin

Alors le problème ne venait pas des guillemets, mais du \ entre Program et Files. (Les forums les enlèvent donc ils sont pas affichés). Ce bug est corrigé.
GNU_Raziel Tuesday 26 June 2007 at 18:55
GNU_Raziel

Euh dsl mais pour CnC3, avec les gillemets ca ne fonctionnent pas alors que sans c'est impec, donc mieux vaut les virer (de toute façon ils ne servent a rien)
Quentin PÂRIS Tuesday 26 June 2007 at 19:01
Quentin PÂRIS
Admin

Si ! LiveInstall mais pas les anti-slashes entre Program et Files par exemple quand tu selectionne un fichier.

Edytowane przez Tinou

GNU_Raziel Tuesday 26 June 2007 at 19:12
GNU_Raziel

Dans ce cas fait 2 type de lanceurs, un creer_lanceur_live et le normal, parsque la ca casse la compatibilités avec les jeux qui ne sont PAS installés par LiveInstall...
SAMsan Tuesday 26 June 2007 at 19:15
SAMsanAnonymous

Oué le backslache pour echapper l'espace... J'ai capté quand j'ai vu qu'il fallait virer les guillemets.
Quentin PÂRIS Tuesday 26 June 2007 at 19:18
Quentin PÂRIS
Admin

En fait il faut soit :
- Enlever le backslashe
- Enlever les espaces : christhaal a mit a jour les scripts en consequences