PlayOnLinux Doesn't See Mounted Disks

Autor Odpowiedzi
daimajoou Tuesday 6 July 2010 at 0:07


POL has given me a problem just lately when I attempt to install new games through it. When prompted to direct it to where the CD-ROM is mounted, when I try to direct it to the CD-ROM or ISO (including typing out the directory), it only gives me "Error: Unable to find the CD-ROM !" I've tried several CD-ROMs and ISOs, but to no avail.

I am able to browse through the mounted disks, however, and even open the .exe's in Wine without any trouble.

"ls" of the directory gives (when Mass Effect is in the drive):

autorun.exe data eula_en.rtf readme_en.txt setup.exe support
autorun.inf directx eula_es.rtf readme_es.txt software

Other disks and ISOs also show up with nothing strange happening.

I run Ubuntu 10.04, POL is 3.7.6., Wine 1.1.42.

Additionally: I have not had this issue before, but I believe the last time I successfully installed something through POL was before I updated to Lucid. Games I have already installed still work, though none of the one's installed currently require the CD to play.

Thank you for your assistance.
Catser Wednesday 15 September 2010 at 21:12


I have the same problem (concerning the Mass Effect installation).
I run (K)Ubuntu 10.04 , POL is 3.8.1, Wine is 1.2.
On past issues I always could evade the problem by copying the correct path into the "Other" dialog (/media/*name of disc*/).
That doesn't work now.

While running POL in Terminal, I get no error messages, when it occurs.

The patched version of Mass Effect seems to work as Wine installation (according to
But I cannot complete the installation.

I would be grateful for some help.
GNU_Raziel Wednesday 15 September 2010 at 23:43

Catser Thursday 16 September 2010 at 12:36

Recognition of the cd-rom worked flawless this time. Thanks!

But I got further issues during the installation.
To be more specific during the updating process of DirectX 9.0c.
The Installation itself seems do be done, but the setup is still working on starting the DXSETUP.exe
Terminal output:
at first:
fixme:fusion:get_assembly_directory Ignoring assembly architecture
fixme:mscoree:LoadLibraryShim (0x922ab0 L"fusion.dll", (nil), (nil), 0x33f120): semi-stub

then only:
fixme:fusion:get_assembly_directory Ignoring assembly architecture
Before POL started the setup, it looked as if it updated DirectX by itself.

With the game came two discs, both seem to contain a DXSETUP.
Moreover, the second contains some data but the setup doesn't aks for it during the installation.

Any suggestions?

Edytowane przez Catser

GNU_Raziel Thursday 16 September 2010 at 14:28

This is a common wine bug with Ubisoft seems to also affect some Bioware games.

I've added a fix to the installer, basically it kill the process when it try to update directX (useless because, like you saw, POL already updated it), just follow POL instructions and press NEXT only when game installer try to update DirectX.
Catser Thursday 14 October 2010 at 14:14

Alright, finally I had some time to try this again.

This time I tried Custom Installation, which fixes the DirectX issue at the end, because you get the option to not install/update DirectX (unlike Express Installation). If this is mentioned by POL it could make things easier later on.

Anyway, I installed Mass Effect, reached the DirectX dialogue without problems, chose NOT installing DX and waited. About two minutes later the setup quit and wine opened a little dialogue saying: "Wine program crash: Internal errors - invalid parameters received"

Mass effect could not be run after following through the last POL instructions.

I uninstalled ME and tried again. This time I switched the DVDs when the setup tried to open the file mentioned above.
Same result. Here is a screenshot with some Terminal lines:

I hope we can fix this (or rather you guys)!