StarCraft 2 sound problem

Autor Odpowiedzi
smonsarr Saturday 28 August 2010 at 16:39

I installed StarCraft 2 using POL, the install went fine and I was able to play the game at the end of the install process.
However, I am having problems with the sound, once I quit the game after the install and I re-start it, I get no sound. I was looking through the forum and came across another post on Starcraft2 about another problem that called for the deactivation of library mmdevapi, this I tried just to see, and I got sound for about 30 seconds. Also, now when I go into the options, and I click on the "sound" tab I get sound for a second, If I click on the tab repeatedly, I get sound, but as soon as I stop, the sound goes.
I am running :
- Ubuntu 10.04 x86_64 kernel 2.6.32-24 / Gnome
- POL 3.8 from the POL deb repos
- StartCraft 2

I also noticed that before I disabled mmdevapi, wine did not even show up in the Applications tab of the Gnome pulseaudio Sound Preferences, with mmdevapi disabled, Wine is at least present.

any ideas ?
GNU_Raziel Saturday 28 August 2010 at 17:42

disable pulseaudio :

pulseaudio -k

It will be fine then :)
smonsarr Saturday 4 September 2010 at 17:58

Hi, thanks.
I solved may problem: in the wine config options, under the audio tab, no draiver was selected. I selected OSS and sound returned.
Beau_Vine Sunday 23 October 2011 at 15:47

EDIT: um, disregard that:incertain: I'm still new to POL. I've still had problems with launching the game with sound, but I've installed wine 1.3.15 via built in manager, changed it in the configuration and voila! Runs with sound.
<3 POL.

disable pulseaudio :

pulseaudio -k

It will be fine then :)

Quote from GNU_Raziel

Hey! Since a lot of people seem to be having problems with sound+SC2, I hope you don't mind the dig (this thread is highly placed on google).

pulseaudio -k

What do I do with this? Do I put it into command on the launcher, or just into terminal? If the latter, will that turn off sound on my machine, and if so - how can I turn it back again?

What I tried so far, was adding it into command line with and without padsp prefix, so it looked like that:

padsp /usr/share/playonlinux/playonlinux --run "StarCraft II Wings of Liberty" pulseaudio -k
/usr/share/playonlinux/playonlinux --run "StarCraft II Wings of Liberty" pulseaudio -k
and I tried just the padsp or a good measure (it worked for me under 1.2)
padsp /usr/share/playonlinux/playonlinux --run "StarCraft II Wings of Liberty"

When I go into wine configuration from POL, and go to sound drivers there, I can only see ALSA, so I can't try out OSS. I tried looking for the package in the self install list, but didn't find it.

ATM I'm downloading Wine 1.2.3, via POL Wine ver manager, and will try to work my way from there, but I'd appreciate any help to get the sound going again :)

Edytowane przez Beau_Vine