Fora

PlayOnLinux website is unavailable

Autor Odpowiedzi
rh Friday 19 August 2011 at 16:01
rhAnonymous

Hi,

I'm using POL 4.0.4 under Ubuntu 11.04. When I start POL I get a message saying that the website is unavailable. Obviously, clicking on "Install" only gives me empty lists of scripts. Clicking "Update" does nothing at all. When clicking a category, for instance "Games", I get the following in my console:
Traceback (most recent call last):
File "/usr/share/playonlinux/python/install.py", line 258, in search
self.apps = codecs.open(Variables.playonlinux_rep+"/configurations/listes/search",'r',"utf-8")
File "/usr/lib/python2.7/codecs.py", line 881, in open
file = __builtin__.open(filename, mode, buffering)
IOError: [Errno 2] File or directory does not exist: '/home/jonas/.PlayOnLinux//configurations/listes/search'
Traceback (most recent call last):
File "/usr/share/playonlinux/python/install.py", line 366, in AddApps
self.apps = codecs.open(Variables.playonlinux_rep+"/configurations/listes/1",'r',"utf-8")
File "/usr/lib/python2.7/codecs.py", line 881, in open
file = __builtin__.open(filename, mode, buffering)
IOError: [Errno 2] File or directory does not exist: '/home/jonas/.PlayOnLinux//configurations/listes/1'


There is nothing in console to indicate that POL is actually trying to access a website, perhaps that shouldn't be shown either?

Anyone have any ideas what the problem might be and how it can be fixed? I appreciate any help.

Edytowane przez rh

Quentin PÂRIS Saturday 20 August 2011 at 13:56
Quentin PÂRIS
Admin

Fix for ubuntu and debian

playonlinux://www.playonlinux.com/fix/force_update.signed

For other distros, download http://www.playonlinux.com/fix/force_update.signed, and run it with "Run a local script"
antitheftmilk Tuesday 23 August 2011 at 23:01
antitheftmilkAnonymous

I'm having this same exact error. I created and ran the script as shown but I still cannot connect to the site. I'm running 10.04 Ubuntu.
rh Wednesday 24 August 2011 at 10:46
rhAnonymous

Running the script didn't change anything for me either, still get the "website is unavailable" message and no install scripts available.

Also tried enabling Offline POL plugin which seems to download install scripts fine but lists are still empty and I get the same error messages as in original post when clicking on a category.

I'm now using POL 4.0.7 BTW.

Edytowane przez rh

Quentin PÂRIS Wednesday 24 August 2011 at 11:15
Quentin PÂRIS
Admin

Try to rename .PlayOnLinux
rh Wednesday 24 August 2011 at 11:40
rhAnonymous

Doesn't seem to do anything for me at least. Fonts download and then everything looks the same as before (i.e. "website unavailable" message, no install scripts, and error messages when clicking categories). Tried running the force update script as well, no change.
Quentin PÂRIS Wednesday 24 August 2011 at 12:21
Quentin PÂRIS
Admin

Is http://repository.playonlinux.com/version2.php available ?

Any proxy ?
rh Wednesday 24 August 2011 at 12:29
rhAnonymous

http://repository.playonlinux.com/version2.php gives me a "4.0.7" response when accessed from Firefox. I'm not using a proxy.
Quentin PÂRIS Wednesday 24 August 2011 at 13:04
Quentin PÂRIS
Admin

Is the window "Manage wineversion" available? (Tool menu)
rh Wednesday 24 August 2011 at 13:18
rhAnonymous

Yes, it is available and shows a number of Wine versions available for installation.
Quentin PÂRIS Wednesday 24 August 2011 at 13:48
Quentin PÂRIS
Admin

Run, in a terminal

wget -q "http://repository.playonlinux.com/version2.php?v=4.0.7" -T 10 -O-
rh Wednesday 24 August 2011 at 14:02
rhAnonymous

OK, done (a couple of times). What now?
Quentin PÂRIS Wednesday 24 August 2011 at 14:51
Quentin PÂRIS
Admin

Does it work ?
rh Wednesday 24 August 2011 at 15:16
rhAnonymous

Damn, that quiet flag prevented me from seeing that it didn't work. Got an "unable to resolve host" error, however both nslookup and ping could resolve the hostname. Added my ISPs name servers to /etc/resolv.conf (before I had just my router added) and POL works as expected! Lists contain install scripts, and so far installation of a game is looking good.

Thanks so much for the help! :)
allen303allen Tuesday 14 February 2012 at 11:02
allen303allenAnonymous

I have the same problem, console shows the same as rh's, but I have some different situations:
1. I use proxy, but is already set in playonlinux.
2. "Manage wineversion" is not available, says "wine packages website is unavailable".
3. when I run in a terminal
wget "http://repository.playonlinux.com/version2.php?v=4.0.14" -T 10 -O-
I get http 407 error, when I add --proxy-user and --proxy-password options, it works fine.

Is that a proxy problem? Can someone help?
grzesius Saturday 2 March 2013 at 17:58
grzesiusAnonymous

I found reason. you must edit your resolv.conf file in /etc. There are DNS servers and my file was:

nameserver 127.0.0.1
nameserver 127.0.0.1
nameserver 127.0.0.1

and I changed two last lines and put other DNS server. After reboot playonlinux worked.