Installation of gecko and vcrun6 (needed for The Sims 3) impossible?

Autor Odpowiedzi
ProVol Wednesday 4 January 2012 at 23:35

Good evening everyone.
This is my first posting here so I hope everything goes right.

Alright, here's the situation.
I try to get The Sims 3 working in PoL (current version, straight from the repo), according to you guys, WineHQ and quite a few YouTube videos, it should work just fine.

Got the DVD, installed the game using the script that came along with PoL, but unfortunately the game refuses to even show at least the splash screen.
My computer seems to work as I can clearly hear the noise of its HDD and see the PC's front light for activity, but even after minutes, no difference.

I reinstalled the game like six or seven times by now, tried different NoDVD patches, still the same.

Next I thought it was a good idea to take a look at the bash output.
The output told me that Wine 1.3.4 waren't installed which is kinda strange as it got even downloaded but no problem, I just redownloaded it manually over PoL's menu, DirectX9 and vcrun6 too, Mono always finds its way on the harddrive.

However, it seems like vcrun6 can't be installed for some unknown reason.
At least that's what I except by reading the output.

$ playonlinux --run The\\ Sims\\ 3
[POL_System_SetArch] Message: POL_ARCH set to amd64
[POL_Wine_SetVersionEnv] Message: Setting wine version path: 1.3.4, amd64
[POL_Wine_SetVersionEnv] Message: "/home/ME/.PlayOnLinux//wine/linux-amd64/1.3.4" exists
[POL_Wine] Message: Running wine-1.3.4 TS3.exe
wine: Call from 0x7b8388e2 to unimplemented function msvcr80.dll._set_abort_behavior, aborting
[POL_Wine] Message: Wine return: 0

When trying to install gecko now, Wine's internal installer freezes up and gives me the typical Windows error message we use to know meanwhile.

I don't know what's wrong but I can figure out that vcrun6 or a later version is needed by TS3 to work.

My system runs with Debian Stable that comes along with Wine 1.0.1 in it's repos.
Maybe that's the problem, because such a old version as mentioned can't handle the setup?

Hope anyone can help.