Diablo 3 ptrace lockup Ubuntu 12.04

Autor Odpowiedzi
d16174l4n63l Thursday 14 June 2012 at 23:04

So I have seen references to people working on the problem but I've seen no results or a real way to fix it.

I use the ptrace command like I should but without fail the system locks up.

How do I fix this?

Distro: Kubuntu 12.04
Graphics: ATI Radeon HD 5450 (Yes it does work)
Catalyst Version: 12.04

What do you need from me, everything else runs beautiful, even the Beta worked just fine this live version is really frustrating.

Edytowane przez d16174l4n63l

Quentin PÂRIS Thursday 14 June 2012 at 23:59
Quentin PÂRISAnonymous

First, what is the problem ?
d16174l4n63l Friday 15 June 2012 at 1:05

When using

echo 0|sudo tee /proc/sys/kernel/yama/ptrace_scope

I click login and the system locks up.

If ptrace_scope is 1 it just doesn't authenticate.
d16174l4n63l Wednesday 20 June 2012 at 15:19

okay 1.3 has been patched up in DIablo 3.
ptrace_scope = 1 - no authentication
ptrace_scope = 0 - system locks up

I have messed with every option, changed wine versions and no favorable results.

d16174l4n63l Wednesday 20 June 2012 at 16:18

Update: this entire issue is based upon the "stable" AMD drivers.

I uninstalled the drivers and used the drivers provided by
http: precise main

The game fired up no problem, a little lagging but definitely playable. Though it still has an issue with changing from full screen to windowed. However again those worked, proprietary do not.

if 12.6 is supposed to be the solution as my card is supported, maybe someone can point to a link or figure out why the 12.4 drivers are failing.

Edytowane przez d16174l4n63l

Quentin PÂRIS Wednesday 20 June 2012 at 16:29
Quentin PÂRISAnonymous

12.4 drivers are failing because they are simply too old and some extensions are missing.

I don't understand why you are using a 1.3 patched while POL supports a recent version of wine patched for Diablo III
d16174l4n63l Wednesday 20 June 2012 at 17:40

the 1.3 is referring to the new Diablo 3 patch.

I use the 1.5.5-DiabloIII_v3 and as a matter of testing 1.5.5-DiabloIII_v2 respectively.

So with 12.4 being so out of date, do you have any way of moving to 12.6 which is supposed to be up to date for the above mentioned specifications.

Quentin PÂRIS Wednesday 20 June 2012 at 17:58
Quentin PÂRISAnonymous

Nope, sorry. I know nothing about ATI cards
d16174l4n63l Wednesday 20 June 2012 at 18:01

No worries, I am looking into instructions now and if I get a favorable result I will make sure to post them here.
d16174l4n63l Friday 29 June 2012 at 10:12

Okay I have new results I hope this helps.  I am confirming for my setup alone.

I used the following instructions to install the proprietary drivers.  Please note you must remove the additional drivers version as this seems to be the issue, at least from what I have seen.

  1. sudo apt-get install build-essential cdbs dh-make dkms execstack dh-modaliases fakeroot
  2. cd ~/; mkdir catalyst12.4; cd catalyst12.4/
  3. wget
  4. chmod +x
  5. ./ --extract driver
  6. cd driver/common/lib/modules/fglrx/build_mod/
  7. wget -O fglrx.patch
  8. patch -p1 < fglrx.patch
  9. cd ~/catalyst12.4/driver/
  10. ./ 8.961 --buildpkg Ubuntu/precise
  11. cd ../
  12. sudo dpkg -i fglrx*.deb
  13. sudo aticonfig --initial
  14. sudo reboot

If you get some error about not having the OpenGL drivers, check that the fglrx isn't blacklisted.  (part of why it didn't work right)

grep fglrx /etc/modprobe.d/*

if it gives you something like:

blacklist-local.conf:blacklist fglrx
fglrx.conf:# This file was installed by fglrx 
fglrx.conf:alias fglrx fglrx


edit /etc/modprobe.d/blacklist-local.conf file and comment out line with "blacklist fglrx" by inserting "#" in front of the line.

It will look like

# blacklist fglrx

reboot and enjoy

This is what worked for me and I didn't need the 12.6 beta drivers. I had no special repositories, or anything beyond that and I am up and running.

Edytowane przez d16174l4n63l

roboso Saturday 30 June 2012 at 18:41

AMD Catalyst™ Proprietary Display Driver - Linux x86 & Linux x86_64 16.6 stable version

32/64 bit〈=English

d16174l4n63l Saturday 30 June 2012 at 23:47

Roboso was there an update?