Jesteś tutaj


New Bug?

Autor Odpowiedzi
MrAppleseed Tuesday 25 September 2012 at 1:24

Hello all, 

Recently I've been experiencing an odd bug, that I'm not sure is because of POL, or because I mucked something up myself, but it's been making all of my games unplayable. It started when I was browsing the web (with multiple windows) and had Steam running. I was Alt + Tab'd out of the Steam window and was responding to a forum post on another window. Suddenly, I got a message from Ubuntu saying that I had 0 bytes of memory left, yet I had over 20 gig's left. When I checked it with Disk Usage Analyzer, it said that my ~/.playonlinux folder was over 80 gig's in size (though it really should only be around 30). I kind of freaked out and restarted my computer. Though this solved my issue with Ubuntu freaking out over memory, another bug involving PlayOnLinux started up. It is as follows:

Whenever I try to run TF2 (Team Fortress 2 (or another game, for that matter)) using PlayOnLinux 4.18, I get the error, "Internal errors - invalid parameters received". This only recently started happening, in fact, before, it worked perfectly! The even more odd thing is that Steam (For TF2) is no longer in my TF2 Prefix (or at least isn't showing up in the POL configuration (though when I checked the actual files, Steam (Team Fortress 2) was still there), yet, it is still showing up as an installed program when I start POL. Previous to this odd bug, I had a normal Steam which I installed through POL first, then, I had another Steam that got installed presumably when I installed TF2 and existed in the same prefix. 

Also, because Steam (Team Fortress 2) is no longer showing up in the configuration menu of POL, I can't run it, nor can I configure it to see if I can fix the bug. However, whenever I run Team Fortress 2, Steam (Team Fortress 2) runs just fine, the only exception being it won't start TF2 because of the bug listed above. 

(Note: This bug not only affects TF2 and Steam (Team Fortress 2), but also my regular Steam install, and my Guild Wars 2 install.)

Here are my system specs and other information:

-POL version 4.18 (updated from 4.17 via .deb downloaded here)
-Ubuntu 12.04 LTS (Kernel = 3.2.0-31-generic-pae)
-Wine version tested on (1.5.12, 1.5.11, 1.5.13 (didn't bother testing on anything else))
-CPU = Intel(R) Core(TM)2 Quad CPU    Q6600  @ 2.40GHz
-Graphics Card = Nvidia 9800 GTX, 1024 Video RAM
-Output of df command:
    Filesystem     1K-blocks     Used Available Use% Mounted on
    /dev/sda6       98050716 66067084  27002948  71% /
    udev             2051244        4   2051240   1% /dev
    tmpfs             824656      936    823720   1% /run
    none                5120        0      5120   0% /run/lock
    none             2061640     1340   2060300   1% /run/shm
    overflow            1024       16      1008   2% /tmp

Thanks for your time!

As a software developer, I know how annoying it can be to debug things without much evidence which is why I tried to be as comprehensive in my description as possible, and I have also included screenshots from everything else I could think of and compiled them into an album at:

I have also recently found and pasted the output of my TF2 logfile into a pastebin located here:

Edytowane przez MrAppleseed

Jesteś tutaj: Index > PlayOnLinux > New Bug?