Вы находитесь здесь

Форум

Diablo 3 FPS Issue

Автор Replies
dayos80 Tuesday 28 May 2013 at 0:26
dayos80Anonymous

Hello everyone, i am having an issue with diablo 3.

My issue currently is when i launch Diablo 3 i have insane low frames in game when my resolution is lower then or equal to 1680x945 once i go higher then that i get insane frame lag on the login screen and while playing. 

My machine ran fine on windows playing all games at 40+ fps all the time.

My setup is as follows
AMD A6-3670 APU with Radeon(tm) HD Graphic x4
AMD Radeon HD 6670 with 1 GB GDDR5
4GB of Ram
F1A75-M PRO

Linux jakes-pooper-scooper 3.5.0-17-generic #28-Ubuntu SMP Tue Oct 9 19:31:23 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

Linux Mint 14 Nadia \\n \\l

The version of Wine used to launch Diablo is 1.5.5-DiabloIII_v3

I have tried the setting of 1 or 2 CPU cores.
also have tried disabling GLSL Support in play on linux.

I am using the Open source amd/ati drivers

Thanks, Jake

Ronin DUSETTE Tuesday 28 May 2013 at 5:39
Ronin DUSETTE
Admin

You need the proprietary drivers for your card. Open source drivers have low performance.

Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
dayos80 Tuesday 28 May 2013 at 21:13
dayos80Anonymous

I tried to swap to the Proprietary drivers and diablo wouldn't even launch.
Ronin DUSETTE Tuesday 28 May 2013 at 21:17
Ronin DUSETTE
Admin

We need the debug or terminal output from POL. Trust me, the proprietary drivers stomp out the open-source ones by leaps and bounds. We will get it figured out, though. :)

So yeah, follow the sticky at the top of the forum to get your debug output and paste it here. That way we can see what exactly is causing the crash.

Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
dayos80 Tuesday 28 May 2013 at 22:40
dayos80Anonymous

Hey DJY, so i got it all to work perfectly !! except alt tab freezes the game. I can figure that out myself though.

what i had to do was as you said, swap to the Proprietary drivers for my card, and then sudo apt-get dist-upgrade and restart the computer.

Once i did that i was running in all resolutions perfect and at all high settings w/ 60+ fps :)

Thanks for the help.

Jake
Ronin DUSETTE Tuesday 28 May 2013 at 22:46
Ronin DUSETTE
Admin

Excellent. Just remember that if you run sudo apt-get dist upgrade, you may end up downloading a new kernel, which means that after restart, you need to run your NVIDIA driver setup again and restart again to build it in to the new kernel.

Other than that, Im glad you got it running. Let us know if you have any issues. Enjoy! :)

Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
Вы находитесь здесь: Index > PlayOnLinux > Diablo 3 FPS Issue