Вы находитесь здесь

Форум

[Script] Civilization IV: Complete

Автор Replies
Jump to the page: 1 - 2 - 3 - 4 - 5 - 6
Ronin DUSETTE Monday 22 July 2013 at 2:05
Ronin DUSETTE
Admin

Yeah. On that note, before you reinstall it, delete the virtual drive for the game so it creates a fresh one when you try to run the script.

Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
steve723 Monday 22 July 2013 at 3:02
steve723Anonymous

The Ubuntu drivers don't work with the Intel GMA 45. I had to install the driver's from Xorg Edgers xcrack. Are these drivers different and do they work with the Intel GMA 45? Of course the debugg log also says:

fixme:msi:ITERATE_CreateShortcuts poorly handled shortcut format, advertised shortcut

Edited by steve723

steve723 Monday 22 July 2013 at 3:05
steve723Anonymous

Yes I noticed the script was updated today.
Ronin DUSETTE Monday 22 July 2013 at 3:08
Ronin DUSETTE
Admin

fixme's are fine. Dont worry about those.

The ubuntu drivers do work with intel chips, as I am running the same on my laptop, but I may be running a slightly different intel chip. As long as you got those installed and restarted your computer, you should be good to go.

Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
steve723 Monday 22 July 2013 at 3:18
steve723Anonymous

I will do this later.
steve723 Monday 22 July 2013 at 17:06
steve723Anonymous

fixme's are fine. Dont worry about those.

The ubuntu drivers do work with intel chips, as I am running the same on my laptop, but I may be running a slightly different intel chip. As long as you got those installed and restarted your computer, you should be good to go.

Quote from DJYoshaBYD


I didn't say that Intle drivers don't work with Intel chips. I said that they don't work with the Intel GMA45. For exeample Star Trek Online won't work with the Ubuntu driver's. I just get a black screen. If I use Xorg Edgers X-crack then STO will display correctly. That's been the case for years and last time I checked -about 2-3 months ago-, several people were still trying to get Intle to fix thier driver's. I guess Intle probably dosn't think enough people are affeted to be worth the cost or something else why don't they fix this. Several other manufacturers have this same issue. Open source video driver's still don't work in all cases for every one. Until they do then Xorg Edgers X - crack project exists to make up for the odd exceptions. Just like things like POL and wine exist until the day when all games get ported to Linux, which at the moment still looks to be several more decades away. Maybe 2070 or later, who can predict a thing like that? Probably easier to predict the Super Bowel during the pre season. This is begining to go of topic so I'll stop. We will need to start a new thread if we need to say more about this.
steve723 Monday 22 July 2013 at 17:12
steve723Anonymous

I am going to delete the vd and try the latest script. Here goes nothing...

Actually that saying should be here goes something since nothing really means your idling. Lol
steve723 Monday 22 July 2013 at 18:05
steve723Anonymous

O no. The script Script crashed. I was away from my computer at the time. The script continued but now it says 'File not found'. I clicked ok and another crash occured. I click next and it wants to install Steam. I'll click cancle and post the debugg log...

[07/22/13 08:37:44] - Running wine-1.4.1 --version (Working directory : /home/steve7233/.PlayOnLinux)
wine-1.4.1

PlayOnLinux logfile
-------------------
Date: 07/22/13 08:37:44

> PlayOnLinux Version
4.2.1
> uname -a
Linux steve7233-HP-Pavilion-dv6-Notebook-PC 3.8.0-26-generic #38-Ubuntu SMP Mon Jun 17 21:43:33 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux
> lsb_release -a

> wine --version
wine-1.4.1
> POL_WINEVERSION
1.4.1
> WINEPREFIX
/home/steve7233/.PlayOnLinux//wineprefix/Civilization4
> Distribution
Ubuntu 13.04
> glxinfo \\| grep rendering
direct rendering: Yes
> glxinfo \\| grep renderer
OpenGL renderer string: Mesa DRI Mobile Intel® GM45 Express Chipset
> OpenGL libs (Direct rendering testing)
32bits direct rendering is enabled
64bits direct rendering is enabled

[07/22/13 08:38:31] - Running wine-1.4.1 cmd /c echo %ProgramFiles% (Working directory : /home/steve7233/.PlayOnLinux)
err:process:init_windows_dirs directory L"C:\\\\windows" could not be created, error 2
err:process:init_windows_dirs directory L"C:\\\\windows\\\\system32" could not be created, error 3
err:process:init_windows_dirs directory L"C:\\\\windows" could not be created, error 2
err:process:init_windows_dirs directory L"C:\\\\windows\\\\system32" could not be created, error 3
err:wineboot:main Cannot set the dir to L"C:\\\\windows" (2)
err:process:init_windows_dirs directory L"C:\\\\windows" could not be created, error 2
err:process:init_windows_dirs directory L"C:\\\\windows\\\\system32" could not be created, error 3
fixme:service:scmdatabase_autostart_services Auto-start service L"MountMgr" failed to start: 2
fixme:service:scmdatabase_autostart_services Auto-start service L"PlugPlay" failed to start: 2
C:\\windows\\system32\\unknown
[07/22/13 08:38:58] - ----- Starting function POL_Install_d3dx9 -----
[07/22/13 08:39:11] - Running wine-1.4.1 regedit /home/steve7233/.PlayOnLinux//tmp/override-dll.reg (Working directory : /home/steve7233/.PlayOnLinux/ressources)
[07/22/13 08:39:11] - Content of /home/steve7233/.PlayOnLinux//tmp/override-dll.reg
-----------
REGEDIT4

[HKEY_CURRENT_USER\\Software\\Wine\\DllOverrides]
"*d3dx9_24"="native, builtin"
"*d3dx9_25"="native, builtin"
"*d3dx9_26"="native, builtin"
"*d3dx9_27"="native, builtin"
"*d3dx9_28"="native, builtin"
"*d3dx9_29"="native, builtin"
"*d3dx9_30"="native, builtin"
"*d3dx9_31"="native, builtin"
"*d3dx9_32"="native, builtin"
"*d3dx9_33"="native, builtin"
"*d3dx9_34"="native, builtin"
"*d3dx9_35"="native, builtin"
"*d3dx9_36"="native, builtin"
"*d3dx9_37"="native, builtin"
"*d3dx9_38"="native, builtin"
"*d3dx9_39"="native, builtin"
"*d3dx9_40"="native, builtin"
"*d3dx9_42"="native, builtin"
"*d3dx9_42"="native, builtin"
"*d3dx9_43"="native, builtin"
-----------
err:process:init_windows_dirs directory L"C:\\\\windows" could not be created, error 2
err:process:init_windows_dirs directory L"C:\\\\windows\\\\system32" could not be created, error 3
err:process:init_windows_dirs directory L"C:\\\\windows" could not be created, error 2
err:process:init_windows_dirs directory L"C:\\\\windows\\\\system32" could not be created, error 3
err:wineboot:main Cannot set the dir to L"C:\\\\windows" (2)
err:process:init_windows_dirs directory L"C:\\\\windows" could not be created, error 2
err:process:init_windows_dirs directory L"C:\\\\windows\\\\system32" could not be created, error 3
fixme:service:scmdatabase_autostart_services Auto-start service L"MountMgr" failed to start: 2
fixme:service:scmdatabase_autostart_services Auto-start service L"PlugPlay" failed to start: 2
[07/22/13 08:39:29] - ----- Ending function POL_Install_d3dx9 -----
[07/22/13 08:39:31] - ----- Starting function POL_Install_steam -----
[07/22/13 08:39:40] - Running wine-1.4.1 cmd /c echo %ProgramFiles% (Working directory : /home/steve7233/.PlayOnLinux/tmp)
err:process:init_windows_dirs directory L"C:\\\\windows" could not be created, error 2
err:process:init_windows_dirs directory L"C:\\\\windows\\\\system32" could not be created, error 3
err:process:init_windows_dirs directory L"C:\\\\windows" could not be created, error 2
err:process:init_windows_dirs directory L"C:\\\\windows\\\\system32" could not be created, error 3
err:wineboot:main Cannot set the dir to L"C:\\\\windows" (2)
err:process:init_windows_dirs directory L"C:\\\\windows" could not be created, error 2
err:process:init_windows_dirs directory L"C:\\\\windows\\\\system32" could not be created, error 3
fixme:service:scmdatabase_autostart_services Auto-start service L"MountMgr" failed to start: 2
fixme:service:scmdatabase_autostart_services Auto-start service L"PlugPlay" failed to start: 2
C:\\windows\\system32\\unknown
[07/22/13 08:40:03] - ----- Starting function POL_Function_FontsSmoothRGB -----
[07/22/13 08:40:06] - Running wine-1.4.1 regedit /home/steve7233/.PlayOnLinux//tmp/fontsaa.reg (Working directory : /home/steve7233/.PlayOnLinux/tmp)
[07/22/13 08:40:06] - Content of /home/steve7233/.PlayOnLinux//tmp/fontsaa.reg
-----------
REGEDIT4
[HKEY_CURRENT_USER\\Control Panel\\Desktop]
"FontSmoothing"="2"
"FontSmoothingType"=dword:00000002
"FontSmoothingGamma"=dword:00000578
"FontSmoothingOrientation"=dword:00000001
-----------
err:process:init_windows_dirs directory L"C:\\\\windows" could not be created, error 2
err:process:init_windows_dirs directory L"C:\\\\windows\\\\system32" could not be created, error 3
err:process:init_windows_dirs directory L"C:\\\\windows" could not be created, error 2
err:process:init_windows_dirs directory L"C:\\\\windows\\\\system32" could not be created, error 3
err:wineboot:main Cannot set the dir to L"C:\\\\windows" (2)
err:process:init_windows_dirs directory L"C:\\\\windows" could not be created, error 2
err:process:init_windows_dirs directory L"C:\\\\windows\\\\system32" could not be created, error 3
fixme:service:scmdatabase_autostart_services Auto-start service L"MountMgr" failed to start: 2
fixme:service:scmdatabase_autostart_services Auto-start service L"PlugPlay" failed to start: 2
[07/22/13 08:40:13] - ----- Ending function POL_Function_FontsSmoothRGB -----
[07/22/13 08:40:13] - Running wine-1.4.1 msiexec /i SteamInstall.msi /q (Working directory : /home/steve7233/.PlayOnLinux/ressources)
err:process:init_windows_dirs directory L"C:\\\\windows" could not be created, error 2
err:process:init_windows_dirs directory L"C:\\\\windows\\\\system32" could not be created, error 3
err:shell:SHGetFolderPathAndSubDirW Failed to create directory L"C:\\\\users\\\\steve7233\\\\Local Settings\\\\Temporary Internet Files".
err:wininet:URLCacheContainers_CreateDefaults Couldn't get path for default container 0
err:shell:SHGetFolderPathAndSubDirW Failed to create directory L"C:\\\\users\\\\steve7233\\\\Local Settings\\\\History".
err:wininet:URLCacheContainers_CreateDefaults Couldn't get path for default container 1
err:shell:SHGetFolderPathAndSubDirW Failed to create directory L"C:\\\\users\\\\steve7233\\\\Cookies".
err:wininet:URLCacheContainers_CreateDefaults Couldn't get path for default container 2
[07/22/13 08:57:57] - Running wine-1.4.1 regedit /home/steve7233/.PlayOnLinux//tmp/override-dll.reg (Working directory : /home/steve7233/.PlayOnLinux/ressources)
[07/22/13 08:57:57] - Content of /home/steve7233/.PlayOnLinux//tmp/override-dll.reg
-----------
REGEDIT4

[HKEY_CURRENT_USER\\Software\\Wine\\DllOverrides]
"*dwrite"=""
-----------
err:process:init_windows_dirs directory L"C:\\\\windows" could not be created, error 2
err:process:init_windows_dirs directory L"C:\\\\windows\\\\system32" could not be created, error 3
err:process:init_windows_dirs directory L"C:\\\\windows" could not be created, error 2
err:process:init_windows_dirs directory L"C:\\\\windows\\\\system32" could not be created, error 3
err:wineboot:main Cannot set the dir to L"C:\\\\windows" (2)
err:process:init_windows_dirs directory L"C:\\\\windows" could not be created, error 2
err:process:init_windows_dirs directory L"C:\\\\windows\\\\system32" could not be created, error 3
fixme:service:scmdatabase_autostart_services Auto-start service L"MountMgr" failed to start: 2
fixme:service:scmdatabase_autostart_services Auto-start service L"PlugPlay" failed to start: 2
[07/22/13 08:57:58] - ----- Ending function POL_Install_steam -----
[07/22/13 08:57:58] - Running wine-1.4.1 start /unix Steam.exe steam://install/3900 (Working directory : /home/steve7233/.PlayOnLinux/ressources)
err:process:init_windows_dirs directory L"C:\\\\windows" could not be created, error 2
err:process:init_windows_dirs directory L"C:\\\\windows\\\\system32" could not be created, error 3
fixme:exec:SHELL_execute flags ignored: 0x00000100
Application could not be started, or no application associated with the specified file.
ShellExecuteEx failed: Success.

alcorsepol Monday 22 July 2013 at 18:31
alcorsepolAnonymous


errrocess:init_windows_dirs directory L"C:\\\\windows\\\\system32" could not be created, error 3


Sounds like either the permissions on the folder is screwed up, or you are running out of space on that partition.
steve723 Monday 22 July 2013 at 18:43
steve723Anonymous


errrocess:init_windows_dirs directory L"C:\\\\windows\\\\system32" could not be created, error 3


Sounds like either the permissions on the folder is screwed up, or you are running out of space on that partition.

Quote from alcorsepol


steve7233@steve7233-HP-Pavilion-dv6-Notebook-PC:~$ df -hT --exclude-type=tmpfs --exclude-type=devtmpfs
Filesystem     Type     Size  Used Avail Use% Mounted on
/dev/sdc7      btrfs     47G   22G   25G  47% /
/dev/sdc1      btrfs    381M   85M  293M  23% /boot
/dev/sdc8      btrfs    932G  135G  760G  16% /home
/dev/sdc5      btrfs     47G  906M   44G   2% /var
/dev/sdc4      ext4     120G  3.6G  110G   4% /media/d74f200c-3eb9-4e3f-a1ef-44f124712d8a
/dev/sda1      fuseblk  286G  261G   25G  92% /media/0F9A2F1E1579DBC5
/dev/sdc3      fuseblk  242G  238G  4.0G  99% /media/For Windows Vist
/dev/sr0       udf      5.2G  5.2G     0 100% /media/TSimsM
steve7233@steve7233-HP-Pavilion-dv6-Notebook-PC:~$

Space isn't the problem.
steve723 Monday 22 July 2013 at 18:56
steve723Anonymous

I tried deleteing and reruning the script until the first crash which was right after vd creation and Dx install:

[07/22/13 09:51:35] - Running wine-1.4.1 --version (Working directory : /home/steve7233/.PlayOnLinux)
wine-1.4.1

PlayOnLinux logfile
-------------------
Date: 07/22/13 09:51:35

> PlayOnLinux Version
4.2.1
> uname -a
Linux steve7233-HP-Pavilion-dv6-Notebook-PC 3.8.0-26-generic #38-Ubuntu SMP Mon Jun 17 21:43:33 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux
> lsb_release -a

> wine --version
wine-1.4.1
> POL_WINEVERSION
1.4.1
> WINEPREFIX
/home/steve7233/.PlayOnLinux//wineprefix/Civilization4
> Distribution
Ubuntu 13.04
> glxinfo \\| grep rendering
direct rendering: Yes
> glxinfo \\| grep renderer
OpenGL renderer string: Mesa DRI Mobile Intel® GM45 Express Chipset
> OpenGL libs (Direct rendering testing)
32bits direct rendering is enabled
64bits direct rendering is enabled

[07/22/13 09:51:43] - Running wine-1.4.1 cmd /c echo %ProgramFiles% (Working directory : /home/steve7233/.PlayOnLinux)
err:process:init_windows_dirs directory L"C:\\\\windows" could not be created, error 2
err:process:init_windows_dirs directory L"C:\\\\windows\\\\system32" could not be created, error 3
err:process:init_windows_dirs directory L"C:\\\\windows" could not be created, error 2
err:process:init_windows_dirs directory L"C:\\\\windows\\\\system32" could not be created, error 3
err:wineboot:main Cannot set the dir to L"C:\\\\windows" (2)
err:process:init_windows_dirs directory L"C:\\\\windows" could not be created, error 2
err:process:init_windows_dirs directory L"C:\\\\windows\\\\system32" could not be created, error 3
fixme:service:scmdatabase_autostart_services Auto-start service L"MountMgr" failed to start: 2
fixme:service:scmdatabase_autostart_services Auto-start service L"PlugPlay" failed to start: 2
C:\\windows\\system32\\unknown
[07/22/13 09:51:47] - ----- Starting function POL_Install_d3dx9 -----
[07/22/13 09:51:50] - Running wine-1.4.1 regedit /home/steve7233/.PlayOnLinux//tmp/override-dll.reg (Working directory : /home/steve7233/.PlayOnLinux/ressources)
[07/22/13 09:51:50] - Content of /home/steve7233/.PlayOnLinux//tmp/override-dll.reg
-----------
REGEDIT4

[HKEY_CURRENT_USER\\Software\\Wine\\DllOverrides]
"*d3dx9_24"="native, builtin"
"*d3dx9_25"="native, builtin"
"*d3dx9_26"="native, builtin"
"*d3dx9_27"="native, builtin"
"*d3dx9_28"="native, builtin"
"*d3dx9_29"="native, builtin"
"*d3dx9_30"="native, builtin"
"*d3dx9_31"="native, builtin"
"*d3dx9_32"="native, builtin"
"*d3dx9_33"="native, builtin"
"*d3dx9_34"="native, builtin"
"*d3dx9_35"="native, builtin"
"*d3dx9_36"="native, builtin"
"*d3dx9_37"="native, builtin"
"*d3dx9_38"="native, builtin"
"*d3dx9_39"="native, builtin"
"*d3dx9_40"="native, builtin"
"*d3dx9_42"="native, builtin"
"*d3dx9_42"="native, builtin"
"*d3dx9_43"="native, builtin"
-----------
err:process:init_windows_dirs directory L"C:\\\\windows" could not be created, error 2
err:process:init_windows_dirs directory L"C:\\\\windows\\\\system32" could not be created, error 3
err:process:init_windows_dirs directory L"C:\\\\windows" could not be created, error 2
err:process:init_windows_dirs directory L"C:\\\\windows\\\\system32" could not be created, error 3
err:wineboot:main Cannot set the dir to L"C:\\\\windows" (2)
err:process:init_windows_dirs directory L"C:\\\\windows" could not be created, error 2
err:process:init_windows_dirs directory L"C:\\\\windows\\\\system32" could not be created, error 3
fixme:service:scmdatabase_autostart_services Auto-start service L"MountMgr" failed to start: 2
fixme:service:scmdatabase_autostart_services Auto-start service L"PlugPlay" failed to start: 2
[07/22/13 09:51:51] - ----- Ending function POL_Install_d3dx9 -----
[07/22/13 09:51:51] - ----- Starting function POL_Install_steam -----
[07/22/13 09:51:51] - Running wine-1.4.1 cmd /c echo %ProgramFiles% (Working directory : /home/steve7233/.PlayOnLinux/tmp)
err:process:init_windows_dirs directory L"C:\\\\windows" could not be created, error 2
err:process:init_windows_dirs directory L"C:\\\\windows\\\\system32" could not be created, error 3
C:\\windows\\system32\\unknown
[07/22/13 09:51:52] - ----- Starting function POL_Function_FontsSmoothRGB -----
[07/22/13 09:51:53] - Running wine-1.4.1 regedit /home/steve7233/.PlayOnLinux//tmp/fontsaa.reg (Working directory : /home/steve7233/.PlayOnLinux/tmp)
[07/22/13 09:51:53] - Content of /home/steve7233/.PlayOnLinux//tmp/fontsaa.reg
-----------
REGEDIT4
[HKEY_CURRENT_USER\\Control Panel\\Desktop]
"FontSmoothing"="2"
"FontSmoothingType"=dword:00000002
"FontSmoothingGamma"=dword:00000578
"FontSmoothingOrientation"=dword:00000001
-----------
err:process:init_windows_dirs directory L"C:\\\\windows" could not be created, error 2
err:process:init_windows_dirs directory L"C:\\\\windows\\\\system32" could not be created, error 3
[07/22/13 09:51:53] - ----- Ending function POL_Function_FontsSmoothRGB -----
[07/22/13 09:51:53] - Running wine-1.4.1 msiexec /i SteamInstall.msi /q (Working directory : /home/steve7233/.PlayOnLinux/ressources)
err:process:init_windows_dirs directory L"C:\\\\windows" could not be created, error 2
err:process:init_windows_dirs directory L"C:\\\\windows\\\\system32" could not be created, error 3
err:shell:SHGetFolderPathAndSubDirW Failed to create directory L"C:\\\\users\\\\steve7233\\\\Local Settings\\\\Temporary Internet Files".
err:wininet:URLCacheContainers_CreateDefaults Couldn't get path for default container 0
err:shell:SHGetFolderPathAndSubDirW Failed to create directory L"C:\\\\users\\\\steve7233\\\\Local Settings\\\\History".
err:wininet:URLCacheContainers_CreateDefaults Couldn't get path for default container 1
err:shell:SHGetFolderPathAndSubDirW Failed to create directory L"C:\\\\users\\\\steve7233\\\\Cookies".
err:wininet:URLCacheContainers_CreateDefaults Couldn't get path for default container 2

It looks like the wine prefix can't be created. Weird it was working. I had to delete the vd manually because POL config wouldn't delete it. I used Dolphine to delete the foulder as per:

alcorsepol
And if you try to remove the VD via POL and it wont be removed, then you
can just go there with your file handler and remove the folder
manually, as POL doesn't keep this data anywhere else as far as I know
(like in a database, it relies on the folder structure).

Quote

Edited by steve723

alcorsepol Monday 22 July 2013 at 19:11
alcorsepolAnonymous

hmm that's wierd, and nothing I have encountered in POL before.
I will investigate a bit.
steve723 Monday 22 July 2013 at 19:59
steve723Anonymous

I tried deleting wine 1.4.1, so the script could redownload it but the crash still occurs when creating the prefix.
alcorsepol Monday 22 July 2013 at 20:07
alcorsepolAnonymous

can you create the path manually?


/home/steve7233/.PlayOnLinux/wineprefix/Civilization4/drive_c/windows


If all else fails I can't think about much more than a broken setup.
Maybe purge wine and pol, remove all configs and restart completely?
Or maybe you have a bunch of games and don't want to do that? ^^
steve723 Monday 22 July 2013 at 20:27
steve723Anonymous

I think I solved it. I reran the script without deleting the vd and telling the script to erase the vd and recreate it. So far I got all the way to installing Steam and the script is still runing. I suspect that there is a database and that telling me I could delete the folder might have been a mistake, but that is just a theory so don't assume you were nesasaraley wrong, maybe my guess is wrong. It looks like I figured it out, but we will see. I probably misspelled that but I think you can figure what I meant.
Ronin DUSETTE Monday 22 July 2013 at 20:44
Ronin DUSETTE
Admin

Dude, Steve; just reformat your system and set it up correctly. I haven o clue how you do these things to your system. hahaha

Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
alcorsepol Monday 22 July 2013 at 21:28
alcorsepolAnonymous

Well as long as you solved it ^^.
I will take a look at the last two "errors" and get the sorted out so that we can make this script official soon ;D

I still want it to be able to handle the other version of the complete edition though, but that will have to wait a little bit =)

How do I submit the script to become signed and added to POL?
steve723 Tuesday 23 July 2013 at 1:42
steve723Anonymous

All games are now installed and working. When you click on an icon for a Civ4 game in POL it says 'Couldn't load a PNG image'. Just click ok then run and the game will start. It probably just can't load the icon image or something. Icons don't have to display correctly just so long as the short cut works.

The games always change my display settings and don't bother to set them back when I exit the game. That's not very nice. I suppose we will just have to live with that.
steve723 Tuesday 23 July 2013 at 3:29
steve723Anonymous

Civ4 runs choppy (video's) in window mode.
Ronin DUSETTE Tuesday 23 July 2013 at 3:50
Ronin DUSETTE
Admin

Well as long as you solved it ^^.
I will take a look at the last two "errors" and get the sorted out so that we can make this script official soon ;D

I still want it to be able to handle the other version of the complete edition though, but that will have to wait a little bit =)

How do I submit the script to become signed and added to POL?

Quote from alcorsepol


Reas the sticky at the top of the forums "Standards for Script Publishing"

Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
Вы находитесь здесь: Index > Your creations. > [Script] Civilization IV: Complete