Вы находитесь здесь

Форум

Magicka wont load

Автор Replies
mike32547 Tuesday 30 July 2013 at 22:31
mike32547Anonymous

Hi,
Im using linuxmint 15 cinnamon 64 bit os
im currently using pol 4.1.1
Pol installed this version of steam. Steam api v012
Built july 26th 2013

I have 1 terabyte hardrive with a amd radion hd 7700/7800 series
http://pastebin.com/U7e9JhVU  describes in detail about what i have

My problem?  magicka wont load.
Pol went through the installation process of installing microsoft xna and whatever else. "Sorry wasnt really paying attention on what it was doing".. Steam stated magicka was indeed installed but pol kept stating "please wait wile magicka is installed"  I waited at least 5 or more minutes.."was watching a 4 minute youtube vid while i was waiting"

and no matter how i try to run magicka.. via pol or steam. it refuses to load.. No errors.. No warnings. Nothing

thanks in advance for helping me figure this out
Ronin DUSETTE Tuesday 30 July 2013 at 22:42
Ronin DUSETTE
Admin

That pastebin tells us nothing. We need to have the debug output.

Also, your version of POL is WAY behind. Please download 4.2.1 in our download section (just choose the Ubuntu .DEB file).

Make sure your graphics card drivers are the newest from AMD/ATI's website.

Upgrade POL to 4.2.1, delete ~/.PlayOnLinux, and try it again.

Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
mike32547 Wednesday 31 July 2013 at 5:29
mike32547Anonymous

Hi, and thank you DJYoshaBYD for your response, its much appreciated.
this is the terminal output from play on linux
http://pastebin.com/DPnbrZqx

and this is a video clearly showing what im having problems with.
http://youtu.be/HSgaHwnOig0

once again, thank you for your time
Ronin DUSETTE Wednesday 31 July 2013 at 5:45
Ronin DUSETTE
Admin

It looks like it didnt install. What I usually do to run games on steam, is start the steam version that is installed in that virtual drive for said game, and then I start it from the Library, instead of any other shortcuts.

Also, you probably need to run this command before starting POL. That should help.

echo 0|sudo tee /proc/sys/kernel/yama/ptrace_scope

Also, you may need to delete the virtual drive and try the full install again, as something may have failed. Try the above options first, as well as maybe upgrading your graphics driver to the newest catalyst (beta) as the stable version does not work well on your version of Linux Mint (which is basically Ubuntu 13.04). A LOT of graphics issues look like they can be avoided by upgrading to that beta driver.

Other than that, Steam has to be failing in some way. Most games, when running from a POL install that requires steam, requires steam to be FULLY shutdown once steam installs the game, and BEFORE the POL installer finishes.

Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
mike32547 Wednesday 31 July 2013 at 17:46
mike32547Anonymous

Hi,
this is from me running Magicka directly through wine
http://pastebin.com/ykgH7zes
Ill reinstall everything as youve stated and upgrade graphic driver. but in the mean time can you tell me if anything is wrong in that pastebin?
Ronin DUSETTE Wednesday 31 July 2013 at 17:50
Ronin DUSETTE
Admin

mike@mike-desktop ~/.PlayOnLinux/wineprefix/magicka/drive_c/Program Files/Steam/SteamApps/common/Magicka $ wine Magicka.exe

Quote


You cannot run POL installed stuff like that. It HAS to be done through POL if its a POL install. If you do it like that, it totally bypasses the ~/.PlayOnLinux/ folder and POL wine, and just uses your system wine and the ~/.wine/ folder.

That debug really doesnt tell us anything.

Ill reinstall everything as youve stated and upgrade graphic driver.

Quote


Sounds good. Post the debug output (not terminal output) from running in a fresh POL install and virtual drive after doing the above-mentioned things.

Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
booman Thursday 1 August 2013 at 1:52
booman

When I tried Magicka before, I noticed that it requires Dot Net and XNA.
Normally it will download fine if Steam is working, but when you launch the first time it will start installing Windows Libraries.

It would be a good idea to already have the libraries installed with PlayOnLinux before launching:
dotnet_35
xna
d3dx9

Which version of Wine are you using?

† Booman †
Mint 19 64-bit | Nvidia 415.25 | GeForce GTX 1060
Linux for Beginners | List of Linux Games | My Games
PlayOnLinux Guides | PlayOnLinux Explained
Ronin DUSETTE Thursday 1 August 2013 at 1:53
Ronin DUSETTE
Admin

You need to ALWAYS install all dependencies BEFORE you install the main program.

Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
booman Thursday 1 August 2013 at 1:57
booman

Main program Steam or Magicka?

I'm asking because a Steam script won't particularly know which libraries all of the different games will need. So it probably won't install all of them, but the basics for Steam to run.

Then you will need to install the proper libraries for each game before installing them.
I noticed a lot of Source games use the same libraries, so this helps, but 3rd-party games like Magicka use Microsoft XNA framework. So those libraries are going to be needed before installing Magicka.
Of course you can let the game install them for you, but it will be Microsoft's libraries instead of the modified-for-Linux libraries. Chances are, they won't work with Wine.

I also checked out WineHQ's and most of the tests show bronze or garbage... meaning it probably won't run.

† Booman †
Mint 19 64-bit | Nvidia 415.25 | GeForce GTX 1060
Linux for Beginners | List of Linux Games | My Games
PlayOnLinux Guides | PlayOnLinux Explained
Ronin DUSETTE Thursday 1 August 2013 at 2:02
Ronin DUSETTE
Admin

There are a lot of things, like .net, vcrun, directx, and others, that if not installed by POL script, they will fail when the REAL installers try to run that came with the game.

When POL scripts install this stuff, there are certain things that it does to make sure that the dependencies installed by POL dont get overwritten by the real installers during the game install.

Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
booman Thursday 1 August 2013 at 14:16
booman

That is my experience too. I have found that PlayOnLinux libraries work better than the ones from actual game Disks.
I've run into problems where I don't know which libraries a game will need and the script doesn't work.
So I usually hop over to WineHQ and see if someone has posted what libraries the game needs.
Also, sometimes you can look on the Disk or Downloaded game and find directories that has dotnet, d3d, vcdist, etc
Those can give you a clue of which libraries are going to install, but not always which version.

† Booman †
Mint 19 64-bit | Nvidia 415.25 | GeForce GTX 1060
Linux for Beginners | List of Linux Games | My Games
PlayOnLinux Guides | PlayOnLinux Explained
mike32547 Thursday 1 August 2013 at 20:26
mike32547Anonymous

hi again,
this is the debug file of running fresh install of pol and fresh install of magicka
http://pastebin.com/pJZuy3Z9
booman Thursday 1 August 2013 at 20:35
booman

Seems like there are more errors this time...
Are you having the exact same symptoms or are there new ones?

† Booman †
Mint 19 64-bit | Nvidia 415.25 | GeForce GTX 1060
Linux for Beginners | List of Linux Games | My Games
PlayOnLinux Guides | PlayOnLinux Explained
mike32547 Friday 2 August 2013 at 1:49
mike32547Anonymous

booman these are the same errors
Ronin DUSETTE Friday 2 August 2013 at 21:27
Ronin DUSETTE
Admin

That is not the full debug output. When you click tools -> playonlinux debugger, pick the Magicka out of the INSTALL SCRIPTS section, and click Locate this logfile, then open it up in a regular text editor, and post the WHOLE thing from that file into pastebin.


Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
mike32547 Monday 5 August 2013 at 16:16
mike32547Anonymous

Sorry i couldnt get a quicker response was busy doing things, heres a complete debug file.
http://pastebin.com/zHpa6tjz

thank you once again for helping
booman Thursday 17 October 2013 at 23:22
booman

I'm Reviving this thread because I'm working on Magicka again.
I actually got it to work with the PlayOnLinux script
It installs:
  • dxfullsetup
  • steam
  • xna31
  • dotnet35
The script also disables GLSL

I had it running with Wine 1.6-rc4 but I had to click "Play" several times before the game actually launches.

I've read there is an audio issue with Alsa, but not confirmed.

Magicka was running beautifully

† Booman †
Mint 19 64-bit | Nvidia 415.25 | GeForce GTX 1060
Linux for Beginners | List of Linux Games | My Games
PlayOnLinux Guides | PlayOnLinux Explained
Вы находитесь здесь: Index > PlayOnLinux > Magicka wont load