Вы находитесь здесь

Форум

WoT crashing at login

Автор Replies
mrmagoo Thursday 1 August 2013 at 10:14
mrmagooAnonymous

Ok im away on vacation and I have been trying to get WoT to play on my portable linux machine while staying up late.  Trying to see if I can get it to work is almost more interesting then actually playing on this machine, as its giving me something to do.

Anyway: The machine is an hp mini 210 netbook.  I have picked up a .exe install file of .75% compressed textures (for game v.8.7) to see if I can get it to work, but I actually cannot find where play on linux installed the game too, so i am unable to actually apply the textures.  Im also running Lubuntu 12.10 and POL 4.2.1.


Launcher works/loads/updates just fine.  I get to the login screen and everything appears to work normally, even sound.  However when I try to log in, it gets to synchronizing with server and just crashes without an error message.

First off thank you for taking the time to consider this.  Second I would prefer no "Netbook sux, dont even try" stuff.  Im equally interested in just GETTING the game to run vs it actually being remotely playable.
mrmagoo Thursday 1 August 2013 at 21:53
mrmagooAnonymous

I have been running it in debug mode today and found this in the log:

wine: cannot find L"C:\\\\windows\\\\system32\\\\ctfmon.exe"
wine: Unhandled page fault on read access to 0x411a06d0 at address 0x6df800

Im thinking this is whats causing the crashes. Now I need to figure out how install ctfmon.exe in wine.
petch Thursday 1 August 2013 at 22:09
petch
Developer

That's probably not the issue, plenty of programs work fine with this message.
From what I understand it's "Alternative User Input Services", which is totally optional.

Edited by petch

mrmagoo Friday 2 August 2013 at 17:24
mrmagooAnonymous

here is the debug txt right at crashing:

err:d3d_surface:surface_upload_data >>>>>>>>>>>>>>>>> GL_INVALID_ENUM (0x500) from glTexSubImage2D @ surface.c / 2342
err:d3d_surface:surface_upload_data >>>>>>>>>>>>>>>>> GL_INVALID_ENUM (0x500) from glTexSubImage2D @ surface.c / 2342
err:d3d_surface:surface_upload_data >>>>>>>>>>>>>>>>> GL_INVALID_ENUM (0x500) from glTexSubImage2D @ surface.c / 2342
err:d3d_surface:surface_upload_data >>>>>>>>>>>>>>>>> GL_INVALID_ENUM (0x500) from glTexSubImage2D @ surface.c / 2342
err:d3d_surface:surface_init Private setup failed, returning 0x8876086a
fixme:d3d_texture:texture_init Failed to create surface 0x1180cb48, hr 0x8876086a
ImportError: No module named BWAutoImport
petch Friday 2 August 2013 at 18:36
petch
Developer

I interpret that as your video driver supports none of the texture formats the game uses, so it crashes.
booman Friday 2 August 2013 at 19:34
booman

Those are Direct X errors
What video chip are you running?

I have an Acer C7 Chromebook with Intel HD 2000 video chip and it can run some games with PlayOnLinux. My best success is Torchlight 1.
It actually runs really well to my surprise...
Other games like Drakensang launches but crashes with artifacts.
So it might be the limitations of your video chip that won't allow you to play certain games.

Find out what video chip your nebook is using and if its supported by World of Tanks

† Booman †
Mint 19 64-bit | Nvidia 415.25 | GeForce GTX 1060
Linux for Beginners | List of Linux Games | My Games
PlayOnLinux Guides | PlayOnLinux Explained
Ronin DUSETTE Friday 2 August 2013 at 21:32
Ronin DUSETTE
Admin

here is the debug txt right at crashing:

err:d3d_surface:surface_upload_data >>>>>>>>>>>>>>>>> GL_INVALID_ENUM (0x500) from glTexSubImage2D @ surface.c / 2342
err:d3d_surface:surface_upload_data >>>>>>>>>>>>>>>>> GL_INVALID_ENUM (0x500) from glTexSubImage2D @ surface.c / 2342
err:d3d_surface:surface_upload_data >>>>>>>>>>>>>>>>> GL_INVALID_ENUM (0x500) from glTexSubImage2D @ surface.c / 2342
err:d3d_surface:surface_upload_data >>>>>>>>>>>>>>>>> GL_INVALID_ENUM (0x500) from glTexSubImage2D @ surface.c / 2342
err:d3d_surface:surface_init Private setup failed, returning 0x8876086a
fixme:d3d_texture:texture_init Failed to create surface 0x1180cb48, hr 0x8876086a
ImportError: No module named BWAutoImport

Quote from mrmagoo


I know there is WAYYYYYYYYYYYYY more debug output than that. Please post the WHOLE thing, not just the errors that you think are wrong. Read the stickies for more info. This will give us more insight into what is wrong.

Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
mrmagoo Saturday 3 August 2013 at 0:37
mrmagooAnonymous

Jayzon Saturday 3 August 2013 at 11:21
JayzonAnonymous

This may or may not help, but you can try to run playonlinux with s3tc forced compression.

force_s3tc_enable=true playonlinux
If this does not work for WoT, at least try it for the games with artifact issues.

Hope this helps.
Вы находитесь здесь: Index > PlayOnLinux > WoT crashing at login