Вы находитесь здесь

Форум

Wine working depending on used DE/WM?

Автор Replies
cronotk Friday 9 August 2013 at 9:12
cronotkAnonymous

Hello!

Because of GNOME 3 being very buggy lately (lagging mouse pointer, randomly blanking the screen for no reason, ...) I have decided to use another DE/WM until those are fixed. The games started from PoL run fine on GNOME 3 though, no stuttering at all. The games include Test Drive Unlimited, Morrowind and World of Tanks.
However, when I start those games while using i.e. Enlightenment or Fluxbox they will not work:
Test Drive Unlimited: white screen/window regardless of fullscreen or windowed execution
World of Tanks: Launcher works fine, but after starting the game: white screen/window regardless of fullscreen or windowed execution
Morrowind: intro video works, but screen freeze after getting to the main menu screen (only fullscreen tested)

Why? I'd have expected that at least Fluxbox (being not composited) would have worked, but no. What does PoL do different while running on GNOME? Or what does GNOME do different that wine works there?

Regards



Distribution: Sabayon
Graphics: some passively cooled Nvidia card with proprietary drivers installed (319.32)
Log files: Sorry, I can provide them later (this evening GMT) if you need them.
booman Friday 9 August 2013 at 21:50
booman

That is very strange. I often use Openbox to test games and gain a few frames per second and have not experienced and problematic symptoms.

Normally I test in Cinnamon first, then logout and log into Openbox.
Then I launch Terminal and type PlayOnLinux
Then I launch my game. usually runs fine...

† Booman †
Mint 19 64-bit | Nvidia 415.25 | GeForce GTX 1060
Linux for Beginners | List of Linux Games | My Games
PlayOnLinux Guides | PlayOnLinux Explained
Вы находитесь здесь: Index > PlayOnLinux > Wine working depending on used DE/WM?