Вы находитесь здесь

Форум

version not same as downloaded?

Автор Replies
gggreggg Saturday 21 September 2013 at 2:12
gggregggAnonymous


New to linux.  Operating with Mint Olivia 15.  On Toshiba Satelite laptop.

Downloaded playonlinux from this site, file named as v 4.2.1

Installed it and it recomended downloading xterm and z7.  Did not but clicked through and went to install / multimedia / ableton 8 & 9.

Getting the error message: "playonlinux 4.1.1 is too old to continue."  "Use 4.1.9" 

I thought I installed 4.2.1 , or does linux do numbers differently too?  ;)

Please advise recomendations to get this issue resolved.  All I wanted windows for now was ableton but if I can use playonlinux I can wipe MS Win from my system.  Please help!
petch Saturday 21 September 2013 at 9:47
petch
Developer

Hi, you're using 4.1.1 indeed (See Help > About), if you didn't add the PlayOnLinux repository to your list of package sources, a system update may have downgraded PlayOnLinux to the version included with Mint 15.
gggreggg Monday 23 September 2013 at 2:59
gggregggAnonymous

hmmm

the OS comes with out of date software and downgrades my updates without telling me or asking me? Seems a bit odd and the kind of thing I thought I was leaving behind with windows!

I've looked into the packages issue and the "synaptic package manager" but am not getting very far. Though it is outside of the scope of this forum, any leads to learn more about package sources and a process around this concept would be appreciated.

Daerandin Monday 23 September 2013 at 15:20
DaerandinAnonymous

Which playonlinux package did you get from this site? Did you get a .deb file or the source archive?

The text below is certainly quite out of the scope of this forum, but I think it should be said.

As for understanding your distros package management, you should read the documentation available on the Linux Minst website and look through the forums as well. From what you are saying in your post you have recently started using GNU/Linux and have previously been a windows user. You should definitely spend some time looking into how your chosen distro works.

I'll help you out with a little bit if info regarding most debian based distros, and indeed most of the more stable distros available. Packages in the official repositories for such distros tend to be slightly older than the absolute latest release from upstream sources. This is because the latest version from upstream sources can often contain bugs or may even break certain setups in extreme cases. To avoid such issues, pretty much all the beginner friendly distros stick with slightly older versions known to be stable.

For most software you probably don't mind. Then there are certain things you want the latest version of, such as PlayOnLinux. Now I am not familiar with Mint, but I find it strange that it would downgrade a package unless you actually installed it from the official repository.
Ronin DUSETTE Wednesday 9 October 2013 at 16:17
Ronin DUSETTE
Admin

Mint is just an offshoot of Ubuntu, and they share a lot of their repo's packages (as outdated as they are). I pretty much gave up on trying to work with them through a bug report to get it upgraded, as they kept asking me repeatedly for the same stuff; dependencies, which are already taken care of with the newest version, but they are just lagging. lol. I always just installed it from the .deb file anyway.

Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
gggreggg Friday 11 October 2013 at 3:49
gggregggAnonymous

I have downloaded the .deb file of POL 4.2.1 and installed it through GDebi - this worked to resolve the issue of an out dated version of POL holding up my installation.

Now I have another issue - thanks to those of you helping out with this!

I was a windows user since v2, and recently made the switch to linux - but it's a steep learning curve and I have a full time job and a small baby so not a lot of time to learn as much through trial and error as I would like. These forums have been very helpful, and your patience and help is appreciated!
Вы находитесь здесь: Index > PlayOnLinux > version not same as downloaded?