Вы находитесь здесь

Форум

No Sound or not recognised

AMD 64 bit

Автор Replies
journeyman3000 Monday 9 December 2013 at 10:29
journeyman3000Anonymous

Hi there.

I'm a new linux user and have managed to get Linux Mint 16 installed with full sound functioning through my HDMI.  I have installed WINE and PlayOnLinux.

I've bought and downloaded several games through GOG.com. POL installed these just fine. I had to configure it pretty carefully to get the video settings correct.*

Unfortunately the sound does not work.  I have to run the game using the version of wine installed on my machine to get it to work.  I'd rather I could run it properly using POL. The WINE config in POL doesn't appear to see my sound card settings.

Also it seems that POL installs games as 32 bit, which might be the problem. I can make a 64 bit environment but how can I move the installation to it?

Not keen on having to reinstall, mostly becuase I don't really know how and it was great just to get the GOG installer to do everything.

Any help would be appreciated.  cheers



* Note to Dev:  It would be great if when setting the video settings there was a countdown to reset them to normal.  I've had to reboot many times becuase the video settings were wrong.
booman Monday 9 December 2013 at 22:55
booman

I had the same problem with Mint too.
I have a GeForce 550 Ti with HDMI audio and didn't want to use it.
But every time I booted up Mint the audio would default to HDMI.
So I would have to manually set it to analog audio several times.
After that it finally remembered.
Go to your system settings and make sure the default is HDMI.
Then try running one of your games.

† Booman †
Mint 19 64-bit | Nvidia 415.25 | GeForce GTX 1060
Linux for Beginners | List of Linux Games | My Games
PlayOnLinux Guides | PlayOnLinux Explained
journeyman3000 Tuesday 10 December 2013 at 10:50
journeyman3000Anonymous

Thanks for your response. I do have HDMI as the default. It's the only sound output I use.

As mentioned the sound works just fine in WINE when I use it directly. It just doesnt work with POL. Also I managed to work out how to use the game in the 64 bit environment but that didnt work either.

As a side not, I used a previous version of wine (1.3.24 i think), and for a moment the sound actually worked in the test. But it then stopped and would not work again. I don't know what that was about but i'm not really that cleaver enough to fix.

any other suggestions?
journeyman3000 Tuesday 10 December 2013 at 11:05
journeyman3000Anonymous

Correction: I didn't work out how to play the game in 64 bit mode. When I thought I moved my games to that environment, what I actually did was competely obliterate them and POL conveniently deleted them, and all my save data.

Nice....not.
petch Tuesday 10 December 2013 at 13:33
petch
Developer

Virtual drives cannot be converted between 32 and 64bit, and script are written and tested for an architecture.
When a change is detected, the "Overwrite" option is not provided.
Time to read the options you're offered.
booman Tuesday 10 December 2013 at 16:10
booman

Correction: I didn't work out how to play the game in 64 bit mode. When I thought I moved my games to that environment, what I actually did was competely obliterate them and POL conveniently deleted them, and all my save data.

Nice....not.

Quote from journeyman3000

I recommend installing your game again in a 32-bit virtual drive
Do you know if your distro is using alsa or pulse audio?

Are you using a 64-bit distribution?

Edited by booman


† Booman †
Mint 19 64-bit | Nvidia 415.25 | GeForce GTX 1060
Linux for Beginners | List of Linux Games | My Games
PlayOnLinux Guides | PlayOnLinux Explained
journeyman3000 Tuesday 10 December 2013 at 20:07
journeyman3000Anonymous

I installed in both 32 and 64 bit. 32 bit first. Neither works. I'm using a 64 bit distribution.

My main WINE sound config - which works just fine - uses PulseAudio. the POL Wine uses either Alsa or default output. Appearently POL doesn't use pulse, or there are some problems between them - i don't understand what their problem is, but maybe they'll patch things up between each other one day.
petch Tuesday 10 December 2013 at 20:20
petch
Developer

journeyman3000 Wednesday 11 December 2013 at 11:43
journeyman3000Anonymous

I've read this info, but since pulseaudio isnt even acknowledged by POL, how do I get it to work? I beleive Alsa is installed but I can't see it either. HDMI isnt even recognise with the latest version.

Also, if POL devs say that they're not even planning on playing with Pulse, then the question remains...what are they doing about all the apparent sound issues that people are having?

Is there a solution to this issue?

Thanks for responses so far. cheers
petch Wednesday 11 December 2013 at 13:51
petch
Developer


Have you tried opening PlayOnLinux console and type what's suggested in the last message of the bug report above?

type -t padsp && POL_Config_Write BEFORE_WINE 'padsp'

(Just in case, to undo above:)
POL_Config_Delete BEFORE_WINE
journeyman3000 Thursday 12 December 2013 at 8:55
journeyman3000Anonymous

I opened the POL console (in the Tools menu), and entered that line. There was no effect.

Update: Prior to doing this, I installed neverwinter nights by downloading the file and manually installing. the sound works. Tried the same with every other game in exactly the same way, but the sound still fails so more confused than ever.
booman Thursday 12 December 2013 at 18:37
booman

Wow, that is very strange. Only Neverwinter Nights sound works for you?
Try plugging speakers into the analog output on your computer and change the default to analog.
If you get sound, then its got to be something with the video drivers and HDMI

I try to stay away from HDMI audio anyways because it could possibly slow down your video card.

† Booman †
Mint 19 64-bit | Nvidia 415.25 | GeForce GTX 1060
Linux for Beginners | List of Linux Games | My Games
PlayOnLinux Guides | PlayOnLinux Explained
Daerandin Sunday 15 December 2013 at 3:25
DaerandinAnonymous

If you use PulseAudio, then you can try installing Pavucontrol, it should be available in the official repos for Mint as it is commonly used. It is a very useful sound config utility for PulseAudio.

Try launching any of your games that don't give you any sound output, then open pavucontrol while the game is running. Switch to the Playback tab in pavucontrol where you should be able to see sound output for all running applications. Here you can also change sound output while a game is running, or look at how your sound devices are configured.
journeyman3000 Sunday 15 December 2013 at 9:58
journeyman3000Anonymous

Thanks for your advice. however the sound for linux is working just fine. ever other application, is functioning normally. I've installed several games now and each one of them , despite being installed with exactly the same settings, function in a different way.

If it's not the sound the the video doesn't work too good either, displaying full screen anywhere around the screen but the center, forcing a windowed mode that doesn't allow for an increase in the size of the window.

I've tried all kinds of things but the fact here is that I can run stuff directly from wine and it works. From POL...nope. I think maybe best advice is stay away from it until the devs fix their shiz.

Daerandin Sunday 15 December 2013 at 14:10
DaerandinAnonymous

I would stil suggest you install Pavucontrol and look into the settings there. I don't know the Mint sound architecture, but if it is as you mentioned previously that Alsa is also installed, then I would assume that it is working with Alsa as a backend for PulseAudio, in which case the problem with missing sounds could simply be with how certain defaults are set on your system.

Not to mention, Pavucontrol will let you output sounds from different sources to different output devices, such as music in speakers and game sonds on headphones. I think it would be worthwhile to give it a try as it is extremely easy to use.
booman Monday 16 December 2013 at 14:38
booman

This is the first I've heard that PlayOnLinux audio doesn't work. I've used it on several distro's and totally different hardware. Audio always works for me.
So I have a feeling its driver related since you are using HDMI
I'm sure you are connecting your HDMI to a television so its totally necessary, but its strange because PlayOnLinux uses Wine.
If Wine alone works, then PlayOnLinux should work.
Can you narrow down to which versions of Wine you are using in PlayOnLinux?

† Booman †
Mint 19 64-bit | Nvidia 415.25 | GeForce GTX 1060
Linux for Beginners | List of Linux Games | My Games
PlayOnLinux Guides | PlayOnLinux Explained
Вы находитесь здесь: Index > PlayOnLinux > No Sound or not recognised