Форум

PlayOnLinux doesn't start, but uses 97+% of CPU power

Автор Replies
Sean2323 Sunday 19 January 2014 at 21:49
Sean2323Anonymous

Hey guys, I recently installed PlayOnLinux 4.2.2, and whenever I try to run it from the icon, it simply flashes a bit, then stops. Running it in the terminal yields:
http://i.imgur.com/IElLxHg.jpg

This entire piece of text repeats infinitely until Ctrl+C is held down for a few seconds, or the Terminal is closed.

Checking my system monitor, I see this:
http://imgur.com/a/0WDer
The program says it's taking up 0 CPU power, when in reality it appears to be driving both cores up to 100.0%.

My OS is Ubuntu 12.04, I have Python 2.7.3 installed, and I've used the Synaptic Package Manager to install and update all of PlayOnLinux's dependencies.

Edited by Sean2323

hego555 Sunday 19 January 2014 at 22:29
hego555Anonymous

Did you install PlayonLinux from the software center, if not, uninstall it, reinstall from the software center.

sudo apt-get install playonlinux

to install from terminal.
Sean2323 Sunday 19 January 2014 at 22:44
Sean2323Anonymous

reinstall from the software center.

sudo apt-get install playonlinux
to install from terminal.

Quote from hego555

The problem remains, no changes whatsoever.
Edit: Rebooted, problem still remains.

Edited by Sean2323

petch Monday 20 January 2014 at 1:04
petch
Developer

Looks like a broken Python installation, maybe more than one 2.7.x version installed?
Google for the error message ("ImportError: cannot import name MAXREPEAT") and you'll find several hits...