Вы находитесь здесь

Форум

Required Game Libraries or Components?

libraries, requirements, components

Автор Replies
siouxscout Wednesday 16 April 2014 at 17:43
siouxscoutAnonymous

The one thing that I seem to be missing when trying to setup a game or get something to work is know what libraries or components I might need to install manually. Whats an easy way to tell other then the obvious like something clearly stating it requires Adobe Air or vcrun2008? Or is this normally not needed maybe?

Recenting I just had issues getting hearthstone working, its working now but really for all I knew it could have tons of requirements I knew nothing about. Luckily latest wine and newest installer seemed to work fine.

Thanks
petch Wednesday 16 April 2014 at 20:39
petch
Developer

For programs that have an install script, like Hearthstone, start with the install script.
For programs not in the list, start by checking the AppDB
Then you can start the program in debug mode (select the shortcut, click on "Debug" in the side panel) and interpret the results. That requires some expertise, and it's difficult to give hard rules on how to do that.
Then you can experiment. Since component cannot usually be simply removed, it's better to backup the virtual drive before anything.

booman Thursday 17 April 2014 at 1:23
booman

Petch is absolutely right. If there is a game (script) available, then it will install the necessary libraries.

Normal libraries like d3dx9, d3dx10, physx, dotnet, vcrun, etc. are bundled with the game files.
So if you want to know what libraries a game requires they are usually found in the game folder, support folder or even a folder called win32. So you will have to look on the CD/DVD or in the download files (Rar, Zip, 7zip, etc)
Even Steam games have packaged libraries after you download the game.

So if you are doing a manual installation check those sources and AppDB for required libraries. Sooner or later you will find the right ones.
If not, post here and we'll try to find out which one's are needed for a game.

† Booman †
Mint 19 64-bit | Nvidia 415.25 | GeForce GTX 1060
Linux for Beginners | List of Linux Games | My Games
PlayOnLinux Guides | PlayOnLinux Explained
Вы находитесь здесь: Index > PlayOnLinux > Required Game Libraries or Components?