Вы находитесь здесь

Форум

LoL does not even start

Автор Replies
mico_magnificent Friday 18 July 2014 at 17:02
mico_magnificentAnonymous

Hello guys and gals,

Recently my LoL stopped working. It happened quite suddenly between monday night and tuesday morning so I believe it is an issue with a new release of some sort. I am using Linux Mint 17 with PLay on Linux 4.2.2. My configuration for LoL didnt change after I set it up following Booman's wonderful guide using wine 1.7 League of Legends. I ran debug and I received the following output:

[07/18/14 16:59:52] - Running wine-1.7-LeagueOfLegends lol.launcher.exe (Working directory : /home/mico/.PlayOnLinux/wineprefix/LeagueOfLegendsAgain/drive_c/Riot Games/League of Legends)
(  ERROR)[16:59:52.958] RADS::Common::RegistryHelp::RegKeyValueString::RegKeyValueString: Failed to find registry value "ProgramW6432Dir" (2).
fixme:ver:GetCurrentPackageId (0x33fc8c (nil)): stub
wine: Unhandled exception 0x40000015 in thread 34 at address 0x330023:0x00796d26 (thread 0034), starting debugger...

I tried reinstalling it following the guide again but it gives the same error.

I hope that nobody else is experiencing this annoying error

 

Mico :D

Edited by Tinou

Maskullking Saturday 19 July 2014 at 11:19
Maskullking

I am experincing the same error half of the time, the other half I get a program error crash.

and this debug:

 

[07/19/14 21:17:30] - Running wine-1.7.19-LeagueOfLegends2 lol.launcher.exe (Working directory : /home/haftka/.PlayOnLinux/wineprefix/LeagueOfLegends/drive_c/Riot Games/League of Legends)
(  ERROR)[21:17:30.663] RADS::Common::RegistryHelp::RegKeyValueString::RegKeyValueString: Failed to find registry value "ProgramW6432Dir" (2).
fixme:msvcp:_Locinfo__Locinfo_ctor_cat_cstr (0x33f918 1 C) semi-stub
fixme:msvcp:_Locinfo__Locinfo_ctor_cat_cstr (0x33f748 1 C) semi-stub
fixme:msvcp:_Locinfo__Locinfo_ctor_cat_cstr (0x33f8c4 1 C) semi-stub
fixme:ver:GetCurrentPackageId (0x33fc8c (nil)): stub
wine: Unhandled exception 0x40000015 in thread 30 at address 0x796d26 (thread 0030), starting debugger...

 

annoying to say the least.

mico_magnificent Saturday 19 July 2014 at 13:17
mico_magnificentAnonymous

Im not sure what happened but I tried re-installing just as Play on Linux says and it works now. I also got that error message Maskullking but it somehow it is working now.

I cant get the store (where you buy runes, not the in-game shop) to work.

omraf Saturday 19 July 2014 at 15:42
omraf

the soultion for now is to reinstall it   i have the same problem

Quentin PÂRIS Saturday 19 July 2014 at 16:48
Quentin PÂRIS
Admin

Have you tried to use the latest wine version (1.7.20-LeagueOfLegends3) before reinstalling it?

dukanax Sunday 20 July 2014 at 1:44
dukanaxAnonymous

I have the same problem with my install and all older wine versions. (no matter if LoL or generic)

There is no 1.7.20-LeagueOfLegends3, only a 1.7.18-LeagueOfLegends3. It's working but it's missing the red icon in shop fix.

I'm currently using 1.7.19-LeagueOfLegends2 as it plays perfectly. Just got the shop issues.
Maskullking Sunday 20 July 2014 at 3:45
Maskullking

I tried reinstalling(both in the original prefix and a new fresh one) but it fails.

Same debug output on both:

 

[07/20/14 13:42:00] - Running wine-1.7.18-LeagueOfLegends3 /home/haftka/Downloads/LeagueofLegends_NA_Installer_05_07_13.exe (Working directory : /)
fixme:wtsapi:WTSQuerySessionInformationW Stub (nil) 0xffffffff 4 0xa5e644 0xa5e63c
fixme:ntdll:NtLockFile I/O completion on lock not implemented yet
fixme:storage:create_storagefile Storage share mode not implemented.
fixme:advapi:LsaOpenPolicy ((null),0xb7e2f0,0x00000001,0xb7e30c) stub
fixme:advapi:LsaClose (0xcafe) stub
fixme:advapi:LsaOpenPolicy ((null),0xb7e2f0,0x00000001,0xb7e30c) stub
fixme:advapi:LsaClose (0xcafe) stub
fixme:advapi:LsaOpenPolicy ((null),0xb7e2f0,0x00000001,0xb7e30c) stub
fixme:advapi:LsaClose (0xcafe) stub
fixme:advapi:LsaOpenPolicy ((null),0xb7e2f0,0x00000001,0xb7e30c) stub
fixme:advapi:LsaClose (0xcafe) stub
fixme:advapi:LsaOpenPolicy ((null),0xb7e2f0,0x00000001,0xb7e30c) stub
fixme:advapi:LsaClose (0xcafe) stub
fixme:advapi:LsaOpenPolicy ((null),0xb7e2f0,0x00000001,0xb7e30c) stub
fixme:advapi:LsaClose (0xcafe) stub
fixme:shell:SHGetKnownFolderPath flags 0x00004400 not supported
fixme:shell:SHGetKnownFolderPath flags 0x00004400 not supported
fixme:shell:SHGetKnownFolderPath flags 0x00004400 not supported
err:richedit:ReadStyleSheet missing style number
fixme:wtsapi:WTSQuerySessionInformationW Stub (nil) 0xffffffff 4 0xa5e640 0xa5e638
fixme:wtsapi:WTSQuerySessionInformationW Stub (nil) 0xffffffff 4 0xa5e640 0xa5e638
fixme:wtsapi:WTSQuerySessionInformationW Stub (nil) 0xffffffff 4 0xa5e684 0xa5e67c
fixme:wtsapi:WTSQuerySessionInformationW Stub (nil) 0xffffffff 4 0xa5e644 0xa5e63c
fixme:ntdll:NtLockFile I/O completion on lock not implemented yet
fixme:storage:create_storagefile Storage share mode not implemented.
fixme:advapi:LsaOpenPolicy ((null),0x2c8e2f0,0x00000001,0x2c8e30c) stub
fixme:advapi:LsaClose (0xcafe) stub
fixme:advapi:LsaOpenPolicy ((null),0x2c8e2f0,0x00000001,0x2c8e30c) stub
fixme:advapi:LsaClose (0xcafe) stub
fixme:advapi:LsaOpenPolicy ((null),0x2c8e2f0,0x00000001,0x2c8e30c) stub
fixme:advapi:LsaClose (0xcafe) stub
fixme:advapi:LsaOpenPolicy ((null),0x2c8e2f0,0x00000001,0x2c8e30c) stub
fixme:advapi:LsaClose (0xcafe) stub
fixme:advapi:LsaOpenPolicy ((null),0x2c8e2f0,0x00000001,0x2c8e30c) stub
fixme:advapi:LsaClose (0xcafe) stub
fixme:advapi:LsaOpenPolicy ((null),0x2c8e2f0,0x00000001,0x2c8e30c) stub
fixme:advapi:LsaClose (0xcafe) stub
fixme:shell:SHGetKnownFolderPath flags 0x00004400 not supported
fixme:shell:SHGetKnownFolderPath flags 0x00004400 not supported
fixme:shell:SHGetKnownFolderPath flags 0x00004400 not supported
fixme:ntdll:server_ioctl_file Unsupported ioctl 110008 (device=11 access=0 func=2 method=0)
fixme:wtsapi:WTSQuerySessionInformationW Stub (nil) 0xffffffff 4 0xa5e640 0xa5e638

Maskullking Tuesday 22 July 2014 at 3:17
Maskullking

*bump*

So no one has a fix for this yet?

Maskullking Saturday 2 August 2014 at 6:37
Maskullking

*bumping again*

Sorry for double bumping, but this is still a problem, and I didn't want to make another topic for the same issue.

I have gone over all guides and other posts regarding LoL with wine.

But I still can't install or run LoL anymore.

Edited by Maskullking

TimidCat Saturday 2 August 2014 at 12:52
TimidCat

Try this:

-open up registry editor

-go to HKEY_LOCAL_MACHINE/Software/Microsoft/Windows/CurrentVersion

-inside currentversion create new string value

-name it ProgramW6432Dir

-set its value to C:\Program Files

That will fix the ProgramW6432Dir registry error. Hope this helps :)

Maskullking Friday 8 August 2014 at 8:36
Maskullking

That does not change anything. As I did not expect it to anyway.

Correct me if I am wrong, as I am making an assumption here, but that registry string would be for 32bit installs in a 64bit wine enviorment no?

I am using 32bit wine, therefore has nothing to do with these problems I am getting.

(but I tried it anyway on the chance I was wrong but doesn't seem to be the case.)

mico_mailman Thursday 18 September 2014 at 23:16
mico_mailmanAnonymous

This is still mico but i forgot my account info.

I put linux 17 on my new lenovo laptop but i am having the same problem i originally started with. I tried TimidCat's suggestion and it got rid of the registery error but it still doesnt work. Now all I get are errors that look like this:

fixme:advapi:EventRegister {2f9efe86-4af7-4f37-a40f-94b909a157d6}, 0x4cc120, 0x625210, 0x63f850
fixme:advapi:EventRegister {ea08c559-95a8-4aa2-afa6-18738eec6d37}, 0x4cc120, 0x625280, 0x63f8c8
fixme:advapi:EventRegister {10f6728c-ef92-4bf1-8397-49e693a6eb74}, 0x4cc120, 0x625248, 0x63f888
fixme:advapi:EventRegister {46dd7f96-60cb-416b-8085-da5cd8f491dd}, 0x4cc120, 0x6251d8, 0x63f848
fixme:ver:GetCurrentPackageId (0x33fbf0 (nil)): stub

I'm not sure why this is happening especially since searching for the error codes turned up no results. I'd like to thank TimidCat for the partial solution.

Llama_Rider Monday 29 September 2014 at 22:16
Llama_RiderAnonymous

Hi. I recently installed a fresh version of linux mint 17 on my computer. Using the install script in the POL install menu for League of Legends, I get through an installation with no errors, but the program fails to open. (the program LolLauncher.exe has encountered a serious problem and needs to close. We are sorry for the inconvenience.)

When using the "Debug" option,
 

[09/29/14 15:09:13] - Running wine-1.7.19-LeagueOfLegends2 lol.launcher.admin.exe (Working directory : /home/(user)/.PlayOnLinux/wineprefix/LeagueOfLegends/drive_c/Riot Games/League of Legends)
c
fixme:advapi:EventRegister {2f9efe86-4af7-4f37-a40f-94b909a157d6}, 0x4cc120, 0x625210, 0x63f850
fixme:advapi:EventRegister {ea08c559-95a8-4aa2-afa6-18738eec6d37}, 0x4cc120, 0x625280, 0x63f8c8
fixme:advapi:EventRegister {10f6728c-ef92-4bf1-8397-49e693a6eb74}, 0x4cc120, 0x625248, 0x63f888
fixme:advapi:EventRegister {46dd7f96-60cb-416b-8085-da5cd8f491dd}, 0x4cc120, 0x6251d8, 0x63f848
fixme:ver:GetCurrentPackageId (0x33fbf0 (nil)): stub
wine: Unhandled exception 0x40000015 in thread 30 at address 0x573eea (thread 0030), starting debugger...

These errors appear to be similar, in some lines, identical to what others have been experiencing.I will try to reinstall LoL without the testing scripts, and see if it makes a difference.

Llama_Rider Tuesday 30 September 2014 at 2:56
Llama_RiderAnonymous

I think I have made progress. I installed LoL using Booman's guide, and got errors identical to what occured previously. I browsed the internet a bit, finding others with this problem, and some of the errors come from, apparently, adjusting the video settings tab after installation. I fully uninstalled LoL from the virtual drive, but did not remove the virtual drive. Then, I fixed the video settings, and for good measure, used TimidCat's registry fix. For anyone who is looking to find their graphics memory, which I believe is important, and may have been causing errors, here is a source: http://www.cyberciti.biz/faq/howto-find-linux-vga-video-card-ram/

After making these corrections to the virtual drive, I ran the installer in the drive, this time with the debugger open.

[09/29/14 19:40:01] - Running wine-1.7.19-LeagueOfLegends2 /home/gavin/Downloads/LeagueOfLegendsBaseNA.exe (Working directory : /)
fixme:ole:CoInitializeSecurity (0x32fa58,-1,(nil),(nil),6,2,(nil),8192,(nil)) - stub!
fixme:ntdll:NtLockFile I/O completion on lock not implemented yet
p11-kit: couldn't load module: /usr/lib/i386-linux-gnu/pkcs11/p11-kit-trust.so: /usr/lib/i386-linux-gnu/pkcs11/p11-kit-trust.so: cannot open shared object file: No such file or directory
fixme:ole:RemUnknown_QueryInterface No interface for iid {00000019-0000-0000-c000-000000000046}
fixme:ole:RemUnknown_QueryInterface No interface for iid {00000019-0000-0000-c000-000000000046}
fixme:apphelp:ApphelpCheckInstallShieldPackage stub: 0x32f39c L"C:\\users\\gavin\\Temp\\{290196E1-CFC9-4399-9191-6586FA5505F5}\\Disk1\\data1.hdr"
err:richedit:ReadStyleSheet missing style number
fixme:explorerframe:taskbar_list_SetProgressState iface 0xd12500, hwnd 0x20048, flags 2 stub!
fixme:explorerframe:taskbar_list_SetProgressValue iface 0xd12500, hwnd 0x20048, ullCompleted 1, ullTotal 64 stub!
fixme:shell:IShellLinkA_fnGetPath (0x1fc4220): WIN32_FIND_DATA is not yet filled.
fixme:shell:IShellLinkA_fnGetPath (0x1fc4220): WIN32_FIND_DATA is not yet filled.
err:setupapi:do_file_copyW Unsupported style(s) 0x144
err:setupapi:do_file_copyW Unsupported style(s) 0x144
err:setupapi:do_file_copyW Unsupported style(s) 0x144
err:setupapi:do_file_copyW Unsupported style(s) 0x144
err:setupapi:do_file_copyW Unsupported style(s) 0x144
fixme:shell:IShellLinkA_fnGetPath (0x1f7de90): WIN32_FIND_DATA is not yet filled.
fixme:shell:IShellLinkA_fnGetPath (0x1f7de90): WIN32_FIND_DATA is not yet filled.

As one can observe, there are errors during the installation somehow

Attempting to run LoL after:

[09/29/14 19:42:04] - Running wine-1.7.19-LeagueOfLegends2 lol.launcher.exe (Working directory : /home/gavin/.PlayOnLinux/wineprefix/LeagueOfLegends/drive_c/Riot Games/League of Legends)
wine: Unhandled exception 0x40000015 in thread 31 at address 0x573eea (thread 0031), starting debugger...

Still errors and crashes, but less of them.

Edited by Llama_Rider

SheHateYou Thursday 18 December 2014 at 19:13
SheHateYouAnonymous

Solution for me I manualy start the LOL client with terminal and sudo privilages

Вы находитесь здесь: Index > PlayOnLinux > LoL does not even start