Вы находитесь здесь

Форум

League of Legends

Connection problems with POL script

Автор Replies
Jump to the page: 1 - 2
claudiop Saturday 23 August 2014 at 2:26
claudiopAnonymous

Hi all.
I've used the script provided by POL to install league of legends(as i've already did before), the problem is that whenever the patcher finishes, and i get to the login screen, it simply is unable to login.

In the patcher it could connect with no problems, and download everything, but once it reaches the login, it tells  "Did not receive a response from the server(attemp x)".
It does three attemps, and each takes less than half a second.
Ends with "Login server did not respond.[...]"

I installed the game myself in a clean wine prefix, with corefonts, vcrun2005, air, and dx9, and it could login well with no problems at all (even if the game crashed loading), so the problem probably is within the script.

There is the game log: https://ezcrypt.it/Hs9n#cbHnYx6UiiIJVr7M6ACC6YCl
And there is the POL log: https://ezcrypt.it/Ls9n#eXNlm0zywR3mTj7xT5lFRWLh
Happens both with Stable and PBE.

Thanks for looking into it :)

jgreen Thursday 28 August 2014 at 0:00
jgreenAnonymous

Same here, and I've got lib32-gnutls installed...

Ronin DUSETTE Thursday 28 August 2014 at 7:49
Ronin DUSETTE
Admin

even if the game crashed loading

It seems like there is still a problem outside of the script if it is still crashing, though. 


Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
jgreen Thursday 28 August 2014 at 12:41
jgreenAnonymous

>It seems like there is still a problem outside of the script if it is still crashing, though. 

Possibly. But the problem is that you can NOT even login with the current script.

 

Ronin DUSETTE Thursday 28 August 2014 at 21:34
Ronin DUSETTE
Admin

 

Possibly. But the problem is that you can NOT even login with the current script.

Others seem to be able to. We always get bug reports about LoL, but if the script was broken for everyone, we would probably be flooded with more reports than usual. I am just curious what is different on your system as opposed to everyone elses. Besides, it still crashes with a manual install, so it seems to be perhaps a missing library or something on your system. 

Of couse, we are just guessing, because we have no idea what kind of system you are running (as per the forum rules, you are SUPPOSED to post those in the FIRST post, with your terminal or debug output). The debug output that I see in your first post does not show much except those winsock errors, which has to do with networking. Again, still hard to tell, because we have no clue what your system specs are. 

Oh, and by debug output, I mean using the installer script. NOT from a manual install. We need to troubleshoot using the script, so that if there actually is an error, we can find it. The full debug output, too. Not just sections that you may think have errors. The whole thing, start to finish. I actually prefer that people run playonlinux from the terminal and post the direct terminal output, but that is just me. 

Edited by RoninDusette


Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
djcole187 Monday 1 September 2014 at 10:48
djcole187Anonymous

I also can't login, it does the 3 attempts at connecting at login pretty quick.  Like a firewall block?  I'm new to linux so no idea...  I'm running Arch with Cinnamon and have 1.7.24LeagueOfLegendsCSMT, did a fresh install also.  Have also tried with 1.7.25 and it also has the same problem.  How am I able to give you a list of libraries installed?  And anything else necessary to help?

claudiop Tuesday 2 September 2014 at 4:47
claudiopAnonymous

Sorry, my bad. I am on Arch x86_64.
There are all my system packages: https://ezcrypt.it/0x9n#3UBzXGJh8EDqWScSylC7aayN
jgreen, also on Arch?

League already worked in this same system (same install, another graphics, same brand) a year or two ago.

EDIT: My bad, wine/POL missing on that list, i've uninstalled them since i don't need them for anything else than league (got plenty of native games). Yet the lib32's are still present.

Edited by claudiop

avojevlavo Friday 5 September 2014 at 23:31
avojevlavoAnonymous

In the patcher it could connect with no problems, and download everything, 
but once it reaches the login, it tells  
"Did not receive a response from the server(attemp x)".
It does three attemps, and each takes less than half a second.
Ends with "Login server did not respond.[...]"

bump, same problem here

i have tried multiple versions of lib32-gnutls (latest is lib32-gnutls-3.3.7-1)

for a while I was suspecting my internet connection (new place) so i started forwarding ports - didnt help, and my windows laptop runs lol just fine except for the fact that some of my friends CANT invite me (i get the invite but after clicking accept it just says that the invite has expired)

help please.

on archlinux64

 Running wine-1.7.24-LeagueOfLegendsCSMT lol.launcher.admin.exe (Working directory : /home/avo/.PlayOnLinux/wineprefix/LeagueOfLegends/drive_c/Riot Games/League of Legends)
fixme:msvcp:_Locinfo__Locinfo_ctor_cat_cstr (0x33f918 1 C) semi-stub
fixme:msvcp:_Locinfo__Locinfo_ctor_cat_cstr (0x33f758 1 C) semi-stub
fixme:msvcp:_Locinfo__Locinfo_ctor_cat_cstr (0x33f8c4 1 C) semi-stub
fixme:ver:GetCurrentPackageId (0x33fbf0 (nil)): stub
fixme:module:load_library unsupported flag(s) used (flags: 0x00000800)
fixme:advapi:RegisterTraceGuidsW (0x594c91, (nil), {f7b697a3-4db5-4d3b-be71-c4d284e6592f}, 7, 0x61be34, (null), (null), 0x6225b8): stub
fixme:process:GetNumaHighestNodeNumber (0x33d800): semi-stub
err:wincodecs:PngDecoder_CreateInstance Failed reading PNG because unable to find libpng12.so.0
fixme:ole:CoCreateInstance no instance created for interface {9edde9e7-8dee-47ea-99df-e6faf2ed44bf} of class {389ea17b-5078-4cde-b6ef-25c15175c751}, hres is 0x80004005
fixme:ver:GetCurrentPackageId (0x19aea08 (nil)): stub
fixme:module:load_library unsupported flag(s) used (flags: 0x00000800)
fixme:advapi:RegisterTraceGuidsW (0x6d11d0, (nil), {f7b697a3-4db5-4d3b-be71-c4d284e6592f}, 7, 0x7bb094, (null), (null), 0x7c6cf0): stub
fixme:process:GetNumaHighestNodeNumber (0x33d860): semi-stub
fixme:process:SetProcessDEPPolicy (3): stub
fixme:heap:HeapSetInformation (nil) 1 (nil) 0
fixme:ntdll:NtIsProcessInJob stub: 0xffffffff (nil)
fixme:imm:ImmDisableTextFrameService Stub
fixme:thread:GetThreadPreferredUILanguages 56, 0x33f1f0, (nil) 0x33f1ec
fixme:winsock:WSALookupServiceBeginW (0x33f1b0 0x00000ff0 0x33f1f8) Stub!
fixme:iphlpapi:NotifyAddrChange (Handle 0x33f1b0, overlapped 0x181888): stub
fixme:win:RegisterDeviceNotificationW (hwnd=0x10056, filter=0x33f218,flags=0x00000000) returns a fake device notification handle!
fixme:win:RegisterDeviceNotificationW (hwnd=0x10056, filter=0x33f218,flags=0x00000000) returns a fake device notification handle!
fixme:win:EnumDisplayDevicesW ((null),0,0x33e118,0x00000000), stub!
fixme:ver:GetCurrentPackageId (0x395e210 (nil)): stub
fixme:ver:GetCurrentPackageId (0x33eb84 (nil)): stub
fixme:wtsapi:WTSRegisterSessionNotification Stub 0x1006a 0x00000000
fixme:msctf:InputProcessorProfileMgr_GetActiveProfile (0x213998)->({34745c63-b2f0-4784-8b67-5e12c8701a31} 0x33eec0)
fixme:ole:RemUnknown_QueryInterface No interface for iid {00000019-0000-0000-c000-000000000046}
fixme:advapi:RegisterTraceGuidsW (0x10117770, 0x12742800, {3dada31d-19ef-4dc1-b345-037927193422}, 1, 0x1272d1e8, (null), (null), 0x12742818): stub
fixme:toolhelp:CreateToolhelp32Snapshot Unimplemented: heap list snapshot
fixme:toolhelp:Heap32ListFirst : stub
fixme:ver:GetCurrentPackageId (0x19aea08 (nil)): stub
fixme:module:load_library unsupported flag(s) used (flags: 0x00000800)
fixme:advapi:RegisterTraceGuidsW (0x6d11d0, (nil), {f7b697a3-4db5-4d3b-be71-c4d284e6592f}, 7, 0x7bb094, (null), (null), 0x7c6cf0): stub
fixme:process:GetNumaHighestNodeNumber (0x33d860): semi-stub
fixme:process:SetProcessDEPPolicy (3): stub
fixme:heap:HeapSetInformation (nil) 1 (nil) 0
fixme:ntdll:NtIsProcessInJob stub: 0xffffffff (nil)
fixme:advapi:RegisterTraceGuidsW (0x10117770, 0x12742800, {3dada31d-19ef-4dc1-b345-037927193422}, 1, 0x1272d1e8, (null), (null), 0x12742818): stub
fixme:gdi:GdiInitializeLanguagePack stub
fixme:module:load_library unsupported flag(s) used (flags: 0x00000800)
fixme:ver:GetCurrentPackageId (0x30eea08 (nil)): stub
fixme:ntdll:NtLockFile I/O completion on lock not implemented yet
fixme:ntdll:NtIsProcessInJob stub: 0x364 (nil)
fixme:ntdll:NtIsProcessInJob stub: 0x364 (nil)
fixme:ntdll:NtIsProcessInJob stub: 0x364 (nil)
fixme:ntdll:NtIsProcessInJob stub: 0x364 (nil)
fixme:ntdll:NtIsProcessInJob stub: 0x364 (nil)
fixme:ntdll:NtIsProcessInJob stub: 0x364 (nil)
fixme:ver:GetCurrentPackageId (0x411dc84 (nil)): stub
fixme:ntdll:NtIsProcessInJob stub: 0x364 (nil)
fixme:ntdll:NtIsProcessInJob stub: 0x364 (nil)
fixme:ntdll:NtIsProcessInJob stub: 0x364 (nil)
fixme:ntdll:NtIsProcessInJob stub: 0x364 (nil)
fixme:wtsapi:WTSUnRegisterSessionNotification Stub 0x1006a
fixme:win:UnregisterDeviceNotification (handle=0xcafeaffe), STUB!
fixme:win:UnregisterDeviceNotification (handle=0xcafeaffe), STUB!
fixme:iphlpapi:CancelIPChangeNotify (overlapped 0x181888): stub
fixme:advapi:UnregisterTraceGuids 0: stub
fixme:sync:SetWaitableTimerEx (0xc4, 0xe4e950, 0, (nil), (nil), (nil), 500) semi-stub
fixme:ole:RemUnknown_QueryInterface No interface for iid {00000019-0000-0000-c000-000000000046}
fixme:lsa:LsaGetLogonSessionData 0x33e3a8 0x33e3b8 stub
err:wgl:wglFinish wglFinish
fixme:win:EnumDisplayDevicesW ((null),0,0x33e6e8,0x00000000), stub!
fixme:win:EnumDisplayDevicesW ((null),0,0x33d7bc,0x00000000), stub!
fixme:ntdll:server_ioctl_file Unsupported ioctl 28000017 (device=2800 access=0 func=5 method=3)
fixme:winsock:server_ioctl_sock Unsupported ioctl 28000017 (device=2800 access=0 func=5 method=3)
fixme:winsock:WSAIoctl unsupported WS_IOCTL cmd (_WSAIO(IOC_WS2, 23))
fixme:ntdll:server_ioctl_file Unsupported ioctl 28000017 (device=2800 access=0 func=5 method=3)
fixme:winsock:server_ioctl_sock Unsupported ioctl 28000017 (device=2800 access=0 func=5 method=3)
fixme:winsock:WSAIoctl unsupported WS_IOCTL cmd (_WSAIO(IOC_WS2, 23))
fixme:imm:ImmReleaseContext (0x2007a, 0x98f76e0): stub
fixme:ras:RasEnumConnectionsW (0x119220,0xc36d258,0x6305fe34),stub!
fixme:ras:RasEnumConnectionsW RAS support is not implemented! Configure program to use LAN connection/winsock instead!
fixme:service:EnumServicesStatusW resume handle not supported
fixme:ras:RasEnumEntriesW ((nil),(null),0x98db618,0xc36da88,0x98aa124),stub!
fixme:ras:RasEnumConnectionsW (0x119220,0x7a2d258,0x6305fe34),stub!
fixme:ras:RasEnumConnectionsW RAS support is not implemented! Configure program to use LAN connection/winsock instead!

 

BloodyDeed Saturday 6 September 2014 at 17:21
BloodyDeedAnonymous

I also have the same problem. Already tried multiple versions of Wine, running Arch x86_64. lib32-gnutls is installed.

xpander Sunday 7 September 2014 at 21:31
xpander

same here with Arch x86_64 ... lib32-gnutls installed..tryed downgrading to different older versions as well.. no go.. 

 

edit: managed to get it working by setting POL to use system wine (1.7.26) and installing wininet
the launcher/patcher crashes though..but you can quickly press launch before it crashes... 

Edited by xpander

avojevlavo Monday 8 September 2014 at 16:55
avojevlavoAnonymous

edit: managed to get it working by setting POL to use system wine (1.7.26) and installing wininet
the launcher/patcher crashes though..but you can quickly press launch before it crashes... 

didnt work for me :(

can you please post your debug log from lol?

Ronin DUSETTE Monday 8 September 2014 at 21:45
Ronin DUSETTE
Admin

Looks like you are missing a 32 bit library:

 

err:wincodecs:PngDecoder_CreateInstance Failed reading PNG because unable to find libpng12.so.0
 

 It is looking for libpng12.so.0 and it is not finding it. Make sure that libpng and lib32-libpng are installed (you will have to enable the multilib repo, if you have not done so.). At least that looks like the problem to me. 


Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
jgreen Tuesday 9 September 2014 at 18:09
jgreenAnonymous

>edit: managed to get it working by setting POL to use system wine (1.7.26) and installing wininet the launcher/patcher crashes though..but you can quickly press launch before it crashes... 

I want to confirm that this worked for me too. thank you kind sir! Though Opening the shop ingame causes the game to crash. could anyone tell me which log I should look through to find what's causing the crash?

edit: seems like I had to apply this patch to wine http://pastebin.com/Nqj1f0z0

Edited by jgreen

Ronin DUSETTE Wednesday 10 September 2014 at 6:51
Ronin DUSETTE
Admin

So, you recompiled with those patches Wine and installed that into your system? Does it seem like you had to add it, or did you actually have to add it? hahaha. :)


Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
xpander Wednesday 10 September 2014 at 8:30
xpander

shop patch is not needed for wine if you run with x3d_platform=1 in the ~/Config/game.cfg

jgreen Wednesday 10 September 2014 at 12:09
jgreenAnonymous

>So, you recompiled with those patches Wine and installed that into your system? Does it seem like you had to add it, or did you actually have to add it? hahaha. :)
If compiling isn't your preference. 
this worked fine too: https://github.com/A-Metaphysical-Drama/LoL-Linux-Tools/
it's no longer being maintained but it still works.

>shop patch is not needed for wine if you run with x3d_platform=1 in the ~/Config/game.cfg

I was not aware of that. I'll add this change and see how it goes without having me patching it in the future.

 

k0ve Monday 15 September 2014 at 9:27
k0veAnonymous

Sorry where do you need to add the x3d_platform=1?

 

I'm very new to wine and cannot find the ~/Config/game.cfg location.

somaasd Friday 10 October 2014 at 23:04
somaasdAnonymous

you find game.cfg under ~/.PlayOnLinux/wineprefix/LeagueOfLegends/drive_c/Riot Games/League of Legends/Config/game.cfg => there are section in this file, you need to add this to the seciont [General]

I've had the same issue, ended up using "System" wine, because all mentioned wine versions had the OPs issue for me.

After using "System" wine, I had the problem with the in-game shop crashing the game. After adding x3d_platform=1 there is no crash, however no in-game shop as well. Its kinda weird, because there is an active click-able region, I can even buy items, just the shop template does not get rendered. Any ideas?

 

Diamond Saturday 11 October 2014 at 10:50
DiamondAnonymous

I tried a lot of versions of wine. Result is always crashing when I try to open the in-game shop. I tried also adding "x3d_platform=1" to game.cfg but it resulted in a no in-game windows - I press the shop button or "P" but no window appears. Shall I publish debug report?

somaasd Saturday 11 October 2014 at 12:05
somaasdAnonymous

so I've got mine working as well, just putting the results maybe helps someone:                                                                                                         
- I'm on 3.16.4-1-ARCH with a VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09)                                                          
- every specific wine version had either the connection retry problem or the GNUTLS publickey decryption error                                                                          
                                                                                                                                                                                        
After choosing the "System" wine I've managed to log into the game. however when getting ingame the ingame-shop caused the game to crash.                                               
                                                                                                                                                                                        
After adding "x3d_platform=1" to game.cfg, it was not crashing, but the shop GUI was "invisible".                                                                                       
                                                                                                                                                                                        
I've installed https://github.com/A-Metaphysical-Drama/LoL-Linux-Tools/, and used the texture_patch script however the ingame-shop was still invisible.                                 
                                                                                                                                                                                        
Finally removing "x3d_platform=1" the shop was visible and there was no crash.                                                                                                          
                                                                                                                                                                                        
I've read up on the "x3d_platform=1". It is a hidden flag for the game config, to use OpenGL. The default value for this is 0, which means directX and the value 2 is software-renderer.

Вы находитесь здесь: Index > PlayOnLinux > League of Legends