Форум

How the get the game at the right size for my screen?

Автор Replies
Cocio_16 Monday 15 December 2014 at 1:01
Cocio_16Anonymous

It is a problem that I have with a lot of games.

For example, I play Starcraft Brood War. The game works fine and full screen. That's good. The problem is that when I put my cursor at the button or the right of the screen, instead of moving on the map of the game, the image on my screen move to my desktop. It looks like a big desktop bigger than my screen, and the game working at the top left.

Some people suggest on the Internet to go in Configure, Wine, Configure Wine, Graphics, and then "Emulate a virtual desktop". Which I tried in various resolutions. I always get the game working in a window in the middle my desktop, everything in proper proportion. Which means the game is too small to play properly. I can’t find how to adjust the size of that window.

 

Help please ?

booman Monday 15 December 2014 at 21:23
booman

The virtual desktop is the best solution.  It handles the mouse and resolution in most games.

The trick is to match your game resolution to your Linux desktop resolution.

Example:

  • Linux desktop 1920x1080
  • Virtual desktop 1024x768 (can be any resolution)
  • Launch game and set resolution in video option to 1920x1080

Now your game should appear fullscreen and handle the mouse override.
This works for 90% of my games.  There are still a few games where your character won't turn completely around 360 degrees until you click on the screen somewhere.


† Booman †
Mint 19 64-bit | Nvidia 415.25 | GeForce GTX 1060
Linux for Beginners | List of Linux Games | My Games
PlayOnLinux Guides | PlayOnLinux Explained