Вы находитесь здесь

Форум

Mass Effect 1 steam version and bumblebee

Автор Replies
cripplebeast Wednesday 27 May 2015 at 9:17
cripplebeastAnonymous

Debug Log:

[05/27/15 19:06:07] - Running wine-1.7.33 Steam.exe (Working directory : /home/tom/.PlayOnLinux/wineprefix/Steam/drive_c/Program Files/Steam)
[0527/190608:ERROR:network_change_notifier_win.cc(173)] WSALookupServiceBegin failed with: 8
primus: warning: recreating incompatible pbuffer
[0527/190614:ERROR:renderer_main.cc(212)] Running without renderer sandbox
[0527/190614:ERROR:renderer_main.cc(212)] Running without renderer sandbox
primus: warning: recreating incompatible pbuffer

 

I'm using a dell xps 17 with an nvidia geforce 555m using nvidia optimus technology

I can play Mass Effect 1 fine on the intel card

I can play League of Legends, Mass Effect 2, Mass Effect 3 and others on the nvidia card

 

When I try to launch Mass Effect 1 from inside steam using primusrun I hear my fan spool up and steam says its preparing to launch Mass Effect, then nothing happens. If I try to launch again, it says its already running.

If I launch Mass Effect 1 from inside steam without using primusrun/optirun then the game works ok, but I have to turn down all my graphics settings.

This is a wineprefix for steam, the same one I use to run Mass Effect 2 on my nvidia card without any issues.

I'm at a loss for what to do next other than settle for playing on the intel card. Does anyone have any suggestions?

 

I also notice that clicking a link inside Mass Effect 1, 2 or 3 that should open a web page, opens the page in the native linux default browser (firefox in my case) and causes the game to freeze, this is unrelated, just thought I'd whack it on the end here

 

Edit: Ubuntu 15.04 64-Bit

Edited by cripplebeast

Ronin DUSETTE Wednesday 3 June 2015 at 2:42
Ronin DUSETTE
Admin

Try switching the Wine version in the Virtual Drive to a newer version. Steam is broken for older versions of Wine, and the ME scripts may be using older versions. You can download/install the newest version of Wine from Tools -> Manage Wine Versions, then switch it in the General tab of the Configure Window. You should also make sure that you have the newest drivers installed, and that you also have the 32-bit libraries installed for your graphics card, too.

If that doesn't work, you can try a -staging version of Wine from Manage Wine Versions and enable CSMT via winecfg in the Wine tab of the Configure window.


Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
Вы находитесь здесь: Index > PlayOnLinux > Mass Effect 1 steam version and bumblebee