Вы находитесь здесь

Форум

Diablo 3

Which components do I need?

Автор Replies
GunnDawg Wednesday 17 June 2015 at 18:13
GunnDawgAnonymous

I installed the Battle.net launcher, launched it and installed Diablo 3. When I launch Diablo 3 I have nothing but a black screen. I suspect I am missing a component from the "Installed Components" tab. So far I have installed d3dx9, vcrun2005, and vcrun2008. Which others am I missing?

Arch Linux Kernel: 4.0.5-1

Nvidia GTX 760 Driver: 352.21

PoL Version: 4.2.8

Wine Version: 1.7.45

Ronin DUSETTE Wednesday 17 June 2015 at 18:34
Ronin DUSETTE
Admin

You should probably delete that virtual drive and install it from the Install Menu in POL, instead of doing a manual install. That should take care of anything that is needed for the game. You also need to make sure that you are running the proprietary graphics drivers, as well as the lib32 graphics libs for your card. That may be the problem right there. 


Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
GunnDawg Wednesday 17 June 2015 at 18:39
GunnDawgAnonymous

Indeed that fixed the issue. I installed it from the Install Menu and launched without issue. Not sure why I decided to do a manual isntall anyways. Thanks.

Ronin DUSETTE Wednesday 17 June 2015 at 18:50
Ronin DUSETTE
Admin

No problem. Glad it worked. :D


Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
GunnDawg Wednesday 17 June 2015 at 19:03
GunnDawgAnonymous

Looks like I spoke to soon. With the install menu installation I get the Diablo 3 cursor and background music but just a black screen to go with it. No menu.

Looks like its using wine version 1.7.15

Edited by GunnDawg

Ronin DUSETTE Wednesday 17 June 2015 at 19:08
Ronin DUSETTE
Admin

Can you post your full debug log, please? You may want to try to disable GLSL in the Display tab, as well. I am not sure if that will help; without logs it is a guess (though this one is more than just a guess, but I never have that problem with Nvidia cards. Just Intel.). Again, make sure that you have all of the 32-bit libs for your graphics drivers installed, too. 


Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
GunnDawg Wednesday 17 June 2015 at 19:14
GunnDawgAnonymous

Turns out the PoL install of Diablo 3 didnt install D3dx9. I manually added that and it launches normal. Wonder why it didnt do that for me.

Ronin DUSETTE Wednesday 17 June 2015 at 19:23
Ronin DUSETTE
Admin

d3dx is not always needed (the script didn't install it, because when it was written it worked fine, so it could be a number of different issues); Wine implements it's own, but sometimes the native one is working... can't really tell without logs, but hey, if it is working, it's working. If more people report that it is needed, then we can add that dependency in. 

Though, in the future, please try and work with us (debug logs need to be posted in the first post of your thread) instead of jumping ahead. You pretty much disregarded what I asked for, which makes it hard to help, let alone figure out what the problem is; it's cool that you got it working, but when we ask for something to troubleshoot, we need it (it helps us improve the scripts by getting the feedback and data that we need to effectively troubleshoot the problem). As of right now, you basically took a guess instead of trying what I suggested first, and even though it fixed it, if it didn't, that just adds to the time that we have to troubleshoot. It helps us help you. :)

Edited by RoninDusette


Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
GunnDawg Wednesday 17 June 2015 at 19:31
GunnDawgAnonymous

I understand, my appologies for jumping ahead. That being said would installing D3dx10 or higher improve performance over D3dx9 or change anything?

Ronin DUSETTE Wednesday 17 June 2015 at 19:34
Ronin DUSETTE
Admin

No. You may want to try the CSMT patch along with making sure that your drivers are the proprietary drivers, up-to-date, and with 32-bit libs installed. CSMT may or may not work, but when it does, it usually gives a pretty hefty increase in performance. 


Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
Вы находитесь здесь: Index > PlayOnLinux > Diablo 3