Форум

Blizzard Games - Wine secondary Logon Service

Автор Replies
set_me_free Friday 11 September 2015 at 2:08
set_me_freeAnonymous

Hello!

I've been running sc2 and hearthstone for almost 2 years now running playonlinux without any problems. Recently when I try to start the games, the Battle.net app says:

"Battle.net requires the Windows Secondary Logon service to be enabled". Please click the error code below for instructions on enabling it."

https://eu.battle.net/support/en/article/BLZBNTAGT00000A29

I've tried to google the subject, some say it can be alleviated by mouting the install CD, but i don't see how that helps with hearthstone?!

I tried to enable the service in wine, but realized it doesnt exist. The barebone windows of wine doesnt have services.msc and if you look at the list of services in regedit, the secondary logon service isnt included.

Can anyone help me to get the games running again? I tried reinstalling hearthstone and that didnt help :/

 

danielkza Friday 11 September 2015 at 13:41
danielkzaAnonymous

I just started seeing the same issue today, it's likely it was caused by a Battle.net update.

gkanos Friday 11 September 2015 at 16:47
gkanosAnonymous

I have the same issue since yesterday!

YabosMcGee Friday 11 September 2015 at 16:47
YabosMcGeeAnonymous

I just came here to see if anyone has seen this issue before. It just started for me today as well. What's weird is I was able to enter my password in Battle.net, and get to the Hearthstone page. I was even able to connect to the European Hearthstone servers. But, when I backed out and tried to connect to the Americas servers, it wouldn't do anything. After closing and reopening Playonlinux, then trying to start Battle.net, I also get the "Windows secondary logon service" error. 

What's interesting to note is when I did a search online regarding this error and Wine is that some users in the Battle.net forums reported the same issue over a year ago. So, maybe it will go away on its own?

 

gkanos Friday 11 September 2015 at 16:54
gkanosAnonymous

I don't bet on it because now you cannot get new updates from battlenet to change the problem by luck

YabosMcGee Friday 11 September 2015 at 19:02
YabosMcGeeAnonymous

It's not luck, I'm pretty sure it's just that Battle.net needs to update in Wine. I've seen it update when launching before, so I know it can be done by the Battle.net client itself running in Wine. 

YabosMcGee Friday 11 September 2015 at 19:49
YabosMcGeeAnonymous

Just a heads-up: For some reason, if I hit "debug" in Playonlinux instead of "run" it brings up the Battle.net login screen and lets me log in. It then lets me launch Hearthstone. I can then quit Hearthstone, close Battle.net, then hit "run" in Playonlinux and it launches fine. 

gkanos Friday 11 September 2015 at 20:13
gkanosAnonymous

I verify this solution works!

set_me_free Friday 11 September 2015 at 22:08
set_me_freeAnonymous

I just tried starting both Sc2 and hearthstone with the debug button, still get the same secondary logon error message :/

anyone got any ideas?

Edited by set_me_free

Simplicity Saturday 12 September 2015 at 2:12
SimplicityAnonymous

In my case using stock wine-1.6.2 I had to enter winecfg and change the library dbghelp from "disabled" to "native" and it opened right up.. in the past it wouldnt open without it disabled so it is likeley that this is the configuration playonlinux is still using. 

palintropos Saturday 12 September 2015 at 3:43
palintroposAnonymous

 

In my case using stock wine-1.6.2 I had to enter winecfg and change the library dbghelp from "disabled" to "native" and it opened right up.. in the past it wouldnt open without it disabled so it is likeley that this is the configuration playonlinux is still using. 

 

While you are correct about Playonlinux's configuration, I'm sorry to report that this fix also did not work at least for me. You can mimic this configuration in Playonlinux by selecting your Battle.net install, clicking the Configure button, and clicking "Configure Wine" under the WINE tab. From there go to Libraries, and you should see an exception for *dbghelp (disabled). Highlight it and click Edit. Changing it to any other state did not work for me, even if I downloaded Wine 1.6.2 and switched my Playonlinux config to that.

dashdashbang Saturday 12 September 2015 at 13:15
dashdashbangAnonymous

1) Launch Battle.net

2) Leave the window with the error message open

3) Launch Battle.net again

It's a strange workaround, but it worked for me every time so far.

davemint Saturday 12 September 2015 at 17:04
davemintAnonymous

 

1) Launch Battle.net

2) Leave the window with the error message open

3) Launch Battle.net again

It's a strange workaround, but it worked for me every time so far.

 

Works for me but I get a white Battlenet screen that does nothing. To play WoW I have to run WoW-64.exe directly. 

palintropos Saturday 12 September 2015 at 17:07
palintroposAnonymous

dashdashbang's solution does not work for me. I still do not get a Battle.net screen.

set_me_free Saturday 12 September 2015 at 23:00
set_me_freeAnonymous

 

1) Launch Battle.net

2) Leave the window with the error message open

3) Launch Battle.net again

It's a strange workaround, but it worked for me every time so far.

 

petch Wednesday 16 September 2015 at 12:00
petch
Developer

Вы находитесь здесь: Index > PlayOnLinux > Blizzard Games - Wine secondary Logon Service