Вы находитесь здесь

Форум

Star Trek Online Audio / Sound Issues

Автор Replies
Buford T. Justice Saturday 19 September 2015 at 20:01
Buford T. JusticeAnonymous

Ubuntu MATE 14.04.2 LTS, PlayOnLinux 4.2.9, and presently Wine 1.7.51.

AMD FX 6300 6-core CPU, AMD Radeon HD 7770 with 1 GB RAM, ALC887-VD sound, and 12.0 GBs RAM.

Star Trek Online loads and acts fairly normal whether I do it with Steam installed to PlayOnLinux or with just the game itself using these directions:

http://www.gamersonlinux.com/forum/threads/star-trek-online-guide.242/

Graphics seems to be fairly fluid which is good, but the problem I am experiencing is with sound.  If I add mmdevapi to the Libraries in Wine and disable it, I get no sound at all in the game.  Without it, I do have sound.  Most of the time, it is garbled / distorted though.  Sometimes it does clear up and sounds like it should.

Is there a setting I am overlooking that would clean the sound up?

Edited by Buford T. Justice

booman Tuesday 29 September 2015 at 21:24
booman

Try installing Star Trek Online from the PlayOnLinux supported installer first.

You should post on their forum since you followed an un-supported manual installation.

If you hear garbled or crackling sound its probably Alsa & Pulseaudio fighting.
Try running the game by clicking "Debug" instead of "Run"

If you see a whole bunch of "buffer underrun" errors then its definitely Alsa fighting with Pulseaudio


† Booman †
Mint 19 64-bit | Nvidia 415.25 | GeForce GTX 1060
Linux for Beginners | List of Linux Games | My Games
PlayOnLinux Guides | PlayOnLinux Explained
Buford T. Justice Friday 2 October 2015 at 16:48
Buford T. JusticeAnonymous

Yes several "buffer underrun" errors about ALSA.  Is there a way to set it to use PulseAudio instead?  Or is there a way to disable PulseAdio so ALSA works?

booman Friday 2 October 2015 at 17:14
booman

Wine doesn't support Pulseaudio so you only have two options...

#1

There is one file you should edit as root, so open a terminal and type:
 

Code:
sudo nano /etc/pulse/daemon.conf

Just scroll to the end of the file. Don't change anything in this file, just add one line at the end:
 

Code:
default-fragment-size-msec = 5

Save the file and exit. Then just type the following command to restart PulseAudio:
 

Code:
pulseaudio -k && pulseaudio --start

#2

Remove Pulseaudio - Not recommended 


† Booman †
Mint 19 64-bit | Nvidia 415.25 | GeForce GTX 1060
Linux for Beginners | List of Linux Games | My Games
PlayOnLinux Guides | PlayOnLinux Explained
Buford T. Justice Saturday 3 October 2015 at 1:58
Buford T. JusticeAnonymous

I did the edit and it seemed like it was going to work, but the garbled sound returned.

ALSA lib pcm.c:7843:(snd_pcm_recover) underrun occurred

Edited by Buford T. Justice

booman Monday 5 October 2015 at 18:15
booman

I have experienced that as well.  Is this ALC887-VD sound a dedicated sound card?
Or are you using sound through your video card HDMI?

I was using a Sound Blaster Audigy on one of my computers and Wine/Games kept fighting with Pulseaudio.  I couldn't get it fixed, so I had to yank the card an now it works fine.

You could always uninstall Pulseaudio, but you don't be able to use the audio controls in Ubuntu.  Instead you have to use Terminal and type:  alsamixer


† Booman †
Mint 19 64-bit | Nvidia 415.25 | GeForce GTX 1060
Linux for Beginners | List of Linux Games | My Games
PlayOnLinux Guides | PlayOnLinux Explained
Buford T. Justice Monday 5 October 2015 at 18:41
Buford T. JusticeAnonymous

It is onboard Realtek HD Audio.  My AMD video card has HDMI sound.  I'd hate to uninstall Pulse, but I might have to if there are no other things to try in order to get the sound working in STO full-time.

booman Monday 5 October 2015 at 19:20
booman

I You can disable the HDMI but you shouldn't have to.
Try restarting your computer after you made that daemon.conf change


† Booman †
Mint 19 64-bit | Nvidia 415.25 | GeForce GTX 1060
Linux for Beginners | List of Linux Games | My Games
PlayOnLinux Guides | PlayOnLinux Explained
Buford T. Justice Saturday 17 October 2015 at 6:35
Buford T. JusticeAnonymous

Did all of that and still the audio sucks in this game with Wine :(

booman Monday 19 October 2015 at 18:48
booman

UGH, its really getting old that Wine doesn't support Pulseaudio
I can only suggest two other things:

  1. Upgrade to the newest Pulseaudio
  2. Uninstall Pulseaudio

Open Terminal with Ctrl+Alt+T

Type:  pulseaudio --version

What version are you running in Ubuntu right now?

Upgrading might be a totall pain and could possible break things.
I'm using Pulseaduio 4.0 in Mint 17.2 which is based on Ubuntu 14.04, so there is a newer version of Pulseaudio, but I have never gone through the steps before.

Uninstalling Pulseaudio will definitely break your volume controls.  You will have to use:  alsamixer to adjust volumes, which really sucks because it will affect everything on your system.  Your Ubuntu graphical volume controls are tied to Pulseaudio.

Either way it is a risk, but might fix your PlayOnLinux/Wine gaming experiences.  If you only play games and don't do a alot of video/audio editing then you will probably be fine.

I recommend researching it first before actually upgrading or uninstalling.

Sorry man, troubleshooting is never easy, but you will always learn something new


† Booman †
Mint 19 64-bit | Nvidia 415.25 | GeForce GTX 1060
Linux for Beginners | List of Linux Games | My Games
PlayOnLinux Guides | PlayOnLinux Explained
Buford T. Justice Wednesday 21 October 2015 at 7:59
Buford T. JusticeAnonymous

I'm on the same--PulseAudio 4.0.

booman Wednesday 21 October 2015 at 18:23
booman

That figures

Well if you are desperate enough to remove Pulseaudio or upgrade, I would post on the Ubuntu forums to get some expert help.  I don't know how to troubleshoot if it causes more problems


† Booman †
Mint 19 64-bit | Nvidia 415.25 | GeForce GTX 1060
Linux for Beginners | List of Linux Games | My Games
PlayOnLinux Guides | PlayOnLinux Explained
Вы находитесь здесь: Index > PlayOnLinux > Star Trek Online Audio / Sound Issues